Question about OKI MICROLINE 520 Matrix Printer

1 Answer

Oki 520 missing print

Hi, the problem I have with my printer is that when it prints it never never prints the top line of dots, so when I print something off it never prints the top of the letters. ie.. if it was to print the letter T it would look or like an I. I have replaced the print head and ribbon, any ideas what might be causing this.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 5 achievements.


    An expert who has written 50 answers of more than 400 characters.


    An expert who has answered 200 questions.

  • Expert
  • 254 Answers
Re: Oki 520 missing print

You have replaced the item which is commonly the cause- the printhead. The other possible problems are: a connection break in the printhead ribbon cable, which makes electrical connection from the driver circuitry to the printhead. Look for a tiny crack, especially along the edge of this ribbon cable. Another possibility is an electronic component defect in the circuitry which fires the printhead, or maybe a loose solder connection in the same circuit. Lastly, when you replaced the printhead, are you reasonably certain the replacement head didn't have a broken top pin or two?

Posted on Apr 10, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

How to printer test page a oki 520

Go to Start / printers and faxes / Right click on print icon / properties / print test page.

Feb 17, 2010 | OKI MICROLINE 520 Matrix Printer

3 Answers

Oki Microline 520 printing slow

Your printhead alignment is out thats why it prints slow

Jul 17, 2008 | OKI MICROLINE 520 Matrix Printer

1 Answer

Sugest my problem

Will printing 4 lables and then will skip 4 lines and then print again

Mar 23, 2008 | OKI MICROLINE 320 Turbo Matrix Printer

1 Answer


Kindly check the DPI settings . May be more DPI this time.

Best Regards

Feb 19, 2008 | OKI MICROLINE 520 Matrix Printer

2 Answers

Oki microline 590 elite

What driver are you using for this printer? Try loading a Epson LQ1050 driver and try again.

Dec 12, 2007 | OKI MICROLINE 520 Matrix Printer

1 Answer

Printing problem with Star Sp200

Seems like a problem with the printer head...It is usual for matrix printers and it happens due to wear and tear..You will have to get the printing head to get replaced..

Oct 27, 2007 | Star Micronics SP 2000 Matrix Printer

2 Answers

Double Printing

check the printer drvier properties and make sur the defaulf is not set to print 2 copies.

Jun 14, 2007 | OKI MICROLINE 520 Matrix Printer

Not finding what you are looking for?
OKI MICROLINE 520 Matrix Printer Logo

209 people viewed this question

Ask a Question

Usually answered in minutes!

Top OKI Printers & Copiers Experts


Level 3 Expert

1113 Answers


Level 1 Expert

38 Answers

Dominion Computer...
Dominion Computer...

Level 2 Expert

269 Answers

Are you an OKI Printer and Copier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides