Question about Kenwood VR-6050 Receiver

1 Answer

Display Lights The display on my receiver keeps going out. The display turns on sometimes, but not all the time. I tried resetting the unit. Does it have something to do with the dimmer?

Posted by on

1 Answer

Re: Display Lights

Send it in to kenwood wirth it the damn thing got power tords it lol i got it pushing 200 wattsx5 with a power esp

Posted on Jun 25, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Denon AVR-3801 lights up,makes rapid clicking noises when amp tries to turn on. Clicking stops but unit doesn't play & sometimes the unit turns off. Occurred after lightning storm. What to do to fix?

Probably damaged by power surge. If you do not have experience diagnosing and repairing electronic circuits as well as having access to schematic diagrams then this is not a repair for you. Failure to replace all damaged components may result in damaging new parts.

Aug 16, 2016 | Denon Avr-3801 7.1 Home Theater Surround 7...

1 Answer

Receiver displays "protect" ...then shuts off

From what I have seen..........

Either you have a speaker that is shorting out, Try unplugging on speaker at a time and turning the unit on, and see if it goes out of protected mode. Keep the volume turned low while doing that. Just go by process of elimination. Or you can disconnect all speakers and see if you still get the error message. If not then connect 1 speaker at a time, if it goes in to protected mode while doing a speaker connection then you found the bad speaker.

Otherwise another thing I read a hard reset you should be able to do on the unit is hold down the power button until it display a message that says "Clear All", then hit enter or follow the directions it gives that should reset the alarm code if the receiver will allow it.

Hopefully one of those 2 things will clear your error........

Best I could find out

I would do the speaker test first, usually its a shorted speaker or wire

Aug 25, 2013 | Sony Audio & Video Receivers

1 Answer

NAD T763 - i turned it on and all the lights on the display lit up and stay on. It doesn't work at all !! Any suggestions?

Have you tried doing a factory reset?

1. With unit powered ON, press the VIDEO and TONE DEFEAT buttons.
2. Display will show "AH RESET DONE".
3. Power off (from rear panel switch) and back on.

Jan 29, 2011 | NAD T763 Receiver

1 Answer

I just turn off my Sony Walkman ,and then the screen display :Power Off.but its not completely off ,the words: Power Off still display on the screen

Remove off the battery for sometime and keep off for sometime.
Later reset the batery and test, if the fault recurrs then it is possible that the mP is not resettting. try and see for any errors in the board, remove and clean.

Sep 23, 2010 | Audio & Video Receivers

1 Answer

TX-DS656 - No display, still works.

Mine goes out sometimes, if I go to the reciever and hit the "Display" butoon, the display lights up dim, at same time, I hit the " Dimmer" botton on remote and display works for about 1-2 weeks. Don't know what is cuasing it, but that got the dispaly to work. Can deal with that I guess.

Sep 02, 2010 | Onkyo TX-DS656 Receiver

1 Answer

MOTU 828MK3 led's flash then no lights do they have a switching power supply ?? Any one have a diagram of the unit

I have a MOTU 828 MK3 and have had trouble with the display lights not working on one of my units. I tried the unplugging and switching from 120 to 220 and back. Sometimes when I started it up it would come on and quickly go off or not even come on at all. I was using the unit by reading the numbers using a flashlight. One day I noticed the light undulating as if trying to come on and I just rubbed my finger over the light as if to try and coax it to come on. The next time I turned the unit on the light came on and stayed lit for the entire session. The light has only gone out one time since, after many sessions. The time it went out, I just rubbed the top of a finger over the display and it came on the next time the unit was started. I now make a habit of rubbing it every time I turn it on. It has not failed since. Sounds funny as it might just be my karma, but I think it more likely that it works because of a slight static charge that I create with the light rubbing of my finger. Just thought you might like to know. Doc Mason

Nov 06, 2009 | Audio & Video Receivers

2 Answers

Firmware upgrade failure

Try this for the reset
First turn the unit off then
hold down the "Pure Direct" and the "Direct" buttons on the display at the same time. And while you are still holding them down turn the unit on with the power button on the display.
this should reset the microprocessor.

You will need to put all custom settings back in.

Let me know if this helps.


Jun 06, 2008 | Denon AVR-3805 Receiver

1 Answer

No sound or display but power

You may have toasted the amp. You cab try reseting the microprocessor by using the hard power button and the a b speaker buttons. turn the unit off using the power button. hold the a and b speaker buttons and while holding turn the unit back on. screen should flash a couple times. release a and b buttons. good luck

Nov 19, 2007 | Denon AVR-1707 Receiver

1 Answer

No receiver display lights

Hi ripper

The unit has a built in display dimmer, with a button to control the level of brightness from the display both on the remote, and the front panel.Try this


Nov 16, 2006 | Onkyo TX-SR601 Receiver

Not finding what you are looking for?
Kenwood VR-6050 Receiver Logo

Related Topics:

179 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Audio & Video Receivers Experts


Level 2 Expert

49 Answers


Level 1 Expert

28 Answers


Level 1 Expert

13 Answers

Are you a Kenwood Audio and Video Receiver Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides