Question about Rockford Fosgate 600.4 Car Audio Amplifier

1 Answer

RF Amp Hey you answered my question...I don't have my subs connected yet, would that cause the problem light to turn on??

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 15,935 Answers

Blown power supply, bad output on the rail. Switcher bad in the power supply. It is going into protection mode because it is seeing something it doesnt like. A service center / tech. will be the only place to repair. Its not a DIY type of repair.

Posted on Dec 27, 2008

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Rockford Fosgate P3002 stopped working


push down and up on your subs and see if they make a starching noise, if they do then they are blown. take a test light to the amp, on the power and the remote and see if it lights up. if it does then turn the amp down and with a small speaker plug it in to the speaker outs on the amp and see if it plays if not then your amp is bad.

Nov 26, 2013 | Rockford Fosgate Punch P3002 Car Audio...

1 Answer

Cadence 400 watt active sub green light on, no sound from the sub. whats wrong?




proceed according and fix it. However yi\ou must read the diode LED for diagnose. God bless you

Mar 26, 2013 | Exercise & Fitness

1 Answer

Hey i have a sony amp (600 watt xm-zr604) with 2 10"sub(sony xplod).when i raise the volume hight enough the amp go off(red light came on) what can i try


sounds as though (at high volumes) the amp thinks it has a short circuit. This may be caused by the way you have them connected.
Speakers have a resistance and amps needs a certain amount of resistance to function right (too little resistance = short circuit)
The way it works out for the speakers is, if the two are connected to one amp output channel, the amp will see half of the resistance of a single sub. (4 Ohms/sub amp sees 2 Ohms)
If the amp instructions say that it's 4 Ohms/channel then you need to use 1 channel for each sub.
Hope this has been some help.

May 07, 2011 | Sony Xplod 800W Class AB Bridgeable...

2 Answers

Amp worked fine one day and the next day i get nothing. the red light on the side is on but i dont get any sound. i took the subs that were wired on that amp and wired them on the other punch 800 i have...


did you check all fuses on amp and coming from battery power wire? also check the ground and rca cables connecting to the unit and make sure the remote wire (small blue wire) didnt come lose thats usualy a sign for the red light

Mar 26, 2011 | Rockford Fosgate Punch 800a2 Car Audio...

2 Answers

Hey i dont know to much about amps, but me and my friend (he knows a decent amount about amps) would plug the power into the amp and the green light would come on. Though when we plug it into the subs, the...


Are you connecting positive to positive and negative to negative from the sub to the amp? If so, try positive to positve (+) in the far left channel and then the negative to negative (-) on the far left channel to. If no luck do the same in the other channel with one sub at a time. Try one sub at a time, Dont try an connect 2 or more subs to one channel as this would cause the amp to go into protect mode (red light you describe). Usually the positive wire has either a line down the wire, writting on it or has a red seperate wire with it when wire end stripped to connect it. Hope this helps and please rate...

Mar 11, 2011 | Bazooka EL1500 Car Audio Amplifier

3 Answers

How do I hook up one sub to my rockford fosgate p3001 amp


Hey i have looked over many rockford manuals,(i own a 300.1 my buddy owns a 325.1) and for there mono(.1) amps there hooked together on the inside so channel A+ and B + are cencted on the inside the amp. So you ither hook one 2ohm sub to channel A or you can hook 1 4ohm subs to channel A and 1 4ohm sub to channel B. There 2ohm stable so any lower will eventualy burn the amp out.

Jan 08, 2010 | Rockford Fosgate P3001 Car Audio Amplifier

2 Answers

Hey i have 4 p1 10" subs and when i turn it up loud it shuts off what could be the problem


Your head unit and the amp are turning on at two different times. Go to Radio Shack or an electronic component retailer and ask for a small 500 to 1000 micro farad capacitor (about a half inch in size). Then connect the side of the capacitor with the line on it to the small remote turn on that is connected to your amp. Next shorten the lead of the other end of the capacitor and connect that lead to your amp where the wire was connected. This causes your amp to take longer to turn on and stops the annoying pop. Good luck.

Oct 09, 2009 | Crossfire Car Audio & Video

2 Answers

No sound protection light on.


Either blown subs, or bad amp.. Disconnect the subs, and try turning the amp on, if the amp is still in protect then your amp is bad, if the protect light goes off, then your subs are bad, or possibly wired at to low of an impedance, but I don't think that will trigger the protect on an Audiobahn amp.

Aug 21, 2009 | AudioBahn A2002T Car Audio Amplifier

1 Answer

Subwoofer Trouble


Turn the bass gain all the way down., Turn up your your volume on bass test song. Crank up the little box next to the steering wheel wide open . Now go gradually turn up the bass gain on the RF amp until you get distortion. Turn the gain down slightly. Now you can enjoy playing the bass from one end of the little boxes setting to the other without ovrloading your amp and subs. Open a can of whoopass on anyone who tries to crank up on your gain.

Nov 09, 2007 | Car Audio & Video

1 Answer

RF P3001 power problems


check your sub woofer connection if you have multiple subs the could be wired in a parallel or with has to many ohms that my cause it to not hit right and cause the amp to get really hot and cut in and out

Nov 15, 2006 | Rockford Fosgate P3001 Car Audio Amplifier

Not finding what you are looking for?

Open Questions:

See all Rockford Fosgate 600.4 Car Audio Amplifier Questions

Car Audio & Video Logo

Related Topics:

52 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rockford Fosgate Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Professor_V
Professor_V

Level 2 Expert

92 Answers

Robert Rankin

Level 2 Expert

338 Answers

Are you a Rockford Fosgate Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...