Question about Kenmore 54351 Dehumidifier

5 Answers

Runs for a couple of minutes and then stops

The dehumidifier seems to run fine for a few minutes and then it just stops. The bucket is not full and the auto shut off indicator light does not come on. If I remove the bucket and put it back in, the unit immediately starts to run again but will only run for a couple of minutes. Unplugging the unit and plugging it back in has no effect.

Posted by on

  • 3 more comments 
  • Anonymous Feb 19, 2008

    got the same problem with mine.

  • leonsarah Feb 29, 2008

    My kenmore dehumidifier 50 pints (model # 58054501700) would runs for 10-20min. then stopped. What causes this?

  • Anonymous Apr 25, 2008

    yeah, the same problem has happened to mine. it worked perfectly fine all summer last year, plugged it in this year, now that it is extremely humid. i cleaned the filter every few weeks last year, and the filter was clean when i plugged it in for this year, so i know the filter is not the culprit of the problem.   

  • Anonymous Apr 26, 2008

    The dehumidifier seems to run fine for a few minutes and then it just stops. The bucket is not full and the auto shut off indicator light does not come on. If I remove the bucket and put it back in, the unit immediately starts to run again but will only run for a couple of minutes. Unplugging the unit and plugging it back in has no effect.

  • ctown955124 Sep 26, 2008

    Same problem. Does anyone else notice if the red button on the inside behind the bucket seems lose? We are thinking that may be the problem (with the lever not working with the button right).

×

Ad

5 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Try cleaning out the air filter using cold water. I did not even know the unit had one until I had the same problem. Pull out the bucket. The filter is located where the front top edge of the bucket would be located if it were in the instrument. Remove it by pulling straight down. It may be taped to the instrument for shipping purposes. According to the manual, this should be done every month. I have had the machine since Katrina and this is the first time I have had a problem. Hope this helps.

Posted on Aug 19, 2007

Ad
  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 1 Answer

I have two of these that are about a year old. They're both doing the same thing. They run for about 5 minutes then stop. They're driving me crazy! I'm going to throw them out and start again with a different brand.

Posted on Jun 22, 2013

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

After 6 months of use, I have the exact same problem with mine. The unit stops running after a few minutes. Sometimes the compressor doesn’t come on at all. I took it back to SEARS and they kept it for almost month. They replaced the capacitor and the main PCB. I brought it home and it worked, but then stopped working again. There is only 4 months left on the warranty. I want my money back.

Posted on Jul 31, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • Expert
  • 184 Answers

The time of year unit is used is an important part of how it works. in cold weather there is less humidity, so the unit cycles faster.there by collecting less water. the other reason could be the fan motor. it sometimes burns out due to dirt. if you don't clean the filter the dirt then travels to the coils which in turn send dirt to the motor. also the motor is working harder to pull air through the coils.

Posted on Dec 18, 2007

Thanks for the solution, but I already gave up on the problem. I tried changing the main computer box and the sensor assembly, neither of which worked. I scrapped the unit.

Posted on Aug 20, 2007

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My ZD30 Zenith dehumidifier..starts, after 10, 15 seconds the full indicator light starts blinking and it stops running!


Normal 0 MicrosoftInternetExplorer4 /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman";} Hi,

Here is a tip that explains what can be happening to make the dehumidifier show that the bucket is full when it is not.

Dehumidifier Problem It shows Bucket Full

heatman101

Aug 30, 2010 | Dehumidifiers

2 Answers

Zenith ZD30 dehumidifier - 1 1/2 years old stopped working had a half bucket oc colledted water in bucket when it stopped. I checked the fuse on the circuit board and have continuity.


Unplug from wall. Take the front cover off and disconnect the 2 wires that attach to the humidity control dial. Plug back in. If it works, the problem is the humidty control dial (mine just went bad). With it unhooked, it will run constantly, but will still turn off when the bucket is full. To turn off, simply unplug.

Jun 16, 2010 | Dehumidifiers

1 Answer

Auto shut off comes on instantly


TURN UNIT OFF.. MAKE SURE DEHUMIDIFIER HAS NOT BEEN RUN FOR AT LEAST FIFTEEN MINUTES... TAKE BUCKET OUT... HOLD IN THE BUTTON THAT THE FLOAT IN THE BUCKET PUSHES ON.. THEN TURN ON THE UNIT.. DO NOT LET GO OF THE BUTTON EVEN A LITTLE BIT IF YOU DO YOU WILL HAVE TO WAIT FIFTEEN MINUTES AND TRY AGAIN.. IF UNIT WORKS THEN YOUR FLOAT IN THE BUCKET IS THE PROBLEM...

May 07, 2010 | Goldstar DH304 Dehumidifier

1 Answer

Empty bucket light is on and dehumidifier will not run


The float switch for the condensate reservoir (bucket) is malfunctioning.

It's sending a false signal that the bucket is full.

Maybe just stuck and needs cleaning or it may have failed.

May 31, 2009 | Whirlpool AD65USL / AD65USM Dehumidifier

1 Answer

LG dehumidifier


I Have an LG Dehumidifier and water has leaked out to the basement floor, it has a hose that drains into the floor

Sep 12, 2008 | LG LHD65EBL Dehumidifier

1 Answer

Auto shut off


Try re-seating the bucket. I have found some LG models that if not seated all of the way will sometimes keep running and think the bucket is not full even when it is. On the models that I have seen do it the problem is usually the left side of the bucket not engaging all of the way. When you reseat the bucket, feel where the bucket meets the dehumidifier on each side and make sure they are even. If one feels like it is sticking out further than the other and you cannot push it in any more pull the bucket out and try and reseat it again until both sides are flush with the dehumidifier. If you found this solution helpful please rate it.

Thanks - Tech101

Sep 08, 2007 | LG DH404E Dehumidifier

Not finding what you are looking for?
Kenmore 54351 Dehumidifier Logo

7,731 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Dehumidifiers Experts

Bill Long

Level 3 Expert

606 Answers

Cindy Wells

Level 3 Expert

6004 Answers

Marvin
Marvin

Level 3 Expert

85161 Answers

Are you a Kenmore Dehumidifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...