Question about Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

1 Answer

I have the upright kenmore progressive with direct drive and the filter canister stops bringing in air and picking up when hose is put into vaccum, when you remove hose and use as an attachment it starts again

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers

Check the hose after the brushes. With this problem there is normally a clog in between where you disconnect the hose (to use attachment) and the brushes that clean the carpet.

Posted on Jan 14, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kenmore Progressive with direct drive model 116.36923502 stopped picking up debris and empted it into the floor and is there something you need to do to switch from floor to using the hose. It does not...


sounds like you have a clog in your hose, full bag, or dirty filters. take the bag door off and feel inside at the bottom for suction or air movement. if you have suction there chances are its a clog in the hose. You can use a coat hanger or something similar to reach into the hose just be careful not to puncture the hose. First just try turning the unit on and stretching the hose as far as you can. try to feel for a clog and try to free it with the hose stretched.

Jan 22, 2010 | Kenmore 31913 Progressive Direct Drive...

2 Answers

The vaccum doesn't pick up dirt, it sprays out


There is probably a second or third filter (besides the canister) that needs to be cleaned.
I doubt that it's rotating the wrong direction.

Apr 25, 2009 | Dirt Devil M084600 Dynamite Bagless...

2 Answers

Kenmore progressive/direct drive-- roller stopped turning


We have the same vacuum & had the same problem. As the vacuum ages & the hose is periodically removed from the nozzle to use with the attachments, the white switch, adjacent to the nozzle connection, wears. If the hose is not fully reinserted or if the attachment notches are inadvertently aligned with the white stitch, the agitator may not work reliably. Assuring the hose is fully inserted, with the locking notches away from the switch has eliminated this problem with our vacuum cleaner.

Jan 24, 2009 | Kenmore 31913 Progressive Direct Drive...

1 Answer

Vaccum has no suction


Here is what we did to fix the problem of our vacuum having no suction.
We unscrewed the three screws on the back and took the hose off of the vacuum.  Then we took the hose outside and put the water hose through the vacuum hose and turned on the water.  After about 30 second the water pushed through a dust bunny the size of a fist and a marker.  Basically, the vacuum did not have suction because the hose was clogged with dust, etc.  After reassembling the vacuum, it worked just fine.  

May 11, 2008 | Kenmore 34923 / 34925 Progressive Bagged...

1 Answer

Kenmore progressive Direct Drive Vacuum w/Hepa


Check the hose and dirt inlet for a blockage. Also the brush roll, check it to see if you can turn it or not by hand. If not, then something may have jammed it.

May 03, 2008 | Kenmore 31913 Progressive Direct Drive...

4 Answers

Kenmore Progressive Direct Drive Upright - noise and bad suction


Had the same problem tonight. Took the entire thing apart only to find there was a much simpler solution. Check the small hose that runs from the brush rollers where the longer hose (on the back) attaches to the side of the vacuum. Easiest way to do this is to lay the handle down and stick something (coat hanger worked good) through it until it comes out of the head. I found a pretty good sized fuzz plug in mine. As soon as I removed it, everything worked great again - and no noise!

Mar 15, 2008 | Kenmore 31912 Progressive Direct Drive...

6 Answers

Vaccum has no suction


Need a new belt -- you might have suction but you need the brush to spin (hard to help without make or model, upright or canister)

Oct 17, 2007 | Kenmore 25614 / 25615 Progressive Bagged...

1 Answer

My vacuum is not sucking at all.....


I took out the air flow filter at the back of the vacuum and turned it on, somehow the clog cleared. Then I put the filter back in and it works perfectly! Barb

Mar 01, 2007 | Kenmore 35912 / 35913 Progressive Upright...

Not finding what you are looking for?
Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum Logo

124 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18381 Answers

Roger Potts

Level 3 Expert

694 Answers

kakima

Level 3 Expert

102366 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...