Question about Aragon 28K MKII 2-Channel Amplifier

2 Answers

Loose knobs I've had this preamp for around six months, and although its sonic performance is ok, its build quality leaves much to be desired. The knobs are starting to loosen up, to the point where, just a few weeks ago, as I turned the power knob, the thing stayed in my hand! Upon examing it up close, I realize that there is supposed to be a tiny screw which fastens the knob to its post. However, the post on the pre's body has no perforation for the screw to settle. Anyone familiar with this product will realize that the power knob (all the way to the left) is the feature that takes the most abuse: It is a double function devise which powers up the preamp on when turned clockwise, and mutes the outputs when turned counterclockwise. The user must apply a greater deal of force to this knob than to the volume and balance knobs. I thought of carefully using Krazy Glue, JB Weld, or any similar product, but I found this resource and decided to wait and see if someone out there has a better suggestion. As many of you may know, Kliptch has killed the Aragon brand, so I can't really pick this bone with them. Thanks in advance for any advice you may come up with!

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 54 Answers
Re: loose knobs

Take the screw to hardware store and get an allen set screw then use an allen wrench to tighten. BIG RED 32

Posted on Apr 12, 2007

Re: loose knobs

Take the scew out and take it to a hardware store to get an allen set screw put that in and tighten with allen wrench. BIG RED

Posted on Apr 12, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Loud distorted noise from the output

well it sounds like a solder pin is getting lose. does it happen when you rattle the vol knob gently? Maybe the potentiometer does also have to be cleaned

Apr 16, 2014 | Marantz Amplifiers & Preamps

1 Answer

6 yrs old,tubes replaced by 1st owner,perfect for first 8 months,then seems volume diminished, and now distorts when i play hard,playing soft no problem but when i strum hard it distorts

Sounds very much like low emission in the output tubes. Do you know if they were replaced with brand new or used ones? Very possibly the replacements, if they were brand new, are Chinese sourced, and sadly their quality is very low and the lifetime short. Russian Sovtek tubes are much better quality and worth paying more for. It's also important to replace output tubes in pairs, and matched pairs if possible. If the tubes age at different rates, the result is signal distortion, getting progressively worse as the valves age further, although seldom bad enough to be really objectionable - unless one of the tubes has pretty much died altogether while the other one is still performing reasonably well - in that case the symptom is pretty much exactly what you are describing.... :o)

Aug 23, 2013 | Traynor Ycv80 Custom Valve 4x10 Combo Amp...

1 Answer

Denon pma 250SE phono problem

Denon PMA 250SE does not have a RIAA phono preamp.

for some info about these preamp and details here; Home Page

Note: Choose a better quality regulated power supply,

for these preamps.

Although an updated turntable with USB can be used

without the need of such RIAA phono preamp.

Jul 26, 2012 | Denon Amplifiers & Preamps

1 Answer

The volume shaft is do I fix it?

Hello, if you gently pull the knob towards you it will come off and youll see a hex nut thats simply loose ,more than likely.

Feb 28, 2011 | Yamaha AX-596 Amplifier

1 Answer

The radio knob turns, but the dial doesn't move

probably it is a loose knob, take out the knob and put paper or any other material to increase the pressure. see it it works. otherwise glue the knod:)

Mar 04, 2010 | Pioneer Amplifiers & Preamps

1 Answer

Connecting amp and preamp not getting sonic sound i'm looking for.

Describe the equipment and how it's connected.

The sound you're looking for is pretty subjective. Can you be more specific?

Dec 23, 2009 | Carver PM950 Amplifier

2 Answers

Are you able to provide a circuit diagram or even a service manual for stereo integrated amplifier Rotel RA-350? The local service group said ''the problem is on the circuit board'' and eturned it unfixed....

Unfortunately schematics are not availabel for these units outside of authorized service centers. Where are you located? Any local shop that works on audio should be able to fix this as the design is relatively straightforward.

Can you also post the problem you are having with the unit?


Mar 02, 2009 | Amplifiers & Preamps

2 Answers

Grounding noise

Pull bottom panel and get some canned air and spray around circuit board .May have a shorted capacitor to ground.Might have to use repair directory on this site.

Nov 18, 2007 | NAD T973 Amplifier

Not finding what you are looking for?
Aragon 28K MKII 2-Channel Amplifier Logo

Related Topics:

155 people viewed this question

Ask a Question

Usually answered in minutes!

Top Aragon Amplifiers & Preamps Experts


Level 3 Expert

4518 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

66499 Answers

Are you an Aragon Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides