Question about Kenwood Audio Players & Recorders

7 Answers

I have a Kenwood CD Receiver Model#KDC232MR that I use on my motorcycle. I took my bike in for detail and when I got it back he radio was not working. I use this mainly as a receiver for the Sirius receiver. The problem seems to be no power to the unit itself,when I take the facepiece off there is a red light flashing. What could be wrong.

Posted by on

  • 1 more comment 
  • Stephen Subin
    Stephen Subin Dec 20, 2008

    All wiring has been checked out and the fuse was replaced: still no power to the unit itself:as mentioned its a Kenwood CD Receiver model# KDC232MR: worked one day didn't the next.

  • Stephen Subin
    Stephen Subin Dec 20, 2008

    when I remove the faceplate I can see a red light flashing on the lower right side; Hope this helps

  • Stephen Subin
    Stephen Subin Dec 20, 2008

    Yes I guess that's about what I throught: if its in error mode then I guess I could just send it back to Kenwood: Thanks for your help

×

7 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 233 Answers

The yellow wire should have 12 volts all the time, red is 12 volts switched (ignition).. being that the red LED is still flashing, this means it has power on the yellow wire. check to see that you have 12v at the red wire (At the stereo plug) and also check the fuse in the back of the unit...you will have to unplug it to see the fuse, it is right by the fuse socket. 
If the fuse is good, and you have 12v on the yellow and red wires, and a good ground on the black, then You might need to look into another satellite capable kenwood.
Stereos mounted motorcycles and boats suffer alot, due to humidity and all the extra moisture they are subjected to. IF you do have to replace this unit, I would recommend using a Kenwood MARINE unit, as they ase designed to deal with the extra moisture. The circuit boards in these units are epoxy coated and sealed from moisture - this doesnt mean they are "indestructible" but they will last alot longer than a average stereo.

Posted on Dec 20, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 916 Answers

There is a fuse both in the back of the deck...and in your fuse panel...

Refer to your service manual for the car to find the correct fuse for the audion system.

and

Refer to your service manual for your deck to see what im talking about...all the fuses Ive seen just plug into the back of the deck.

Also all the wiring could be correct but one may be loose.

Try cleaning all the contact points and resetting it and make sure that the fuses have power going to them.

Posted on Dec 20, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 5,158 Answers

The read flashing light is "normal" .... warns theives when the faceplate is removed. when you put the face plate back on is it seating properly... also was the power unhooked from the radio for any length of time ?


Posted on Dec 20, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 6,966 Answers

Hi and welcome to FixYa,

Initially, your info that the problem came about after a detailing work is significant. Probable faults could be:

  • press the reset button, right side of the faceplate after the SRC;
  • moisture inside the unit, try using a can of compressed air. Use the long small tube/nozzle to fit inside the unit;
  • clean the multiple contacts both of the unit and the faceplate;
  • there are two (2) wires that supply the need power, yellow from the always on B+12 such as the battery terminal and red which is ACC controlled +12.
Good luck and Thank you for using FixYa. Happy Holidays.

Posted on Dec 20, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Kenwood Master
  • 19,396 Answers

If there is no power at all, check the fuse. If you have a red light on the unit it means there is power, but unit is not starting.

If you have a red light the radio is on error mode for some reason, in this case do the following:

  • Ensure the radio is not just asking you the anti theft code, in this case you will be asked to input a code to proceed.
  • Unplug power negative battery for ten minutes, this will reset the radio.
  • Check the wiring at the back, ensure there is no short or missing contact.
If all the above did not help that means that the radio is on error mode, in this case it must be removed and tested on an external 12v DC 5A regulated power supply, and taken apart for testing. This job is usally done at car stereo fitter repair shop.

Posted on Dec 20, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 10,594 Answers

Let me know does the red light flashing in circuit board or just behind of front panel.

Posted on Dec 20, 2008

  • Shahid Electronics
    Shahid Electronics Dec 20, 2008

    Find is there any reset switch located, press it once and place front panel back and insert cd or select tuner.

×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,110 Answers

There is a fuse both in the back of the deck...and in your fuse panel...

Refer to your service manual for the car to find the correct fuse for the audion system.

and

Refer to your service manual for your deck to see what im talking about...all the fuses Ive seen just plug into the back of the deck.

Posted on Dec 20, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Need wiring diagram for Kenwood KDC-X679 CD receiver for my 1997 Chevy truck


The manual for the Kenwood Excelon KDC-X679 has the wiring diagram for the connections to the car/truck on page 33. Crutchfield has the manual on the product page: http://www.crutchfield.com/S-FpCU7SY0yQm/p_113KDCX679/Kenwood-Excelon-KDC-X679.html . (Click on the Details tab.) The direct link to the manual is http://pdf.crutchfieldonline.com/ImageBank/v20050828082600/Manuals/113/113KDCX679.PDF .

Kenwood also has the manual on their support page: http://manual.kenwood.com/en_contents/search/ . Just enter the model number. On this site, you can find the manual is several languages. The direct link to the English version of the manual is http://manual.kenwood.com/files/B64-2764-00.pdf .


I hope this helps.

Cindy Wells

Jan 30, 2016 | Kenwood Car Audio & Video

1 Answer

Where does the orange and pink wire go to dpx303


Hi there,

You have only provided us with details on your Kenwood Receiver, but not the vehicle make or model.

Therefore, I can only answer based on the Kenwood receiver wiring.

The Kenwood receiver loom has an ORANGE (White stripe) wire - this connects to your vehicle's "Dimmer" control wire.

Kenwood receiver loom does not have a Pink wire.


Hope this helps.

Dec 18, 2012 | Kenwood DPX303 CD receiver

1 Answer

I have a kenwood it says,kdc-mp142 and all of a sudden it just says protect. it wont do anything


The Kenwood radio will generally give a "PROTECT" error if the amp or receiver is being overloaded. This may mean that some of your wiring may have gotten frayed, one of your speakers isn't putting out the right voltage, or the receiver has decided to go bad. Make sure all of your connections in the back of the radio are solid and not frayed. If that's not the problem, try running each of the speakers one at a time. If one causes the radio to go into protect mode, that's your culprit.
If neither of these are the issue and the radio decides to stay in "protect" mode, your receiver may have seen better days and may need a replacement.

Feb 28, 2011 | Kenwood KDC-MP142 Car CD/ MP3 Player

1 Answer

Need security code for kenwood kdc232mr


You will need to visit an Authorized Dealer or service center for that product to get the unlock code reset. You can find a dealer listing on their website, or call them.

Jan 05, 2011 | Kenwood 50W x 4 MOSFET Apple iPod...

1 Answer

I have an KDC-MP435U receiver with 160w kenwood speakers. can you please advise for the the best speakers for this model? can I add a subwoofer? Please advise how can I improve my car sound. I'm using this...


Yes you can add a subwoofer. you will need an amplifier and feed the signal to the amp with your subwooder output rca jacks on the back of the radio. this will give you control over the sub.

Jan 03, 2009 | Kenwood KDC-MP435U CD Player

2 Answers

KENWOOD RADIO


take a pen and press the reset button ...it's a tiny little button next to the button that takes off the faceplate...

Jan 18, 2008 | Kenwood KDC-MP235 CD Player

1 Answer

Kenwood receiver/sub problem


The amp's remote turn-on wire is probably connected to the blue wire coming from the back of the stereo - this is intended for a power antenna, which is why it only works when listening to the radio. Disconnect it from the blue wire and connect it to the blue/white wire coming from the back of the receiver and you should be good to go.

Sep 21, 2007 | Kenwood KSC-WD250 Car Subwoofer

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

29 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

4940 Answers

Eddie Dalton
Eddie Dalton

Level 2 Expert

53 Answers

Henry  Thomas
Henry Thomas

Level 3 Expert

1074 Answers

Are you a Kenwood Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...