Question about Hifonics Brutus BX12D4 Car Subwoofer

1 Answer

Car audio sub issue please help

I had to move my sub around and when i wwent to hook it back up now when the music plays its a steady bass sound

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 62 Answers

Did u cross any wires when putting back check rca cables

Posted on Dec 20, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Stereo install yukon w amp and subs


Recheck your connections from deck to "non-sub" speakers. Are you using an adapter from deck to vehicle wiring harness OR are all wires individually connected?

Apr 09, 2014 | 2002 GMC Yukon

1 Answer

Quantum audio 2000watts amp


Feedback that's not bass.

Feb 23, 2014 | Car Audio & Video

1 Answer

My amp won't play bass everything is hooked up


I have a similar problem with my 2012 civic, I hooked up my 1800w kenwood mp to my 2 12" w6s and 1 song plays and sounds great, the rest of my songs have no bass from the subs, just the car speakers sound normal so I dont know what the hell thats all about. I thought it was a wiring issue but I can play the one song all day and it sounds perfect so any suggestions? thanks in advance

Jan 29, 2012 | Sony Car Audio & Video

1 Answer

I have just run a bass test and I am getting bad vibration noises from one of evp subs the sub works but seams to crash at certain frequancies


Over-driving or resonances can be unpleasant and intermittent. Decide which you have. Find some music that causes the symptom.

If you haved two identical subs the diagnosis should be easy enough. Swap them physically.

Lower the volume. Problem solved?

Move the sub around the room to see if it changes for the better or worse. Room boundaries and YOUR position relative to the speakers play a huge part in bass response.

Maybe the speaker cone is damaged or the voice coil is separating.

Mar 06, 2011 | Audio Players & Recorders

1 Answer

I play my music on low and it has bass wen i turn the radio up it starts hiting only certain bass notes the lowest dont hit hard it starts sounding weird???? i have it hooked to a audiobahn aw1206t...


sounds like you have some wires crossed. check your radio setting and make sure that the subs are only playing bass and no trebble. buy some new rcas

Mar 10, 2010 | Nitro BMW-486 Car Audio Amplifier

1 Answer

Poor sound/ Unable to play anything load without distortion.


i can tell you right now base on the vehicle you have a bad system hook wosrt if you are using factory head unit

Mar 25, 2009 | Kenwood KAC-8151D Car Audio Amplifier

1 Answer

Subs wont play music


Sounds like your RCA's are the source of your problem. Unplug your RCA's before you turn your car on. You may need to isolate your RCA's and the ground wire on the back of your head unit.

Feb 04, 2009 | Metrik Amplifiers MAX-1202 Car Audio...

1 Answer

Whenever i wire 2 4 ohm svc subs the system just starts to pound real hard and its not like bass moving to music but just bass just moving up and down


It sounds like you have an open shield ground. To check the shield in your head unit, read through the following page.

Temporary Shield Ground Repair

Let me know if you have any other questions.

Aug 26, 2008 | Profile 600MSX Car Audio Amplifier

1 Answer

Amp and sub bass playing through all speakers


You need to go into the setup menu and find out if the radio has a sub low-pass filter that redirects the bass to the pre-out for the subs, and away from the main speakers. Fiddle in the audio menu.

Apr 15, 2007 | Xtreme Sound WMS336 CD Player

Not finding what you are looking for?
Hifonics Brutus BX12D4 Car Subwoofer Logo

Related Topics:

55 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hifonics Car Audio & Video Experts

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1165 Answers

Jaime Hernandez

Level 3 Expert

2336 Answers

Marvin
Marvin

Level 3 Expert

81400 Answers

Are you a Hifonics Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...