Question about Car Audio & Video

1 Answer

Protection light i hooked everything up but the protection light stays on.plus whats the fuse rating for this amp cause i have a 15. power acoustic 2000 watt i tried everything and still not able to get the protection lite to go off im open to trying something new

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 21 Answers

Take the amp out and hookit up to the car battery and let it charge then unplug it do this a couple of times then rehook it to the cars audio system it sounds like your amp may be locked..

also check your speaker wires from amp to speaker box then from the back of the box to the speaker inside the box you may have a short..

thats where i would start.. hope this helps

Posted on Dec 21, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

300W Pyramid PA305 protection light


What is the speaker load in Ohms that you are running? Or what exactly is hooked up to it? are you bridging it? The protection light will come on if the load is too much for the amp to handel. If the load (in Ohms) is less than the rated load that it can run, it will stop the output to keep the amp from self destructing. The amp will sense that the demand for power will be too high for the amps circuitry which will either make the amp get so hot that it will burn up the copper on the board or more likely burn up the power mosfetts that power the speakers. If the Ohms are within range then it will allow power to flow through the circuit until the rails that the mosfetts are bound to until they get so hot that it will go into thermal protection. So if your amp has both thermal and overload protection lights and the overload is light then the load is probably too much for the amp. if it's bridged in mono the you can only have 1 speaker setup hooked up it if it's a 2 channel amp. a 4 channel amp bridged in mono for both front and rear channels will be able to have 2 speakers rated a 4 ohms each hooked up to the amp 1 set per bridged output or channel.
Try it running in stereo with only 1 speaker per channel and see if it will produce sound. If not then you have an amp that has internal problems and will need to be serviced. Check your warranty to see if you are covered.

Apr 02, 2013 | Pyramid PA305 150 Watt PA Amplifier Car...

1 Answer

My power acoustic protection light stays on i got good ground and a good positive connection, no speakers or RCA's hooked up, what could it be


Are you fused close to the battery with a 30-50 amp fuse block?
Ground unit also to most closest suitable location!
Is your power wire undersized?
Check units fuses you may have blown one hooking it up!!
Good luck

Feb 15, 2011 | Power Acoustik LT-1920/2 Car Audio...

3 Answers

I have a Lanzar 4000 watt amplifier hooked up to 2 12inch MA Audio subs. When I crank my car the green power light on the amplifier comes on, but after a second or two it changes to protection mode. I have...


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Time to get an old school Opti Drive. .A thumbs up would be greatly appreciated if this answer is helpful to you. lanzar-4000-watt-amplifier-hooked-up-2-shonxoarcym4awy4zl1imx4o-2-0.jpg Lanzar

Jan 29, 2011 | Lanzar VIBE286 Car Audio Amplifier

1 Answer

Amp burned out but fuses still good?


this is caused by inproper wiring from the speakers/subs to the amplifier.. an amp will still put out power to subs and speakers when it's wired improperly but it won't last for very long doing it... 6 months is longer than usual....

Dec 05, 2009 | MA Audio M1900XE Car Amp

1 Answer

Its stuck on protected. I recieved the amp for my birthday in 2000. It protected it self 90 days later. I needed an amp righr then so I went and bought a 600 watt jensen. I took the old one out of the...


whats the ohm rating of amp probally 4 what is the ohm rating for sub how many subs are you running how do you have them hooked up parallel or series is your wiring to amp right

Jul 06, 2009 | Car Audio & Video

1 Answer

Protection light flashes on and i get nothing


Hello shwoop22,

It sounds like power is shorting out or the amp is defective. With the fuse removed, use a multimeter set to ohms and check between the power terminal to ground.

The protection light will normally come on if the amp overheats (for example when running with too low impedance), or if the speakers are shorted.

Hope this helps.

May 04, 2009 | US Acoustics USX-2100 Car Audio Amplifier

1 Answer

Sony explode amp for my car


Try disconnecting everything but the power connections. If the protection light still comes on, then there's a problem in the amp. If it goes out, then there's a problem elsewhere. In that case, hook up one speaker cable at a time and power on. If the protection light comes on, then either that speaker is bad, or you've got too many speakers connected to that one amp output. Too many speakers connected together can cause an overload and trigger the protection circuitry, or worse, blow out something out.

Hope this helps, and please rate my advice.
Thank you, and good luck!!

Feb 04, 2008 | Car Audio & Video

2 Answers

VB101PK REV 13, AMP WITH SUBWOOFERS


was the amp hooked directly to the box? You probably rattled the power connections from the circuit board like I did on a PT 800 watt amp.but check amp fuses first.

Sep 15, 2007 | Visonik V117SX Car Audio Amplifier

2 Answers

Protection light


have you wired it up properly + to + and - to - and the power + and -

Aug 13, 2007 | Power Acoustik GOTHIC OV4-600 Car Audio...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

356 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4807 Answers

yadayada
yadayada

Level 3 Expert

70374 Answers

The Knight
The Knight

Level 3 Expert

72640 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...