Question about Alpine MRD-M500 Car Audio Amplifier

2 Answers

My amplifier is plugged but doesn`t bring a sound why?

The led light is on but theres no sound comming out of it

Posted by on


2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

My alpine amp LED is coming up and saying -----R whats that mean was working fine then it just stop working

Posted on Aug 08, 2012

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 5 achievements.


    An expert who has written 50 answers of more than 400 characters.


    An expert who has answered 200 questions.

  • Expert
  • 218 Answers

If your are certain that you have a signal going to the imputs of your amp and you are certain that the speakers are OK and you have not turned the gain control all the way down then that just leaves a fried amp. Good luck.

Posted on Apr 02, 2007


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

LED light doesn't light up on JL Audio XD 600/1

It could simply be a faulty or burnt out bulb, just find a small bulb at Ace Hardware or the similar, and replace it.

Aug 14, 2012 | Car Audio & Video

1 Answer

Hi there, I have an american DJ Dekker LED. I plugged it in and put it into Sound active / sound to light mode. I'm getting response to sound because I can hear and see the fan inside the unit...

I have OFTEN found that a cable has come loose. Open the unit and look for such a situation. Also make sure the motion (probably a disc) is working/rotating since with high power LED devices, they have interlocks for safety to keep beams moving.

Jun 24, 2011 | American DJ Supply American Dj Dekker Led...

1 Answer

I have two Behringer Eurolive B415DSP speaker, one of them stopped working out of no where. To my best knowledge, the problem is that it doesn't turn on. I had the Fuse check already and thats not the...

This is alimentation fault of the amplifier inside the box. Dismount the amplifier block and take a look first if there are some burned pieces. If it seems all ok, better bring it to a electronics/ tv service center.

May 18, 2011 | Behringer Eurolive B415dsp 600w 15" PA...

1 Answer

There is a red light shinig inside my CROWN XLS

Lots of electronics have lights (LEDs) that turn on when they are plugged it. Most people just don't notice them. If it is working properly, then the light is normal.

Mar 04, 2010 | Crown XLS 602 2-Channel Amplifier

1 Answer

Power up led red does not go to green left side no sound

bring it to the service near you coz thats repairable that was power problem

Apr 06, 2009 | QSC MX1500A 2-Channel Amplifier

1 Answer

Amp quit putting out sound

It is probably in the "protect" mode. When this happens, the amp will have power going to it and seem to be turned on, but no sound. Many amplifiers have a LED that is normally red and it lights up when in the protect mode. Check all the LED's on the amp and see if one of them is for the protect mode.

When an amplifier goes into protect there are usually only 2 reasons for it.

1. A bad speaker

2. A channel blown inside the amp.

Disconnect the speakers to the amplifier and see if it makes the amp come out of protect mode. If the amp has an LED to indicate when it is in the protect mode, this LED will shut off, and sometimes they have a relay inside the amp that you will hear click. If you hear the click sound form inside the amp after you disconnect the speakers, you probably have a bad speaker. Take yours to a service center and ask them to check them for you, many shops will do this for free, I know that my shop will do it for free, so I assume that many others will also.

If the amplifier has a blown channel, you need it serviced. There is no quick fix for a blown channel. If you have a multimeter I can tell you how to check some of the components inside to verify if it has a blown channel. Let me know if you are able to do this and I will give you instructions on how to properly test the components. If you do not have a multimeter, there is really no way to figure out what components are bad. Your only choice would be to take it to a service center for repair. They can give you an estimate of what it may cost before you are committed to paying for a repair. Most car amplifiers will cost about $100 to $150 to repair a blown channel. It just depends on how much damage there is, and the rates of the service center.

I hope this is helpful, and if so a good rating would be appreciated. If you need to communicate more with me to determain what the problem is, please wait to give a rating until we are finished. That way I will not get an undeserved bad rating. By the way, the only rating that is good (meaning that it doesn't lower my over-all rating) is a FixYa! rating. The "Helpful" and lower just bring my rating down. After all, the only reason for offering this free help, is to get a good rating.


Nov 18, 2008 | Jl Audio 500/5 Car Audio Amplifier

2 Answers

Need schmatic for ep2500

check preamps small parts! maybe you have change value capacitors and resistors!

Sep 13, 2007 | Behringer EUROPOWER EP2500 Amplifier

1 Answer

Rt 202 led light red and no sound

With the system turned off, disconnect the speaker wires from the amplifier. Turn on the system. If the light stays red, then the amplifier has an internal problem. If the light turns green, then your problem is a blown speaker, or a speaker wiring issue.

Jun 03, 2007 | MTX RT202 Car Audio Amplifier

Not finding what you are looking for?
Alpine MRD-M500 Car Audio Amplifier Logo

Related Topics:

258 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4905 Answers


Level 2 Expert

150 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides