Question about Edirol UA-25 External Sound System

1 Answer

Mic problems: playback works great through interface, microphone isn't being detected

Hey there I just recently bought the Edirol UA-25 interface and an Apex 435 microphone... and i've installed it and all of the drivers, etc. for the interface without a problem, it plays back sounds through winamp, itunes, windows media player, etc. PERFECTLY. I've ran into 2 issues though. The first needs to be dealt with before the second is even relevant. 1) My computer/interface doesn't detect the microphone. The cable is secured to the mic and the interface, and the interface is set to record in advanced mode,96k, with phantom power on, as it told. However, when I go to test my mic in windows, it doesn't pick up any sound. Even with the levels all the way up. No Sound at all detected. What's the issue here? 2) Although the interface works with winamp and media playing programs, when I playback a track in Adobe Audition 1.5, it comes out of my laptop speakers, rather than through the interface! Frustrating, is there compatibility issues or do I just have something not set up correctly? Help is greatly appreciated! Thanks - Ellzy96

Posted by on


1 Answer

Check in contraol Panel under sounds and audio devices that you are using the Edirol and not an on board sound. It sounds like although the cards installed its not selected as the audio device to record from. You will also have to tel Adobce audition to select the Edirol as you audio card of choice as it to can be changed to select input from other sound devices.

Posted on Apr 18, 2007


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

I just brought the nt1-a and plugged it in to my cakewalk UA-25 EX and nothing ...No sound from the mic ...

  • Be sure Phantom power is on.
  • Check that other mics or sources work properly through the interface.
  • Check that the mic functions through another mixer/interface.

Aug 12, 2010 | Rode NT1A Professional Microphone

1 Answer

How to use a condenser mic on a mac/in garageband?


If you are sure that the microphone and the cable is OK, it could be that you're phantompower is to low.
Normally you need 48 Volt, you can check that with voltage meter between pin1-2 and 1-3 from the XLR.


Jan 22, 2010 | Audio Players & Recorders

1 Answer

No Sound From Channel 2 on my UA 25

My laptop is problems .sound driver is uninstalled

Feb 12, 2009 | Edirol UA-25 External Sound System

1 Answer

Edirol UA-25 not working on Mac OS X

I had the same problem. When I installed the Edirol software it prompted to 'reboot' and when it restarted all the lights on the Edirol came on.
Why don't you try it like that.
Hook up the Edirol Install the software Reboot
Best of luck Victoria

Nov 19, 2008 | Edirol UA-4FX External Sound System

1 Answer

No sound being picked up by Edirol

I discoverd the the digital in button had been pressed in. This was the mic was not picking up any sound.

Jul 09, 2008 | Edirol UA-25 External Sound System

4 Answers

Edirol ua-25 not detecting midi but audio works fine


On the back of the UA25 there's a switch called "Advance" - this needs to be set to ON for the device to work as a MIDI interface.

LC (UK).

Feb 27, 2008 | Edirol UA-25 External Sound System

2 Answers

Only Hearing Sounds on One Side of Headphones

your headphones are bad sounds like cheak out the new seinhezer hd280 pros ok 99 bucks best they make

Jan 23, 2008 | Edirol UA-25 External Sound System

1 Answer

Playback recordings

Problem with cable? Change in sample rate? Have you changed software/drivers? Could do with more info.

Jan 17, 2008 | Edirol UA-25 External Sound System

2 Answers

Audio Inputs suddenly producing buzz/broken

The UA 25 needs a GOOD quality USB cable, the thicker the better. Cable loss means that by the time the 5V power supply from the computer reaches your Edirol, the voltage has dropped to about 4V, which then has to be boosted back up to 5 Volts and inverted to -5V.

Cheap cables will hamper performance or prevent it working at all ( I lost 2 hours once with this problme ) . Also avoid using the FRONT USB connectors on PCs, use the connectors that plug direct into the MOBO on the rear of the chasis.

Good luck

Dec 22, 2007 | Edirol UA-25 External Sound System

2 Answers

Edirol Ua 25 Making humm noise when recording Mic

I had the same problem, it was due to the charger i had for the laptop, this problem can be accomplished by purchasing STEREO leads. I do not know the reason they work, but if anyone does find out please tell me


Sep 16, 2007 | Edirol UA-25 External Sound System

Not finding what you are looking for?
Edirol UA-25 External Sound System Logo

216 people viewed this question

Ask a Question

Usually answered in minutes!

Top Edirol Computers & Internet Experts

Folusho Adeyanju
Folusho Adeyanju

Level 2 Expert

131 Answers


Level 3 Expert

781 Answers

Ben Armstrong

Level 2 Expert

357 Answers

Are you an Edirol Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides