Question about Sony Xplod XM-1652Z Car Audio Amplifier

2 Answers

Took out my amp and sub put it back in and now it wont work

I took out my sub and amp and i put it back in with new 4gage wire and rca's and my led light wont come on unlees i put some of hte power wire on the rem and than it sounds like im geting 2 much power to the sub "sounds like crud" than the light turns red help me plese

Posted by on

  • alex johnsion Apr 02, 2007

    but when the red light comes on no amp or sub they wont work

×

Ad

2 Answers

8 gauge reccommended make sure all connections are good and clean try new remote wire and make sure ground is less than 10 inches also being 8 gauge wire

Posted on Jun 05, 2007

Ad

You masht seting all parameter too the midel befour selected oan by oan,step by step equalayzer

Posted on Mar 30, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Pyle Academy 2300 watt amp not working =(


wrap a striped speaker wire around the back of the rca out put on your cd player and for the record that aint a 2300 watt amp its like a 300 watt amp

Mar 30, 2010 | Pyle PLAM2300 Car Amp

1 Answer

No sound


hi there
on your CD deck or what ever unit you plugged the RCA wires to needs to be set on subs the radio needs to be set to put sound to your amp.....on your CD player if you press the F/function button a few times it will scroll to SW which is for the subs set this to the on position or if your CD player has a button with SW press it and turn on this feature......if this has been done......check the fuse or fuses on the amp.......if you have done all of the above check the back of the CD unit to make sure you are plugged into sub-woofer RCA or R (rear) RCA ..........sometimes people accidentally put the RCA wires into the aux input RCA,,,,,, double check this.........
hope this helps

Mar 07, 2009 | Crunch PZi1000.1 Car Audio Amplifier

1 Answer

Only get sound wen rca's r in halfway


You have a bad set of RCA's. Try and get a pair specifically made for car audio. There are hundreds of brands, usually the cheap ones work fine.

What usually happens is on cheap RCA cables, wires inside the actual plug split apart and short out on one another. Get another set of cables and you'll be fine.

Jan 30, 2009 | Alpine MRP-M450 Car Audio Amplifier

1 Answer

Subwoofer Output Not Working...


first check that the subwoofer function on the actual head unit is turned up,second check that the gain on the amp is at bout half way then check that it is on a lp (low pass setting)
then check that the boost on the amp is turned up.
please leave feedback.
cheers

Jul 02, 2008 | Eclipse CD5405

1 Answer

No sound


did you set your gains and base boost also when you put sterio back in dash did you put rca's on proper outputs or the rca's could have pulled out when putting back in
you have high output and low output

are your subs getting sound to them at all any current going threw speaker wires to subs
radio settings might not be set to back end for subs this is a feature on most receivers to shut off back end subs

May 08, 2008 | Kicker KX200.4 Car Audio Amplifier

1 Answer

Amp issue


rca cables and connectors

Aug 16, 2007 | Orion 3002 Car Audio Amplifier

1 Answer

Subwoofer Output Not Working...


The first thing to try is disconnecting ONE of the two subs. See if you get more bass with a single sub than with both. If you do, re-connect the second subwoofer, but reverse the (+) and (-) wires.

Jun 19, 2007 | Panasonic MXE CQ-C7401U CD Player

1 Answer

My 7801 doesnt turn on


check pwm circuit amps turn on with 3-4 volts on mosfet gates ic 494, 5252or 555 controll these.hit me up for more

Apr 03, 2007 | MTX THUNDER7801 SUPER AMPLIFIER CLASS D...

Not finding what you are looking for?
Sony Xplod XM-1652Z Car Audio Amplifier Logo

Related Topics:

142 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

xxxxxx xxx

Level 3 Expert

5001 Answers

The Knight
The Knight

Level 3 Expert

75871 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...