Question about Jl Audio JL5001 Car Audio Amplifier

1 Answer

Amp not working

I have a jl audio 500/1 car amp the green light comes on but can't get amp to play. I have moved my ground around to differant places that don't hav paint on it, and stil does nit work. tried hooking it up many differant ways no bass. can you help. The people i bought it from are tring to charge me $200 to send it in to the shop and i know that is bullshit.please help or send me on the right path to getting it fixed.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 62 Answers
Re: amp not working

Check your inputs, make sure your getting power through them. Make sure you LPF is not at the minimum as very few songs have frequencies below 30Hz (your lpf may be different).

Posted on Mar 25, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

I have a jl 500/1 amp hooked up in my car and the power light comes on for about 5 seconds then turns off. no sound out of the subs. it is hooked up to a factory deck through a high to low level converter....

hook up the remote wire ( or make sure its hooked up good) check your ground! ground wire not big enough awg wire and put on bare metal not more than 1 foot away from amp. bad ground will cause this.

Sep 12, 2011 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Hello, I've Got the JL Audio 500/1 and I am running two 15" Kicker Comps. in a sealed box and bridged to my 500/1 and for some reason all of a sudden the amp now powers off then on none...

If your sure the unit is getting the correct power, check the ground cable, make sure it is connected to a clean surface. (remove any paint where the ground is connected.) Double check your wiring. Make sure all of your connections are good. Do not forget the fuse holder, check it too.

Apr 03, 2011 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

My amp jl audio 500/1 i connect it and the green light turn on then i turn in the sterio and it sounds but when i turn off the sterio and when i wanna turn it on again the amp dont turn on i dont know why

Check the remote lead and see if it is getting power at the amp when it won't come on that way you know if the issue is with the head unit or the amplifier.

Mar 08, 2011 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

I have a jl 500/1 . The distribution block is lit showing 12v plus. no green power light on the amp? I disconnected pwr and ground and reconnected. the green light came on for 10 seconds and shut off. all...

The amplifier will not power on unless/until it recieves the turn-on signal from the head unit.

It seems the issue is with the head unit in this case.

Check the fuses and verify constant and switched power with a multimeter.

Once the Head unit powers on - the amplifier should also.

Thanks for using FixYa - a 4 THUMBS rating is appreciated for answering your FREE question.

Jun 18, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

My Jl Audio 500/1, power light comes on but no power to subs

maybe it dont have enough to push it ,,did you try it before you buy it?

Mar 01, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Green power light on JL Audio 500/1 but no output

Its the power transistors that would be affected by low voltage. It delivered till it finally gave up 'cos the output wattage to be generated at low voltage means more current flowing through the equipment. This high current will adversely affect all small solenoid valves & transistors and IC's. Even failure of one section of any IC is rarely detectable with the naked eye. It has to be thoroughly checked with a multi-meter to assess the damage correctly......sodeep

Jul 30, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

JL Audio 500/1 Amp, The green power light is on but no sound!

Check to be sure you are on the correct outputs on the head unit, and be sure the outputs do not have a separate volume control.

Mar 06, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer


It indicating that the power output is too loud and possibility of speakers may get damaged if played at this volume for long periods. When the loudest sound is played the led light mightshow its loosing its brightness and dims in time with the sound level.......................sodeep

Jan 17, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Rca Connection

You need to check the shield ground on the head unit. The following link will guide you through the test procedure.

Shield Ground Testing

Jun 07, 2008 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Jl 500/1

Nine times out of ten if the amp smells burnt it usuallly is. Your best bet is to hook another amp to your system and see if you get sound.

Jan 30, 2008 | Jl Audio 500/1 Car Audio Amplifier

Not finding what you are looking for?
Jl Audio JL5001 Car Audio Amplifier Logo

Related Topics:

65 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Amplifiers Experts

matthew walsh

Level 1 Expert

69 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Sudeep Chatterjee
Sudeep Chatterjee

Level 3 Expert

3267 Answers

Are you a Jl Audio Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides