Question about Orion HCCA-D5000 Car Audio Amplifier

1 Answer

Amplifier does not work

The protection, power, and esp indicator lights keeps comeing on and off

Posted by on

  • Anonymous Mar 04, 2009

    my amp turns on and it used to have a blue light when it worked but now its got a red light wen it terns on and it wont let my subs run whats wrong with it?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 15,935 Answers

Remove the speaker wires and re-test. If the amplifier powers on, without fault, you know the sub(s) and/or wiring are the culprit. If the power and ground are ok, take the amplifier in for service. The indicators are there to let you know of a problem. If it is an internal one, a certified tech will be required.

Posted on Dec 22, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The red protect light comes on, i dont know how to make it go green so it will work. please help!!


Devices with several light emitting indicators would each display as observation of manufacturers installed features. Red indication is power cciuit indication, yelow as alternate warning where green is indication of regular fucntionality. Once the device is least malfunct, every light is an equal expectation. Usually with amplifeiers, the red light has to be on throughout until stereo became powered on to porduce green light effects as radio expectations.

Feb 14, 2011 | Volfenhag ZX-8200 Car Audio Amplifier

2 Answers

My phoenix gold x200.4 amp turns on but the protect light keep on flashing


  • What does it mean when the LEDs flash on my amplifier?
    With most recently produced Phoenix Gold amplifiers, a flashing/blinking LED is an indication that the unit is in protect mode, usually due to an overcurrent condition caused by an internal short, external short (speakers), or low impedance. Overheating will also cause the amplifier to shut down temporarily.

    If amplifier remains in protect mode, power down the amplifier, disconnect the speakers, and power up again. If LEDs continue to flash, there is probably an internal problem with the amplifier that will require service attention to fix.
  • Sep 23, 2010 | Phoenix Gold ZX600ti Car Audio Amplifier

    1 Answer

    I have a orion hcca-d1200 and it keeps shutting off and blinking protect light and the esp indicator light. what could be wrong with it?


    Possibly a shorted output transistor. If it was the power supply you would be blowing fuses, which I assume you aren't.

    Nov 23, 2009 | Orion HCCA-D1200 Car Audio Amplifier

    1 Answer

    Amp 7541a amp was working fine, Took it out of one


    REMOVE THE RCA INPUTS AND DISCONNECT THE SPEAKERS, THEN POWER THE AMPLIFIER UP WITH THIS NO INPUT, NO SPEAKER LOAD CONDITION. IF IT STILL GOES INTO PROTECTION AND YOU HAVE VERIFIED THAT THE POSITIVE AND ESPECIALLY THE GROUND CONNECTIONS, ALONG WITH THE REMOTE CONNECTIONS ARE 100%, THEN THE AMPLIFIER WILL NEED TO BE SERVICED. KEEP IN MIND, THAT DURING THE INITIAL TURN ON OF THE AMPLIFIER, THEY SOMETIMES WILL ILLUMINATE THE PROTECTION LIGHT WHILE STABILIZING THE POWER SUPPLY AND OUTPUTS, BUT AFTER THAT THEY SHOULD SHOW NORMAL POWER UP. IF YOU GET IT TO POWER UP FINE, THEN RECONNECT THE SPEAKERS AND IF STILL OK, THE RECONNECT THE RCA'S. IF IT IS STILL POWERED UP, THEN START TO TURN UP THE MUSIC. IF IT IS STILL POWERED UP AND NO MUSIC, THEN CHECK THAT YOU DEFINITELY HAVE A PROPER SIGNAL COMING FROM THE RADIO. LET ME KNOW IF YOU NEED FURTHER ASSISTANCE.....V

    Nov 18, 2009 | Infinity Reference 7541a Car Audio...

    1 Answer

    I have a Directed D2400 amp and my red ESP is on


    ESP ties the amp into your vehicle's alarm system. If the amplifier is working normally you can ignore the light. Note that this is NOT the protection LED for the amplifier.

    Nov 04, 2009 | Directed 2400d Car Audio Amplifier

    1 Answer

    Protect light keeps coming on when i give my jensen amp power


    Eith some wires touched, you dont have big enough fues or you have somehting hooked up wrong

    May 28, 2009 | Jensen LXA300 Car Audio Amplifier

    2 Answers

    500.1 amp power lights blinks on and off


    Protection mode; follow this link to get a manual for the amplifier: http://mobile.jlaudio.com/products_amps.php?amp_id=439

    Below information is from the manual:

    Status Indicator Lights / Protection Circuitry
    There are three status indicator lights on the top of the amplifier. These are as follows:1) "Power" (Green): lights to indicate that the amplifier is turned on and operating normally.
    2) "Thermal" (Red): lights to indicate that the amplifier has exceeded its safe operating temperature, putting the amplifier into a self-protection mode, which reduces the power output of the amplifier. The red light will shut off and the amplifier will return to normal, full-power operating mode if the heat sink temperature drops back to a safe level.
    3) "Low ω" (Amber): lights to indicate that the impedance of the speaker load connected to the amplifier is lower than the optimum impedance load range for the amplifier. When this light is on, a protection circuit engages and reduces the power output of the amplifier. The amber indicator will also light when a short-circuit is detected in the speaker wiring (this can be a short between the positive and negative speaker wires or between either speaker wire and the vehicle chassis).
    There is only one condition that will shut down an undamaged 500/1v2 completely… If battery voltage drops below 10 volts, the entire amplifier will shut itself off. The green "Power" indicator on the top of the amplifier will turn off when this occurs. The amplifier will turn back on when voltage climbs back above 10 volts. This may happen in a rapid cycle when bass-heavy program material causes a weak charging system to dip below 10 volts momentarily. If this is happening in your system, have your charging system inspected to make sure it is working properly.
    For information on troubleshooting this amplifier, refer to Appendix E (page 21).

    Jun 25, 2008 | Jl Audio E1200 Car Audio Amplifier

    1 Answer

    No Sound/ lights flashing on Amp


    Disconnect your subs from the amp. If the lights go out then your sub is blown and is putting the amp into protect. If the lights keep flashing even with the subs disconnected than the Amp is toast.

    Jul 09, 2007 | Sony XM-752EQX Car Audio Amplifier

    1 Answer

    No power output from the amplifier...


    The EEE and protect leds being on is a clear indication this AMP is toast.

    Jun 24, 2007 | Ultimate Sound T3 Series 4600 Car Audio...

    Not finding what you are looking for?
    Orion HCCA-D5000 Car Audio Amplifier Logo

    Related Topics:

    226 people viewed this question

    Ask a Question

    Usually answered in minutes!

    Top Orion Car Amplifiers Experts

    Tygh Duval
    Tygh Duval

    Level 2 Expert

    290 Answers

    Steve Sweetleaf
    Steve Sweetleaf

    Level 3 Expert

    1128 Answers

    yadayada
    yadayada

    Level 3 Expert

    60667 Answers

    Are you an Orion Car Amplifier Expert? Answer questions, earn points and help others

    Answer questions

    Manuals & User Guides

    Loading...