Question about Crown XLS 802 D Amplifier

Open Question

Crown XLS402 Amp

Amplifier power LED flickers but dies after a second, R22 is extremely hot (even for a ceramic!) although value is correct. LED2B illuminates for 1 second after power-on but fades out. No sound and some smoke was reported. No obviously failed components. Not got a schematic so hoped someone had run into a common symptom with this unit :)

Posted by on

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
robotek
  • 1512 Answers

SOURCE: Crown Amp Possibly Blown??

Hi, probably worth fixing, Crown gear is generally reliable, but this one has failed for some reason. Puffs of smoke are not generally good... If it has blown an output array, expect a costly repair.

regards
Graeme

Posted on Apr 04, 2008

Ad
  • 4234 Answers

SOURCE: amp lights up but when it goes to actually kick on it shuts off

The only component I can think of that fits your description is a bypass capacitor for filtering high frequency interference. That should NEVER get hot. This amp is going into protective shutdown. This unit should be brought in for service. Continued attempts to run this will end up causing additional damage. Where are you located?

Dan

Posted on Feb 17, 2009

  • 4234 Answers

SOURCE: i need the schematic for the crown amplifier

These are available for purchase from Crown. Generally they are not available on the web. Is there a specific problem that you are having?

Dan

Posted on Jun 29, 2009

  • 5603 Answers

SOURCE: Crown XLS402 amplifier will not work

It is probablly in protect mode due to a failure. This prevents blowing your speakers.

You will need to have or do servicing on it. First verify that you can unplug ALL INPUTS and that speakers are connected and problem of the protect LED exists. A bad input MIGHT be causing this due to a ground loop.

Make sure NONE of your speaker leads are grounded or shorted.

Posted on Nov 08, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

KONZERT AV-502A KARAOKE AMPLIFIER,POOR AUDIO,2-RESISTOR WORN OUT PLS. HELP ME


pls check burnt resistors, if ceramic it's value is .25 0hms 5 watts, if big carbon film resistor it's value is 10 ohms 3 watts. check also power transistors A1941 & C5198. also check driver transistor A940 & C2073

Jan 06, 2013 | Car Audio & Video

1 Answer

Got a crown amplifier XLS 602 its powering up the relays are clicking, all voltages seems ok the signal led's are on but there's no sound output on both channels. I manage to trace the signal


Check your input or output cables might be dirty I had the same problem
and 1 of my output wire was dirty so i sprayed tha electric cleaner and its all good now
Aloha

May 21, 2012 | Crown XLS 602 2-Channel Amplifier

1 Answer

I test my crown amplifier 3600vz a few minites then i stop couse verry hot i discover i open the back panel i saw resistor12 and resitor14 burn,i ask what is the promblem,the value of r12 and r14 is...


The ouput drivers have failed and along with the heavy current drain the resistors burnt off . So before the resistors are changed the entire section of the predriver and output section must be checked before new outputs are installed.
test the amplifier with a series voltage regulator and is there is heavy load drain then shut down and recheck till the drain limit is maintained to confirm the correct working of the amplifier.

Sep 09, 2011 | Crown MA-3600VZ Amplifier

1 Answer

I have two Crown XS 1200 and the fault light keeps blinking no fans turn on and ive tried turning them on and off unpluging removing everything off them crown website says its in protected mode is there...


Hello,

A common problem for these is bad capacitors in the power supply, Remove the back from your Amplifier and look at the power supply on the middle section of the amplifier

You will see bid round capacitor that are bulged / domed shaped on top usually these are valued any that have bulged or leaked a brown like substance should be changed.
This will cure the problem as they overheat being sat next to a heatsink that gets very hot!
Try and change them for the same capacitor rating but a higher voltage.
Hope this help in solving the problem....

May 11, 2011 | Crown XS1200 Amplifier

1 Answer

I installed my amp into my 02 neon and it just drains the battery, even while amp is off.. while driving even the amp makes al te lights dimand flicker. i unhooked the power supply for the amp and now the...


Your amp is straining for power, try upgrading your alternator or and a battery in your trunk... or capacitor.And also make sure that the fuse closest to your amp is the total value of the fuses in your anp

Aug 02, 2010 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Crown XLS402 amplifier will not work


It is probablly in protect mode due to a failure. This prevents blowing your speakers.

You will need to have or do servicing on it. First verify that you can unplug ALL INPUTS and that speakers are connected and problem of the protect LED exists. A bad input MIGHT be causing this due to a ground loop.

Make sure NONE of your speaker leads are grounded or shorted.

Nov 07, 2009 | Crown-Audio XLS 402D Amplif 300 with 8o...

1 Answer

I have a crown ce 2000 watt amp. channel 2 keeps turning off


Do you get any Fault indications?

Have you swapped the speakers around to eliminate them as external causes?

When the channel dies is the unit very hot and is the fan turning very fast (it should be if hot)? The fan could be defective, slow or airflow may be restricted.

Turn the amp off and examine the fan guard on the rear to make sure it is clear of dust and debris. Vacuum it out if necessary. With a small thin non-metalic object reach in and test the fan for free movement by trying to rotate it. It should coast.

Apr 27, 2009 | Crown CE2000 2-Channel Amplifier

3 Answers

Peavey SP 2G has a burnt ceramic capacitor in crossover


Ive been through this. Although it certainly appears to be a ceramic capacitor, its actually called a polyswitch. .65 amp. Parts express carries them. Part no. 071-256.

Mar 28, 2009 | Music

1 Answer

Amp lights up but when it goes to actually kick on it shuts off


The only component I can think of that fits your description is a bypass capacitor for filtering high frequency interference. That should NEVER get hot. This amp is going into protective shutdown. This unit should be brought in for service. Continued attempts to run this will end up causing additional damage. Where are you located?

Dan

Feb 17, 2009 | Crown XTi 4000 Amplifier

1 Answer

Technics SA-R330 recevier/amp


It seems the amplifier of your receiver is wearing out or the power.If the output of your amp usually short circuits you should conclude so.if not you should recheck the power supply whether it has a "slow short circuit" especially on the ceramics. In the meantime install a fan for cooling.

Aug 03, 2008 | Technics Computers & Internet

Not finding what you are looking for?
Crown XLS 802 D Amplifier Logo

Related Topics:

72 people viewed this question

Ask a Question

Usually answered in minutes!

Top Crown Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5585 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

The Knight
The Knight

Level 3 Expert

75898 Answers

Are you a Crown Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...