Question about Yamaha RX-V1700 Receiver

3 Answers

No power to head unit no power. no lights. nothing I have checked fuse in plug. I changed lead, and it started working - then stopped again. It has not started again Help - I cannot have a Christmas without the TV

Posted by on

3 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 275 Answers

Usually when an apliance goes dead or burns because of a bad voltage regulation and won't come back on , there is no way to fix it. I would recommend not to spend time or money on someting that is unfixable. Try to see if you can get a warranty replacement.

Posted on Dec 15, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 624 Answers

You said that you changed the "Lead", does that mean that you replaced the A/C cord? And after that it started to work for a while? If so, does this unit have an A/C cord that you can take out and plugs into the back of the unit?

If this is the case, it may need some solder connections on the A/C jack that the cord plugs into to be re-soldered. These type of jacks often get broken solder joints on them and this will cause the unit to be totally dead.

If I am wrong about my assumptions, could you please give a little better detail about what you have done concerning this "lead". Just what type of "lead" is this one that you replaced?

Thanks,

Dave

Posted on Dec 15, 2008

  • Dave DeGain
    Dave DeGain Dec 18, 2008

    Have you seen any solutions yet? If you could answer them it would make it much easier to help you.

×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 479 Answers

Its definately blowing the components due to high voltage and resistots bneeds to be checked.as over current is passing through the board.

Posted on Dec 15, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Unit has power and lights up. None of the buttons work and cd wont eject. The CD eject button turns the unit off but won't eject the CD. Cannot change the functions. Have reset the unit and checked th


Remove the face plate and clean the contacts on both the head and the radio. It sounds like a bad connection, The base and head use serial data to talk to each other(control).If one of these connections are bad the unit will not work properly.

Oct 06, 2014 | Sony MEX-BT2900 Bluetooth Car Stereo with...

1 Answer

What could be the cause of the receiver act like it's not plugged in? No lights or anything.


Is the outlet live? Does something else plugged into the same outlet work?

Does the receiver have a master power switch on the back that may have been switched off by accident.

Some - not all receivers have user replaceable fuses. If you do not see a fuse holder on the receiver near where the power cord attaches then you may need to open the chassis to see if there are replaceable fuses on the power supply board inside. Follow where the power cord connects to the chassis. It will lead to a board with a transformer that changes high voltage to the low voltage that the receiver needs to operate.

IF there are user replaceable fuses inside they will be on the power supply board.

PLEASE make sure that the unit is unplugged and has been for some time as the transformers sometimes stores residual voltage that will harm you. Don't do this unless you know what you are doing inside the unit. I recommend novices just take it to the repair center.

Also - IF you replace with the wrong fuse type and rating you can cause further damage to your unit.

Good luck and be careful.

May 26, 2014 | Sherwood RD-6108 Receiver

1 Answer

Hi. Very odd. My Philips FW-C83/22 has just stopped working. It's completely dead. There's no lights, no noise, nothing. It's like there's no power getting to it at all. I've checked the lead and fuse and...


the power supply has burned out, this is the most common failure in all receiver's, I never recommend repiring, the cost to repair is about $200.00 on average last time got one fixed, you can replace it with a new one if u watch the sales for less and the new receiver will be a far better unit with many improved functions and added features.

Jun 19, 2010 | Philips Audio & Video Receivers

1 Answer

Yamaha rx-v563 just stoped working no power no displayed nothing have removed plug and tried other power points still nothing help


Check the internal fuse inside the unit. If it goes again, after replacement, get back in touch with us. If OK check the transformer and the power switch.

Mar 01, 2010 | Yamaha RX-V563 Receiver

1 Answer

My str-k502p stopped showing the lights on the front. everytime i plug it in it makes the clicking sound like its on but nothing shows up. when i try pressing the power button all that happens is the...


Check fuses on unit .Fuses should be on right side of amp .If all fuses are okay.If a fuse needs replacement .Replace with same type and always make sure unit is unplugged .Its possible unit needs repair

Jul 20, 2009 | Sony Audio & Video Receivers

1 Answer

Primare A30.2 power amp has suddenly stopped working. Was playing OK, then after about half hour of non use (still powered up) it clicked and the green light went off. Both fuses (mains plug and in the...


Check for the fuses inside the machine, replace only with same ratings! Make sure there's no shortcircuit at the speaker output terminals. Have it checked out by your local dealer if you are in doubt.

Pat.

Oct 08, 2008 | Audio & Video Receivers

1 Answer

I have a technics 1200 mk2 turntable. It turns on properly, and appears to work, but when I place the needle on the record, I get nothing through the speakers. I don't know if the connection is being...


Turntable signal problems are difficult to locate because of the extremely low signal levels. Are you sure that you have the output of the turntable connected to a Phono input? If connected to a standard AUX or Tape input, you won't hear anything. Check for signal by turning on the unit and touching lightly the needle. You should hear a scratching sound. If not, start with a new needle.

Keep us posted.
Dan

Aug 14, 2008 | Technics Audio & Video Receivers

1 Answer

Dead


IT COULD BE A FUSE , needs to be replace , if your handy , you can do it yourself , open unit , and check where the power supply is .look for a tiny glass tube type fuse , replace , and try again , hope this helps , please rate , AJ

May 07, 2008 | Harman Kardon AVR 7200 Receiver

1 Answer

Motorcycle


try the ing. switch

Mar 11, 2008 | Yamaha Audio & Video Receivers

1 Answer

Its off & it doesnt want to turn on?


I just had the same thing happen with mine. First i blew out the 7 years of collected dust. No change. Checked the fuse. Good. Scrached head. Check. Out of curiosity i pulled the fuse out, and put a small bolt in its place. Powers on right away now. I dont have to sit and play with it for 10-15 min anymore. So, a new fuse should fix it. I will find out tomorrow.

Jan 03, 2007 | Aiwa AV-D67 Receiver

Not finding what you are looking for?
Yamaha RX-V1700 Receiver Logo

Related Topics:

74 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha Audio & Video Receivers Experts

Larry Stiles
Larry Stiles

Level 2 Expert

286 Answers

jonpoint

Level 1 Expert

4 Answers

Are you a Yamaha Audio and Video Receiver Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...