Question about SmartParts SP15MW (092566981886) Digital Picture Frame

1 Answer

Digital picture frame wont power back up

Hi there, I have a SmartPartsProducts digital picture frame model # SP15MW & it wont power up after a power outage. I have checked the power supply & it has a green flashing LED . Not sure what to do next. If there is an internal fuse I can take it apart & replace, but not sure. Thanks for any help--Don

Posted by on

  • 1 more comment 
  • Don Gair Jan 19, 2009

    Tech support said blinking led on power support meant it was bad. They said they would send out another.

  • hoboparade Mar 05, 2009

    I had radioshack test the power from the power supply and it was getting a full charge. The connection was solid, and the frame obviously is getting power from some source. I'm going to take the frame apart but if it was a fuse it wouldn't even flash when it starts. Watch it for just a split second after you press and hold the power button.
    I'm guessing a capacitor got fried or it lost connection since it seems like this is a common problem with other frames. I had the problem with an LCD monitor and had to resolder the connections in the capacitor.

  • thehugles Mar 18, 2009

    I have the same problem, there is no power in the frame. I also took it to radio shack and they checked the power source and there is no problem there, the connections are fine and they even tred it with another power supply, the problem is with the frame itself.

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers

Test the power adapter. If the light is flashing, it may not be getting the 12 volts that it needs. You can test it w/ a voltage tester or if you don't have one, take it to Radio Shack and they can test it. If it's dead, or short, replace it and then the frame will work again.

Posted on Jun 27, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Can't find instructions on how to work the frame Model # sp92


You can download the manual at
http://www.smartpartsproducts.com/content/nhome/sp92.php

Oct 10, 2010 | SmartParts INC. digital frame. 7.0 in....

1 Answer

Hi...my SmartParts Digital Photo Frame, Model number SP15MW, is not working right. It has pink vertical lines going through the photos and looks awful. I haven't used it much and can't figure out why its...


I had the same problem, I downloaded the desktop software from the manufacturer's website at: http://www.smartpartsproducts.com/content/support/optipix/index.php

It fixed my problem. Create a folder on your computer's desktop, remove the photos from your SD card, use your cable to connect your computer to the frame, then re-import the pictures to the frame using the optimization tool on the Smartparts Desktop. Works like a charm!

Aug 09, 2010 | SmartParts SP15MW (092566981886) Digital...

1 Answer

I lost the remote control for my SP15MW, Where can I get the replacement?


You may want to try smartparts website - support section - with email and phone numbers here http://www.smartparts.com/?#/support/contact_us/ and contact them to see it they can supply or which dealers sell replacement parts

Mar 23, 2010 | SmartParts SP15MW (092566981886) Digital...

2 Answers

SmartParts SP15MW photo frame won't turn on--pwr adptr shows 12 v


It's the power adapter... I had the same problem as of yesterday and today I used the power supply from my HDTV and it worked as good as new. Will have to go out tomorrow and get a new power supply.

Dec 14, 2009 | SmartParts SP15MW (092566981886) Digital...

1 Answer

RE: omnitech 8.5 digital picture frame. smartparts tells me to connect usb cable but it already is connected. tried reloading software, same problem.I am trying to copy photos to the picture frame.


I had same problem today, my software on the PC was version 3.03, I upgraded to 4.1, it seems to work better now.

These frames are a little flaky, sometimes I have to power it off, and on, for it to be recognized.

software at
http://www.smartpartsproducts.com/content/support/optipix/index.php

Oct 03, 2009 | SmartParts (1DPFSP01) Digital Picture...

1 Answer

Frame will not power up or start.


The power adapters for the SP15MW's burn out very quickly so every thoug you have power in the outlet, it is not getting to the frame. Take the adapter to Radio Shack to have them test the voltage. If it's dead, you need to replace it and then the frame will work.

Jun 23, 2009 | SmartParts SP15MW (092566981886) Digital...

2 Answers

Smartparts digital frame XPX8 won't turn on


The frame has a light sensor. If it is too dark, the frame turns off the screen. You can change the sensor setting to avoid this problem. Check out the FAQ as following http://smartpartsproducts.com/content/support/faq/news.php?newsid=16

Mar 28, 2009 | SmartParts SPX8 Digital Picture Frame

Not finding what you are looking for?

Open Questions:

See all SmartParts SP15MW (092566981886) Digital Picture Questions

SmartParts SP15MW (092566981886) Digital Picture Frame Logo

Related Topics:

380 people viewed this question

Ask a Question

Usually answered in minutes!

Top SmartParts Digital Picture Frames Experts

kakima

Level 3 Expert

96417 Answers

Bill Gilhooly
Bill Gilhooly

Level 2 Expert

94 Answers

Tony

Level 3 Expert

2598 Answers

Are you a SmartParts Digital Picture Frame Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...