Question about Car Amplifiers

1 Answer

Amplifier problem Recently I bought a Kenwood amplifier (KAC-PS201T). The problem is that the sound output is not clear as it should be and seems like the channels are mixed up. If I put the balance from the HU all to the left, music is heard from both speakers and vice versa. Wiring is all set corretly, infact I tried another amplifier and worked ok. Can I fix it myself?

Posted by on

  • Carlo Brincat
    Carlo Brincat Dec 22, 2008

    Yes it is on stereo :(

  • Carlo Brincat
    Carlo Brincat Dec 22, 2008

    hmm .. yes I called a tech last week but he told me to bring the amplifier after the xmas holidays, abt mid january. I am a technician (computer and printer repairs) but I never saw an amplifier except when it had only dry joints. I know jsut the basic on amplifiers.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 15,935 Answers

There is a mono/stereo switch on that amplifier. Make sure Stereo is selected.

Posted on Dec 22, 2008

  • blueextc3221
    blueextc3221 Dec 22, 2008

    Unless you have experience with energy storage, a certified tech will be able to help you. Find a service center or ask a local shop for a referral because unless released properly. stored voltage inside the amplifier can be fatal. Usually, there will be a nominal $10 - $20 charge to tell you whats wrong, and if you decide to repair, it will come off the repair bill.

  • blueextc3221
    blueextc3221 Dec 22, 2008

×

1 Suggested Answer

  • 14 Answers

SOURCE: kac-ps201t problem

I had a similar problem with a KAC-X812D Kenwood amplifier.
My problem turned out to be that the RCA inputs were so sensitive, they picked up interference from my head unit through the RCAs.
I replaced the head unit with a newer model, and had no problems after.

This may not be your case, but hope it helps.

Posted on Dec 17, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kenwood KAC-8103D on and off problem


it sounds like the power wire might be grounding out somewhere that you dont know of it could be by the fuse link so I would say put electrical tape on any exposed wire on the fuse link first if that don't work try change the power wire.

Jul 19, 2010 | Kenwood KAC-8101D Car Audio Amplifier

1 Answer

I recently purchased a new Kenwood KAC-9104D 1800 amplifier. I hooked it up just as I had with a previous amplifier but it wont power the subwoofers. When one of the RCA cables is plugged in and the other...


You should check and verify first the output signal in the amplifiers by using a multimeter on the db range, this is to identify good output of the amp. After that check the polarities for correct wire orientations.You should connect the speakers one at a time to check.

Jan 16, 2010 | Kenwood KAC-9104D Car Audio Amplifier

2 Answers

How many watts is it


http://www.kenwoodusa.com/UserFiles/File/Global/Consumer/Manuals/kac528.pdf

Page 7 of the manual gives you all the different configurations of this amp, and it's MAX power. FYI; Kenwood rates their amps at MAX power, not clean. Hope this helps.

Sep 30, 2009 | Kenwood KAC-628 Car Audio Amplifier

4 Answers

KAC-8070 kenwood 4-channel power amp


Audio section
Max Power Output (4 ohms, 1kHz)
Rear 70W + 70W
Front 35W + 35W
Max Power Output (4 ohms, 1kHz, 10% THD)
Rear 45W + 45W
Front 25W + 25W
Max Power Output (4 ohms, 1kHz, 1& THD)
Rear 37W + 37W
Front 20W + 20W
Frequency Response (-3dB)
Rear 2 Hz ~ 100 kHz
Front 5 Hz ~ 50 kHz

Sep 27, 2009 | Kenwood KAC-8101D Car Audio Amplifier

1 Answer

LOW VOLTAGE


start with a voltage meter see if you have 12 v

check your ground
check all your connections ... "most the time i will simply rewire the whole sound system"

hope this helps

Dec 26, 2008 | Kenwood KAC-X201T Car Audio Amplifier

1 Answer

Kac-ps201t problem


I had a similar problem with a KAC-X812D Kenwood amplifier.
My problem turned out to be that the RCA inputs were so sensitive, they picked up interference from my head unit through the RCAs.
I replaced the head unit with a newer model, and had no problems after.

This may not be your case, but hope it helps.

Dec 15, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Install my Kenwood KAC-9102D in my 2006 Acura RSX Type S


You will probably need to use a Line Output Converter (LOC). They're available at virtually any shop that sells car audio.

Many times, the outputs of the OEM amplifier will have significant DC voltage on them. This could damage the input circuits on the kenwood amplifier.

Let me know if you have any other questions.

Aug 24, 2008 | Kenwood KAC-9102D Car Audio Amplifier

1 Answer

Amp light is on but no power to my subs!


Hi There.

When you say the 40 Amp fuse blew. Was it your mains battery fuse or was it the fuse on the amplifier? If it was the fuse on the amplifier then you may have hurt the amplifier. The Kenwood KAC-8101D is a 1000 Watt monoblock amplifier. Therefore if you say that 1 of your woofers is not playing, then it is almost certainly blown if you are sure it is connected correctly. Try disconnecting it and only running the woofer that tries to play. If this woofer is still working correctly, you will notice a drastic drop if the sound of your bass. The reason for this is because you have changed the impedance load on your amplifier due to the fact that the other woofer is not working. Have your working woofer checked and replace the faulty woofer then you should be banging again.

Hope this helps!!

Jan 30, 2008 | Kenwood KAC-8101D Car Audio Amplifier

1 Answer

Kenwood KAC-PS201T


The first thing you must do is to confirm that you have voltage at the amp. Just because the fuses look good, that doesn't mean you're getting power to the amp.

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

Jan 21, 2008 | Kenwood KAC-X201T Car Audio Amplifier

2 Answers

Kenwood KAC-9152D problem


It sounds to me like you may have burnt a trace off of the bottom of the circuit board inside the amplifier. If you know how take the amplifier apart and look carefully at the traces. To be clear the traces are the lines on the bottom of the circuit board not the component side. Look carefully they can sometimes be hard to spot. If you find one solder a jumper wire across the two points. If you take the amplifier apart take care in treatment of the output transisors along the sides.

Jan 17, 2007 | Kenwood KAC-9152D Car Audio Amplifier

Not finding what you are looking for?
Car Amplifiers Logo

Related Topics:

190 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...