Question about Miele S334i Vacuum

Open Question

Purchaing a used Miele Ambiente 334i

Is an electric hose standard with this unit I know that it comes with a dual purpose un powered head and that I have to purchase a beater bar for carpet seperately but I cannot tell from the picture whether the hose also has to be purchased for the unit.

Also any site that might have information regarding parts for this unit would be helpful it is older and the Miele site does not even have it listed....

Posted by on

3 Suggested Answers

reddevil6
  • 1673 Answers

SOURCE: Miele Beater Bar

Something may have come apart under the nozzle cover, you will have to take the cover off to see. Including a picture, maybe it will help.
bdd4bda.gif

Posted on Mar 03, 2008

  • 521 Answers

SOURCE: power to power carpet head

once again remove the electrical connections and clean it and also blow the dirt and then fit it tightly and carefully.if anything broken inside replace it.

Posted on Aug 09, 2008

  • 120 Answers

SOURCE: I have just purchased a used Miele S528 and the

as long as all the wiring on the power nozzle looks secure and it plugs safely into the end of the hose then you should be fine.

Posted on May 10, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Miele S 558 hose keeps powering down while vacuuming. I understand that the newer SES 125-3 hoses are supposed to correct the problem. Before I buy, I'm wondering if this has proven to be true.


Debra, Searched the net. and the problem does seam to be poor/faulty circuit board in the hose and the SES 125-3 replacement hose is to be the fix. You could dissassemble first and clean the contacts first, to see if you can correct and extend the life of old hose. Check the attached links,instruction and guides, Good luck
"I hope this helped you out, if so let me know by pressing the helpful button. Check out some of my other posts if you need more tips and info."
just bought Miele s558 Silver Moon seems like it from 2000 or so If it in...
My Miele S5980 is cutting out How do repair the hose to fix it
Amazon com Miele SES125 Vacuum Cleaner Deluxe Electric Hose Miele Vaccum...

Jul 08, 2016 | Miele Vacuums

1 Answer

Miele Vacuum(Saturn300). Vacuum powerhead(SEB234/236) does not work, no light comes on and no power. is it the hose(SES119) or the powerhead? tried plugging and unplugging.


You need to check your voltage coming out of your hose and wand, be sure that the handle switch is in the on position. Voltage should be +/-120V. If you have voltage there then you have a power head issue. The replacement would be the SEB 228, you could also use the SEB 236. The SEB 236 is a deluxe version of the SEB 228.

If you need any help feel free to contact me.

Tim
TheVacCenter.com

Feb 24, 2013 | Miele Vacuums

2 Answers

We have a Miele Silver Moon vacuum that isn't


Hi dear.There are two type of attachments for this vacuum cleaners to pick up the pets hair,fluff & so on.They call it"Turbo & Power Brush".Turbo brush operates with machines suction & Power one operates with small electric motor which is built in the unit.They work with the same prenciple.There is a belt drives the rotary brush.OK.there are two small yellow screw underneath the unit.Please undo them,take of the cover & clean the rotary brush,check for the belts tension.It should be enough tight to drive the brush.If not ask for spare part from Miele in your country.After cleaning please put it back in order.To test it,attached to the vacuum.Turn the power on for Turbo brush,as long as suction starts,brush should start turning too.For the Power one,there should be power button on the handle to turn it on & off.Press it.It should work.On both of the unit,brush should spin good & strong enough to do the job when it's attached the surface you are vacuuming.Check the brush after each use,cleaned if neccesary. I hope that helps.Thanks.

Aug 01, 2010 | Miele s558 Silver Moon Vacuum

1 Answer

Power Problem


Hi There,

Unfortunately this is being caused by static electricity building up in the electronic controls in the handle of the hose. I've seen this problem on numerious occasions, and in fact I have the twin brother of the Blue Moon, or the Silver Moon which used the same hose, and has the same problems in my own home.

The good news is that Miele has redesigned the hoses to fix this, and I have never seen a single problem on the newer style hoses. I guess the bad news is that the hose is not cheap.

I would recommend to you to go ahead and purchase the new hose. The average life expectancy of your Miele is 20-25 years, so you still have a lot of life left in your vacuum.

Here's a link to the SES125 Hose that fits your Miele Blue Moon on our website:
http://www.govacuum.com/miele-165.html

To change the hoses out, simply push the two tabs on the end of the hose that plugs into the vacuum, and pull the hose backwards until it disconnects. You'll see on the end of the new hose electrical connectors. Simply line these up with the opposity receptacles on the canister and push the hose down until you hear a snapping noise.

I really hope that this information was helpful to you. If you have any follow up questions, or would like a clarification, please use the comment box on this page.

If this was able to help you fix your machine, please be so kind and rate my repair or leave me feedback. This is really appreciated.

Thanks again,

Chris Jones
GoVacuum.com

Jun 15, 2010 | Miele Blue Moon Bagged Canister Vacuum

2 Answers

Power head stopped working could it be the switch? could it be the motor? thanks


If its an electric head switch it off and remove the screws underneath or if it has a slide out cartridge check that the brush isn't clogged with dust. Sometimes the toothed belt can come undone if there's an obstruction.

Jun 13, 2009 | Miele S514 Solaris Turbo Plus Vacuum

2 Answers

Blue Moon Miele power head stops intermittantly


It is not a solid short. This is caused by static arcing in the wand and in the connectors from base to hose. I was able to fix mine by smearing some dialectric grease on all electrical parts in the wand(especially by the led switch) and in the three prong connectors at the base to hose. Have not had nay problems since doing this.

Apr 15, 2009 | Miele Blue Moon Bagged Canister Vacuum

1 Answer

Meile SEB 213 powerbrush cuts out


Your problem is either in the wand, assuming you have the telescopic dark grey electric wand. The only other thing it could be is the hose, once again, assuming you have the electric hose with either the rocker switch that shuts down the power brush, or the deluxe hose, with the electronic suction control, as well as the brush shut off. Miele wands and hoses are notorious for causing power brushes to cut off. If your Miele is under two years old, I would suggest taking it to a autherized Miele service center, and see what, if any, warranty you have left, and have it checked out. Let me know how you make out.

Jan 14, 2009 | Miele SEB 213-2 Vacuum

1 Answer

Electrical to power head


Greetings from GoVacuum,

There could be a couple of reasons why you are not getting power to your power brush. The first and most popular reason is the hose of the machine. Sometimes the wires inside of the hose will go bad, causing the power not to get down to the power brush, but the rest of the vacuum working well.

You can test this hose easily. You will need to go out and purchase a continuity tester from Home Depot or Radio Shack. When the electrical test is in the continuity position, remove the hose from the canister, and put one of the testers on one of the electrical prongs that plugs into the canister itself, and put the other tester into socket where hose connects into the wand, you should have continuity on both terminals. It is important that the switch that controls the power brush is turned to the on position. If one of the terminals does not have continuity, you will need to replace the hose itself.

If both terminals have continuity, then you should then follow the same procedures on the electrical wand. If the wand tests ok as well, you may have a loose connection in the power brush.

Please let me know if none of these solutions work for you, I can then shoot a video showing you how to open the power brush to check for loose connections.

You do have a Miele S548, correct?

Please feel free to email me with any questions, I really enjoy sharing my knowledge of fixing and repairing vacuums, and would be delighted to answer any questions you might have.

Chris Jones
GoVacuum.com
chris.jones@govacuum.com

Aug 09, 2008 | Miele S548 Bagged Canister Vacuum

2 Answers

Power to power carpet head


it sounds like the spring on the cord reel let go. difficult to reinstall. it may have been broken already and that is why it came off. it is rather meticulous trying to work on a cord reel. many can't be disassembled without breaking

Aug 09, 2008 | Miele S548 Bagged Canister Vacuum

2 Answers

Miele Vacuum cannister


Most times you have to replace the neck on the powerhead. Sometimes the switch in the handle of the hose will have a bad solder connection. But S300 is not a good model number, also the powerhead has its own number on the bottom, so couldn't look up parts for you.

Feb 21, 2008 | Miele S300 Bagged Canister Vacuum

Not finding what you are looking for?
Miele S334i Vacuum Logo

Related Topics:

266 people viewed this question

Ask a Question

Usually answered in minutes!

Top Miele Vacuums Experts

Ryan S
Ryan S

Level 2 Expert

328 Answers

Roger Potts

Level 3 Expert

694 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Are you a Miele Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...