Question about Lanzar 2H 1000W MOSFET AMP Car Audio Amplifier

Open Question

Rca jacks when i hook up both jacks to amp speakers sound terrible but with one it works eaither side but not both what could br the problem

Posted by on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Sony XM-GTR4A


contact sony .... or check your head unit is recieving

Mar 29, 2014 | Sony Car Amplifiers

1 Answer

I have a brand new soundstream xxx 6500d amplifier and when i installed it for the first time protect mode light come on even without rca jacks and speaker wires hooked up. any1 can help?


You need to plug in the RCA and speakers you could blow the amp. The amp is sensing no Input and No output. I would unplug the amp wait around 30 seconds then install the rca and speakers THEN install amp to battery + cable. You should be ok.

Jan 24, 2010 | Soundstream Xxx-6500d Power Amplifier Xxx...

1 Answer

Hooked up the amp, lights up, fans kick on and run fine, speakers hooked up proper, no sound? hooked up speakers to another amp and they work fine. Fuses are all good too. Thoughts?


could be bad rca cables or no output from the radio rca outputs. the sub control may be turned off on the radio (ive seen that alot at my work). if all that is fine, the amplifier may be bad. the rca cables may be plugged into the "out" section of the amp. gotta look at all the small obvious things first. good luck.

Dec 18, 2009 | AudioBahn A2300HCT Car Audio Amplifier

1 Answer

My alpine v12 turns on but no sound


no you don't have to hook up both of the power terminals. but should have it hooked up so you get the proper power to the amp. use a disubution block with two 8 gauge wires.

do you know if the radio's rca jack's are good? have you ever had another amp in the car? if it worked before try new rca's from the radio to amp. recheck all connections from amp to speakers and make sure no wires fell off.

Sep 22, 2009 | Alpine MRD-M605 - V12 MONO AMP 600WX1 RMS...

1 Answer

My kac 7202 amp turns on but nothing comes out with everything hooked up


Use process of elimination. Connect the speakers that are hooked up to your amp directly to the radio, if they work check your amp. Make sure the rca jacks are connected properly. Sometimes the radio has rca's that are "inputs", make sure they're connected to the "output" rca's. If those are ok, your amp may be faulty. Try the amp on your friend's car see if it works. If it doues your radio might be at fault...or just bad rca cables. like i said, use process of elimination to narrow down the faulty equipment.

Sep 14, 2009 | Car Amplifiers

1 Answer

Trying to hook up amplifier to after market 6by 9 using factory radio


You can not connect the speaker lines directly to the RCA inputs of your amplifier. But you can connect them to your amplifier if your amp has a high level input. Most of the time it looks just like the speaker jacks of the amp, but smaller. It will be labeled high level input or speaker input. Sometimes an amplifier will have a jack for a wiring harness just for this purpose. Some amplifiers have them and some don't.

If your amplifier does not have them, you can purchase a line level adapter at most anyplace that installs car stereos. it converts the speaker level to the proper level of the RCA input.
Just follow the instructions on how to connect it.

If you try to connect the speaker outputs directly to the RCA input of the amplifier you will blow up the pre-amp in your amplifier.

I hope this was helpful to you, if so a good rating is always appreciated.

Thanks and let me know if you need more help.

Jun 20, 2008 | Car Amplifiers

1 Answer

Ok this problem is killing me...


maybe the speaker is bad

First try one thing, switch the rca jacks around and see if the other speaker stops working this time.

If so the problem is in the rca jack or head unit.

If the same speaker is still not working, the problem will be the speaker, you will have no other options left since you changed amplifiers and checked all wiring.

Let me know if this helps you

Jun 18, 2008 | Visonik Dual Bass Box with Amplifier Car...

1 Answer

Amp not working


1. Did you witness this amp ever working if not then you may have a blown amp. Hook up the speakers, get a portable player with a head phone jack get one of those cables with a headphone plug on one end and RCA's on the other plug the portable player into the amp and hit play. If sound comes out then your problems are elsewhere. If not I'm afraid your amp is probably toast. If the OHM rating of the speakers are too low for the amp then the amp will go into protect. This will be indicated by the protect LED lighting up or the power led changing color from say green to red.

Jun 28, 2007 | Kenwood KAC-729S Car Audio Amplifier

Not finding what you are looking for?
Car Amplifiers Logo

Related Topics:

19 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lanzar Car Amplifiers Experts

Radames Pagan
Radames Pagan

Level 3 Expert

195 Answers

Joe Alexander
Joe Alexander

Level 2 Expert

64 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Are you a Lanzar Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...