Question about Sta Rite Sta-Rite Max-E-Therm High Effiency - Propane Heater - 333,000 BTU

1 Answer

Lpg spa heater cuts out at 86 degrees....

Worked great up to 104* then started quitting at 94* now 86*
service heater light comes on, board indicates flue sensor error. installed new one, didn't help.
put in new board, didn't help. new thermostat, didn't help. new limit switches, didn't help. gas pressure okay at 12 column inches. in short, have swapped out every working part one by one, nothing helped. the heater repairman is stumped.
what am i missing?

Posted by on

  • ifixpools May 11, 2010

    Do you have an automated time system on the pool? Jandy, EasyTouch, etc.???



    If so, check the water temp on the panel inside when the pump is running. If it is not the same as a physical check of the water or the temp display on your heater, you have the solution.



    A sensor that is 10 degrees off will shot a pool heater off at 94 if it is set to 104. Most time management sensors fail early at about 8-10 degrees too high. Eventually they fail to about 130+ and the heater will not fire at all.

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 4 Answers

Is this an indoor heater? Vent could be blocked.

Posted on Dec 04, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Bryant Gas furnace model number is 373LAV036095 the pilot light won't light. Gives us indication that the pressure value is stuck??? Sends into lockout mode. Where is the pressure value located in the...


This is a down flow unit. There is no pressure valve on this unit. Here is all the parts on this unit.
1. Manual - reset, when used.
2. Blower and blower motor
3. Relief box also known as a exhaust flue.
4. Gas valve control knob or electric switch, ON/OFF
5. Gas Valve
6. Gas burner
7. Ratting plate
8. Blower door safety switch
9. Blocked vent safeguard tube and switch
10. Gas Manifold
11. Manual limit switch (2)
12.Hot surface ignitor
13. Flame sensor
14. Inducer blower motor
15. Control board with relays and transformer.
That is all the parts. The first thing the heater gets a call from the thermostat to the control board marked W. The board sends 24v to the inducer fan relay which makes and causes the inducer fan to come on now there is a small tube that runs from the inducer fan box to a switch when the switch makes it sends power to the board which proves you have cleared the exhaust flue then the flat surface ignitor starts to glow and then gas valve opens and fires. now if this tube is stopped up the heater will not fire and will lock the unit out. Also if the flue is stopped up with trash it will do the same thing. If you are not familiar with gas heating units you should call a service company out and check out the system there is a lot of things that need to be checked out every heating season as to keep you and your family safe.

Mar 02, 2015 | Heating & Cooling

1 Answer

Have a Pentair Easy Touch. Says spa water temp is 86 thermometer in spa says 96 have it programmed for 104 and indicator is on for heater but can't get it higher. Rheem heater is turned all the way up


could be the heater is defect, the thermostat is defect or the thermometer is defect. Try to rule out 2 of these and you know what is wrong. Or het heater just does not get any power?

Nov 01, 2014 | Pool & Spa

1 Answer

The OH Light keeps coming on although the temperature never exceeded 100 degrees.


check your recirculation pump it sounds like it isnt working or plugged filters

Oct 16, 2014 | Pool & Spa

1 Answer

Leisure Bay spa will not heat past 86 degrees. Element and sensors are new. Spa has excellent flow and correct voltage at terminals.


if the spa does not heat up to 104 degrees then the temp sensor is what you are going to need.
Are there error codes showing on the screen of the topside?
You will need to know the model number of the control box or the model number of the heater tube in order to get the proper sensor.


Rod
US Parts Center
888-521-6183

Feb 09, 2013 | Pool & Spa

1 Answer

My leisure bay spa will not heat past 86 degrees.


If your spa will not heat up to the 104 degrees or what temperature you set it at then you have a bad temp sensor.

RodUS Parts Center888-521-6183

Feb 09, 2013 | Pool & Spa

1 Answer

I have an Aqualink system, spa set to 104, it will heat to 94 and stay there, temp sensor is working, took water sensor out of line, plugged line, assumed heater would just keep heating, it did heat a


The heater may be wired just fine. The aqualink uses its water temp sensor to call for heat based on what you've set the thermostat to on the aqualink. However, most heaters have built in thermostats that over-ride the aqualink. Those thermostats come factory defaulted not to go over 94. Check your heaters manual on how to adjust the thermostat on the heater. Your heater should have its thermostats set to 104 and the aqualink will control the actual temp of the water by calling for heat based on what you've set the thermostat on the aqualink for. Hope this helps.

Oct 16, 2012 | Jandy Aqualink Rs4 One Touch Control...

1 Answer

Pentair Minimax has worked correctly for 5 years. Now is comes on and the heater starts up for maybe 30 seconds and shuts off for a minute or two. It cycles like this for a really long time... a couple...


Usually this means that the flue temperature sensor indicates too high a temperature. this is usually caused by too low water flow through the heater and therefore both the water and the flue temperature is too hot. You should check all the baskets, the pump impeller, the filter and any return devices to make sure water can flow at full rate. It is unlikely but maybe the flue temperature or control board is defective.If all else fails you may be able to call the Pentair technical support line to help diagnose the problem. I hop this helps.

Aug 13, 2011 | Pentair Minimax NT Heater

1 Answer

I have a Pentair Mastertemp 400. It worked fine for 3 years until the temp sensor went out and both (internal and external) were replaced about a year ago. It then worked fine for about another 7-8...


You might have a much bigger issue than the temp sensor. When the heater is running hold the "pool" or the "spa" button for 12 seconds. This will show the exhaust temp, if the temp is rising above 375 degrees with in 1-2 mins then your not getting the heat out of the heat exchanger.
One other thing to check would be an external by-pass. If you have an external by-pass make sure the by-pass is set correctly. Opened or closed to much can cause the problem your having.

Mar 04, 2017 | Pentair MasterTemp 400000 BTU Pool and Spa...

Not finding what you are looking for?
Sta Rite Sta-Rite Max-E-Therm High Effiency - Propane Heater - 333,000 BTU Logo

305 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sta Rite Pool & Spa Experts

Jay Finke
Jay Finke

Level 3 Expert

1264 Answers

john h

Level 3 Expert

9052 Answers

steve morris
steve morris

Level 3 Expert

1675 Answers

Are you a Sta Rite Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...