Question about Polaroid FLM-2632 Television

1 Answer

No Power My t.v. was working fine, and has been just great for the month or so that we have owned it. This morning I went to turn it on and I noticed that there was no red L.E.D. light on which is always on when the the unit is off. I went to turn it on using the remote and nothing. Usually when I turn it on a blue light comes on to let me know that it is working. I used the remote and still nothing and I even tried to manually turn it on using the power button on the t.v. itself. Nothing happens. I am using the recommended surge protector, that we were told to buy, by the sales assocciate. I am at a complete loss and frustrated, for this t.v. is very new. If you have any suggestions, I welcome them, otherwiswe I guess I will be taking it back to the store along with my receipt. I thank you for your time. Sincerely, Michael Meredith Citrus Heights, CA

Posted by on

  • 1 more comment 
  • Anonymous Dec 08, 2007

    I have exactly the same problem. TV is a year old.

  • nketter May 05, 2009

    i have the same problem but my tv has no warranty because i bought it on ebay .if anyone know's the part i require them please let me know

  • Anonymous May 23, 2009

    I have the
    Polaroid FLM-2632 - 26" LCD TV and I have the same problem. The TV is only about three years old. This is the biggest waste of a television I have ever bought. I called Polaroid and they told me they could replace the control box for almost 300$ which is somewhat of a discounted price but I could almost just go buy another tv for what I would spend to fix this one. PISSED!!!!!!!

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have the same TV and it did the same thing. I called Polaroid's customer support line and they were very helpful. They sent in a work order to the local servicer in my area. I then got the number of the place (VIEW ELECTRONICS) and called them a few days later. They said that it was a very common problem and that they knew exactly what part it needed and ordered it. At the moment, i am waiting for the part to arrive and when it does i can just take it into the store and it will take them about 20 minutes to install and that should be it. I'm not sure what caused it but hopefully this part will fix it. Hope this helped...

Posted on May 26, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

4 Answers

I have a 06 Mercury Milan with 120k miles. Yesterday morning I noticed a strange smell when I got in my car; hard to describe but almost tangy? I thought maybe my daughter dropped some food between the...


Sounds like your belt broke or came off. If the power steering quit working too. The belt runs power steering, alternator, A/C unless it is different belt. Have you looked under the hood at all? If it turns out that it isn't that. Then check all of the connections on the battery and alternator. Check fuses for charging system.

I hope this helps.

Sep 05, 2010 | 2006 Mercury Milan

1 Answer

My amp will not power up


try hotting your remote wire to your batter if it don't come on u will need a new amp

Jun 14, 2010 | Diesel Audio NS-1000 Car Audio Amplifier

2 Answers

I have 1998 Chevy Silverado with over 200,000 miles. One morning I started it up just fine, backed out of the drive way, and it just died. I turned the ignition to off, and turned it back on and parked it....


Check your battery terminals. They may be corroded or just loose. If you get it running again have the battery and charger tested at an Advance or Autozone.

Hope this helps.
Rich

Aug 19, 2009 | Chevrolet Silverado 1500 Cars & Trucks

1 Answer

RCA R52WH74 power light blinks but no power


i unfortunately cannot help you with your problem, but i have a question, how did you disconnect the front panel?

Mar 24, 2009 | Televison & Video

1 Answer

Transmission help?


finally got the problem solved, there was a short in the wiring next to the computer, had the short fixed and the transmission is working fine now

Dec 16, 2008 | 2000 Nissan Sentra

2 Answers

My TV died this morning


Sounds like a power issue with the unit you will have to call the customer suppport line and have them refer you to an authorized dealer or send it back to them.

Aug 06, 2007 | Emerson EWL3706 37 in. LCD Television

7 Answers

My screen froze when i started a video. how do i unfreeze it?


the same shit happened 2 me yesterday night. this is the second time it happend. the screen is blank but it still has alight. this morning i noticed that that light went off so i turned it on and it worked but it said battery too low so i charged it and its working. so give about a day to see iff it works, and i hope it works for u

Apr 21, 2007 | SanDisk Sansa e250 MP3 Player

Not finding what you are looking for?
Polaroid FLM-2632 Television Logo

175 people viewed this question

Ask a Question

Usually answered in minutes!

Top Polaroid Televison & Video Experts

The Knight
The Knight

Level 3 Expert

75767 Answers

matt martin
matt martin

Level 3 Expert

1229 Answers

Jaime Hernandez

Level 3 Expert

2336 Answers

Are you a Polaroid Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...