Question about Behringer B1520 Pro Eurolive 15" 2-Way Speaker Pair Main / Stereo Speaker

1 Answer

While playing it (the speaker just quit on me

It is not the fuse. Checked it out. Didn't seem to blow out or anything like that. Just quit making sound while I was using it.

It is a 2-way 400 watt powered loud speaker with integrated sound processor. It is the B215 NOT the B1520

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 3 Answers

The same problem in the B300 is fix by changing ic 7815 and ic 7915. Dan

Posted on Jun 07, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

E315 cerwin vegas speakers and one keeps blowing a fuse when I turn it up to the normal volume I play them.Can I use a bigger fuse or is it the speaker?About a yr old rarely used until the last few mo


Try playing the speakers at a friends house or something to see if you blow their fuse. If you don't then you know for sure that you need a bigger fuse, but if you do then it's the speaker.

Jun 03, 2013 | Audio Players & Recorders

1 Answer

Front and back speakers quit working but my subs still work. Is this a fuse problem?


Don't know,but I doubt each different speaker would be fused

Something NO ONE seems to understand IS

Look at an actual fuse
They are no more than a piece of wire
They don't do anything

They just sit there and wait for high current
flow,that causes them to get hot & melt,thus
breaking or opening the circuit they protect.

If a fuse ever opens or blows you DO NOT replace it

You find out why it blew,you have problems down steam
in the wiring.

Apr 27, 2011 | 2004 Nissan Sentra

1 Answer

My speakers dont seem to be working. I checked every wire and fuse. The power shows its on. It did spark a little. I checked everything. Unplugged battery and amp put back in. When i touch the remote...


Some amps don't have fuses, they reset themselves, what metal are you touching the remote wire to? The remote wire is a + wire. So you should NOT be touching it to anything other than something +. So run the remote wire to the back of the radio where it should be, there should be a blue wire on the back of your radio if its aftermarket. If its a stock radio then run it to your fuse box (I don't know which one you'll have to figure that out yourself) Also I've had the rca wires quit working on me before, so you may need a new set.

Feb 17, 2011 | Rockford Fosgate T600-2 Car Audio...

1 Answer

There is no sound coming from the speakers on the SC-HT900 dvd home theater sound system. It used to make a loud pop sound but then would still work. Now it does not make any sounds. The dvd will play...


May be a fuse inside blown , if it makes a loud pop that can take out a fuse, If you find one blown , replace with same type and try machine .Dont replace with higher rated fuse though , if it keeps blowing. Try using headphones and if you get sound , may be speakers.
pete

Nov 29, 2010 | Panasonic SC-HT900 System

1 Answer

My sub quit working the other night i had it playing for about 10 hours and it just quit


what kind of amp fosgate was bad for blowing the fuse inside check to make sure all your wires are connected and no breaks

Aug 11, 2010 | Rockford Fosgate Car Audio & Video

1 Answer

Stock radio 01 eclipse radio turns on, cd plays but no sound from speakers. any thoughts


Assuming you have checked your wiring to the speakers and they are all intact, you are looking at an amplifier failure.

If you have the inifnity system there is an external amplifier under the passenger seat. You can check it's fuse in the fuse box on the drivers side dash endcap. The fuse holder is an add-on fuse holder to the right of the block (as you look at it), not in the main fuse block.

If the fuse is blown, replace it, but likely it will blow again. The external amps have a very high failure rate and unfortunately are quite pricey.

If you do not have the amplified system, the radio internal amplifier has gone out, and the radio will need to be sent out for repair or replaced.

Oct 25, 2009 | 2001 Mitsubishi Eclipse

1 Answer

The sound quit working while playing the


What type instrument is it? Yamaha makes a bunch of different ones. Specify a mdel number.

Oct 01, 2009 | Yamaha Music

1 Answer

Amp won't put out sound


Hi there,

A lot of Amps come with fuses as a safety mechanism so you don't blow the speaker and/or internal components in the case of a power surge etc. Check for a blown fuse. Sometimes they have a fuse holder in the back of the amp and it is labelled "fuse" which cetainly makes it easier to find. Hope this works and helps.

Nov 17, 2007 | Prime 40 Watt 2 Channel Lead Electric...

Not finding what you are looking for?
Behringer B1520 Pro Eurolive 15" 2-Way Speaker Pair Main / Stereo Speaker Logo

Related Topics:

652 people viewed this question

Ask a Question

Usually answered in minutes!

Top Behringer Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

4861 Answers

The Knight
The Knight

Level 3 Expert

72670 Answers

Serge Lavallee

Level 2 Expert

67 Answers

Are you a Behringer Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...