Question about Alpine MRP-M350 Car Audio Amplifier

1 Answer

My sub quit working

I have a kenwood head unit, a 300 watt alpine amp, and a 10 inch boston fused subwoofer. i got in my car and my sub wasnt working. I checked the fuses in my sub and they were fine. Then i checked the fuses in my amp and they were both melted. i replaced them and i still have no sub. What has happened and why and do i need to take it in and have it fixed?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

First off you should have installed an inline fuse block that fuse will pop first an inline fuse is cheap go to a wall=mart it will run you around 10.00 that gets mounted under your hood cut your power cable in half the one part of the cable should be cut 12 inches that will tie into your possitive terminal on your battery after that is all tightened to your battery you will strip about an inch of coating offf of your power wire tie that into the end of your fuse block make sure it is tight than do the same to the other side just measure from there to your mounting spot for your amplifier and tie your power cable into your amplifier use 8 gauge power and ground cable... your problem with your amp is that you burned up a couple capasitors or even a resistor i just fixed an amp that both fuses were smoked just tear your amp apart look under the control board you will see were a sauder joint is cracked those capasitors and resisters are very cheap there made out of ceramic i just got done repairing my friends amp works like a new one.. good luck if you have problems or w you get it fixed email me.. gordo8785@yahoo.com best of luck buddy..

Posted on Jan 10, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What amp would be better to use with what speakers/sub? I have a KAC-7202 kenwood 920W maximum power (150wX2 RMS, 4ohms) (230wX2 RMS 2ohms) and then the other amp I have is a Alpine MRP-M500 mono power...


I'm using that Alpine right now for 2-12" subs and I have compared it to 6 or 7 other amps this month and most were 4 channel 150Watt/Channel Bridged to 300Watts x 2 and found the Alpine to be superior in both sound quality and loudness. The Alpine has also not turned off even with full volume for hours at a time, Very solid amp I was very surprised due to it's size!

Apr 04, 2013 | Kenwood Car Amplifiers

1 Answer

Two questions. 1) can my amplifier over-power this sub; kicker L7 15 inch dual voice coil 1,000 watts RMS wired for 2 ohms? 2) is my amp too small for this sub-woofer? thank you for your time.


No, your not over powering your L7, your underpowering your subwoofer.
Your Kenwood is
500W x 1 at 4ohms [20-200kHz 0.5% THD]
900W x 1 at 2ohms [100Hz 1.1% THD]
Your L7 is:
Max Rec Amplifier Power (WATTS PEAK/RMS)* 2000/1000But its ok for your subwoofer, alteast your not giving it to much stress. But personaly, get another mono amplifier that would match your subwoofers rating.

Apr 08, 2011 | Kenwood KAC-9103D Car Audio Amplifier

1 Answer

I have the MRP-M1000 amp. I want to hook up 2 alpine subs to this amp. Which alpine subs would be the best for this amp? Please be specific with ohms and watts.


Your best bet will be to wire 2 subs in parallel to the amp. Each sub should be rated for at least 300 watts rms at 4 ohms. This will give you a total impedance of 2 ohms, and your amp will put out 600 watts rms at that impedance. That way, each sub will receive 300 wats rms. I would not recommend wiring subs in parallel, as you will need two 1 ohm subs at 300 watts rms, which are harder to find and will be more expensive. A parallel circuit is the most efficient way to do it.

Feb 23, 2011 | Alpine MRP-M1000 Car Audio Amplifier

1 Answer

I have two 12 inch rockford p1 punches powered by an 800 watt sony explode amp (2 Channel) and i want to install another 15 inch kicker with a 1200 watt amp not sure the model, i got it from a friend and...


I have a similar setup & I just run the second amp straight off the other amp by running positive & remote wires directly from 1 amps positive & remote inputs to the others amps inputs. But my head unit has RCA inputs, (sub in & front & rear inputs) so from my 4 channel amp I run 2 6 inch alpine S's to the front to the front RCA inputs of the head unit, & 2 Pioneer 440w 6x9 inch speakers to the rear inputs. & my 800w 12 inch sub from my 2 channel amp to the sub woofer inputs on the head unit. Has blown my eardrums for nearly 12 months now great stuff! Hope this has helped

Mar 12, 2010 | Sony Car Amplifiers

1 Answer

Amp burned out but fuses still good?


this is caused by inproper wiring from the speakers/subs to the amplifier.. an amp will still put out power to subs and speakers when it's wired improperly but it won't last for very long doing it... 6 months is longer than usual....

Dec 05, 2009 | MA Audio M1900XE Car Amp

3 Answers

I have an alpine MRP-500 amp that used to work great with my 2 10" Type-R subwoofers. Out of nowhere the sound just stopped working and still will not. I had the amp and subs tested and the guy said it was...


  • make sure the subwoofer level is up on the head unit.
  • Make sure the RCA cables are good.
  • Make sure the remote wire is connected and has 12v+ when the head unit is on.
If the remote wire is not turning on the amp, its not going to work. To hot wire it to see if thats the problem, just run 12v+ to the remote jack. That will turn on the amp.

Nov 22, 2009 | Alpine MRP-M500 Car Audio Amplifier

1 Answer

I have 2 6x9 speakers up front 4 6 1/2 3-ways


Hello rjmiller4039,

Although amps with 5 channels are pretty rare, you can get one. Alpine, Boston Acoustics, Infinity, JL audio, MTX, and Polk all have 5-channels ranging in price from around $350 up to around $1,000. The Alpine PDX-5 will output 75X4 watts RMS for the front and rear stereo channels and 300 watts to the mono sub channel. It is priced at $599.99 at Crutchfield.

Hope this helps.


Sep 18, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Got jl300/2 amp confused which subwoofer sounds good


Hello drsubhakar26,

JL W6's will perform well with from 150-600 watts RMS. W7's with from 150-500 watts. Less expensive Alpine Type R's work OK with from 200-500 watts RMS. Either of the brands will sound good. None of them will perform to their full potential with 300 watts RMS. Powering any sub with a 2-channel amp is a compromise. A monoblock is more efficient.

Hope this helps.

Jul 12, 2009 | Jl Audio Slash 300/2 Car Audio Amplifier

1 Answer

I have an alpine head unit and a kenwood 1000 watt amp. I have two 12" subwoofers hooked up to the amp and thats it. I got my tweeters, and door speakers powered by my head unit. The bass was cutting in...


your amp may have burned out or try checking the fuse in the amp and the car also your channels may be burned or you may jus have water damage to the amp

Feb 18, 2009 | Kenwood KAC-7202 Car Audio Amplifier

1 Answer

Subwoofers cut out while driving but amp LED light is still on...


To test if subs are blown push them in with your hand lightly and listen for any crunch noise if you hear one then they are blown

Jan 12, 2009 | Car Amplifiers

Not finding what you are looking for?
Alpine MRP-M350 Car Audio Amplifier Logo

389 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1128 Answers

Are you an Alpine Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...