Question about Amplifiers & Preamps

1 Answer

C325 BEE Hi, Did you solve you issue with the C325 BEE ? If yes, how ? Thanks a lot in advance - I have the same probem with mine. Stepahne

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I didn't solve the problem myself, but I knew a man who knew a man at the BBC who could. The problem was caused by an overheating condenser. You'll need to find an electronics expert to identify what condenser. 
I have had no problems since. Good luck!

Posted on Dec 13, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Left channel doesnt produce sound as vu meter don't represent any output as well. Think perhaps the mono stereo switch could be the issue, seems like I was able to get channel running by flipping switch...


Hi
from your description it looks like the switch causing this problem
replace the switch might solve this problem unless its cause some short on the main circuit
if you want to fix he Amp let me know

ecrdn@yahoo.com

Jack

Oct 19, 2010 | Mcintosh MC352 Amplifier

1 Answer

Hi please help i cant find the specs for the C320


Not much - I saw one quote at 40, one at 50 watts rms. Strange that the manual doesn't include specs.

http://www.amazon.co.uk/Nad-C320-BEE-titane-Amplifier/dp/B0001HYIMS

May 11, 2010 | NAD C320 2-Channel Amplifier

1 Answer

Hi, i have a nad c325 bee amp and i have a problem with hooking up speakers. I have just the tiniest amount of sound coming out so there's some signal there. I have tried different speakers so i know its...


Before you continue, turn the volume DOWN. If you can't hear it at mid-volume there's no sense in spinning the volume knob higher. You'll only endanger your ears and speakers if you suddenly resolve the switch or whatever is the problem.

Are all sources acting the same?

Check these things (from the manual):

Tape Monitor selected?

Muting?

Headphones inserted?

Jumpers missing between Pre-Out / Main In?

BTW: the manual is available at retrevo.com

Apr 06, 2010 | NAD C325BEE Amplifier

1 Answer

Sound probem of marantz amplifier at right side.


sure it is not the speaker?
switch them and check

Mar 02, 2010 | Amplifiers & Preamps

2 Answers

NAD C320 BEE - goes silent. Only yellow light.


Hi,
Just came accross your post accidentically, while reparing my own C320BEE. May be it 's too late for you now, but it could help others: I had the very same symptoms as you described and after a long search found out that the trouble was R45 in one of the 18V regulators. (R45: 33 ohms 1/2W fuse resistor, situated more or less half-way between the two "metal towers" on the main board. Replace by a somewhat stronger type 1W or so.
Likewise R46.)

Dec 23, 2009 | NAD C320 2-Channel Amplifier

1 Answer

What are the Behringer EP2500's output stage transistors?


Faichild/Toshiba make the output transistors for the ep2500, part numbers 2SA1943 and the 2SC5200. Beware though there are a lot of dodgy fakes around on ebay. Profusion are excellent. Heres the links for them.
http://www.profusionplc.com/pro/gex/pcatdtl0?ipartno=2SA1943-O
http://www.profusionplc.com/pro/gex/pcatdtl0?ipartno=2SC5200-O

Nov 27, 2009 | Behringer EUROPOWER EP2500 Amplifier

1 Answer

Hi My Fender Stage 100 DSP has a probem in that it doesnt always power up the first time you hit the off / on switch sometimes it takes two or three times before it turns on. It never has not turned on at...


It sounds like a power supply problem. If you can find the power supply board, look for bad solder joints, look for caps that might be bulging on the top, could be a leaky cap. I'm not sure of your power button, but it could be faulty.

Oct 22, 2009 | HHB Radius 50 Tube Amplifier

1 Answer

Com terminal on MC2205


Typically the black is common and the red positive. The only difference will be the direction in which the speaker cone moves. Either it will move outward or inward. In the correct connection polarity, the cone should move outward. Be careful that both speakers are connected the same way. This is actually just as important. If they are hooked up differently, they will be out of phase and you will notice a significant DROP in low end response.

Dan

May 12, 2009 | Mcintosh MC300 Amplifier

1 Answer

HiĀ  I have a C325 BEE and it turns off after 15 min What can I do ?


It sounds like the CD player is going into standby mode. When this happens it is usually a power supply issue. Look for bad capacitors or solder joints in the power supply. If you don't know what a bad cap or solder joint looks like, take it to a NAD repair shop.

Dec 12, 2008 | NAD C325BEE Amplifier

Not finding what you are looking for?
Amplifiers & Preamps Logo

Related Topics:

79 people viewed this question

Ask a Question

Usually answered in minutes!

Top Amplifiers & Preamps Experts

 Grubhead
Grubhead

Level 3 Expert

4584 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

68223 Answers

Are you an Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...