Question about Thermaltake A2397 Silver River R 2.5in Hard Drive Enclosure Retail Drive Case

1 Answer

Not working Just got this a couple of weeks ago. I have a functional Hitachi drive installed in it. I am running XP Pro. I am using the branched USB cable. The lights come on but my computer doesnt see it at all. Does not say found new hardware, when I do a new hardware install it does not even see anything new. Just totally invisible. ARRRGHHHHHHHHHHH

Posted by on


1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 5 achievements.


    An expert who has written 50 answers of more than 400 characters.


    An expert who has answered 200 questions.

  • Expert
  • 202 Answers

Has it worked since you received it? Can you hear/feel the drive starting or getting any power? Are any of the pins bent where the drive attatches to the case? Sounds like a power issue on the enclosure if your sure the drive is good. Try a different USB port/cable. Does the USB port work for other devices i.e.printer? Sounds like a returner. Let me know what happens. Good Luck, Tim

Posted on Mar 08, 2007


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Getting system to recognize Hitachi CinemaStar P7K500

If you have OC that motherboard, roll it back. The drives that you are using are dinosaurs compared to the motherboard. Legacy issues exist.

Mar 03, 2017 | Hitachi CinemaStar 7K500 HCS725032VLA380...

1 Answer

Good day, dear Experts :) My MB is an Asrock 775 VMS with WinXP SP3 , Intel Celeron 2.8 GHz , 2G RAM , PS Chieftec 500V. I use the motherboard's AGP slot for VC, preferring various Radeon cards, like...

The HD4650 is a power hungry card. If the entiresystem refuses to start, then the power supply may not be able to run the configuration.
Of course, this is just a possibility, or your card is just damaged.

Mar 11, 2011 | Asrock 775VM800 Motherboard

1 Answer

I run Window XP Pro. A couple of weeks ago, the plug and play stopped working. I plug in a flash drive, it gets read but it doesn't "pop up." How can I get that feature back?

Add a DWORD value in the following key, and name it EnableBalloonTips. Set its hex value to 1.


Jan 04, 2010 | Microsoft Windows XP Professional for PC

1 Answer

SIIG Hi-speed USB 4-port cardBus - iphone/flashdrive problems

Remove your device from the device manager and reboot unit.
Restart and reload device drivers.
Make sure the driver are for xp pro

Nov 14, 2009 | Electronics - Others

1 Answer

T40 intermittently crashes and recovers "from a serious problem"

If you have not upgraded of changed your power supply, you probably should. Also, you could be having troubles with your RAM. Have you try to perharps repair or re-intall window?

Let me know

Apr 13, 2009 | IBM ThinkPad T40 2373 Notebook

1 Answer

Smartdisk Firelite usbflb80 stopped working

My Smartdisk Firelite 80 gig Mini-Drive will not power up when plugged into the front or rear USB Ports (Windows XP Pro System). Last used successfully on 4-Apr-08 with no issues. Any suggestions?

Feb 22, 2008 | FireLite (USBFLB80) Hard Drive

2 Answers

USB port is not working under windows xp sp 2

you can try the following steps.
Install the driver for the camera and the ipod as XP is preloaded with drivers for cameras for only selected models only.

Hope it helps.


Dec 30, 2007 | Soltek SL-915G Pro-FGR Motherboard

1 Answer

External HDD

I have 2.5" HItachi 120GB and the same problem !!

Nov 16, 2007 | Hitachi USB 2.0 to IDE 1.8" Aluminum...

2 Answers

Seagate freedesktop agent 500gb, not detected on windows xp

I am facing the same same problem with my freeagent 750. It work some time, but most of the time it shows u in My Computer, but cannot enter. Couple of time if you run "chkdsk <Drive Letter>:/R" re-scans the entire hard disk and then it shows up. But that too stopped working now :-) Still hanging around for a resolution.

Nov 12, 2007 | Seagate FreeAgent Pro - 500GB, 7200 RPM,...

Not finding what you are looking for?
Computers & Internet Logo

Related Topics:

172 people viewed this question

Ask a Question

Usually answered in minutes!

Top Thermaltake Computers & Internet Experts

Martin Clarke
Martin Clarke

Level 2 Expert

186 Answers

Brad Brown

Level 3 Expert

16806 Answers

Lawrence Oravetz

Level 3 Expert

10045 Answers

Are you a Thermaltake Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides