Question about Pioneer GM-7200M Car Audio Amplifier

1 Answer

My 600 watt amp for my car just now start putting a red light on

The protection light. it was working just fine but now that all it does.. HELP ME

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 44 Answers

You may need a new power supply inside amp. If you where running speakers with to many watts it will burn up the power supply. Try unplugging all wires. Replug them in also check fuse underhood and inside amp

Posted on Jan 12, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Protect Light On Amp Being Weird


Could try switching right and left subs. If the problem moves to the other side pull the wiring and redo.
Then if the wiring is ok check the sub.

May 15, 2013 | Jensen JPA600D - 600 Watts Digital Mono...

2 Answers

2 12" subs + 600W amp. Turn on, goes boom once, then red light


Is your gain all the way up? If it done this before, sounds like your over working the amp. Make sure your subs ohm load is capable with the amp load to. If they are 1 ohm and your amp is only 2 ohm stable, it would beat for a lil bit then go into protection mode to. Check your wires too.

May 13, 2010 | Insignia 600W Bridgeable Amplifier with...

1 Answer

JVC 600 watt amp overheated


Yes it has a protection mode, let it cool for while then try it again, if it over heats quick make sure you're not running the amp below its stable impedance.

Aug 30, 2009 | JVC KSAX4504 MOSFET 600-Watt Amplifiers...

1 Answer

Jbl am in protect mode


if it goes in protect mode means ur amp is turn up to high or it is over heating so it protectn it from fryn ur amp try to adjust it down

Jul 12, 2009 | JBL BP1200.1 Car Audio Amplifier

2 Answers

How do I fix the problem so they work again.?


A 1000 WATT AMP HAS PROBABLY GONE INTO PROTECTION MODE BECAUSE YOU ARE TRYING TO RUN 1600 WATT SUBS COMBINED

Jun 08, 2009 | Car Amplifiers

3 Answers

My red light on my amp is on and wont go out


Unfortunately I think you need to get it repaired or replaced .When a protection light will not turn off it is generally caused by an internal short and needs one or more replacement parts for it to come alive again.
-Dynami

Apr 03, 2009 | Insignia 600W Bridgeable Amplifier with...

2 Answers

When powered on protection light comes on


ya i would say its not grounded right

Mar 02, 2009 | Car Amplifiers

4 Answers

Red light


something is shorted in the circuit, or your subs. unhook the subs first and try it again, if it is still in protect then it is most likely the output transistors.

Feb 22, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

4 Answers

No response from amp


it sounds like you have a bad ground make sure its on the froame or body and make sure any rust or paint is sanded or scraped off

Feb 09, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Amp not working correctly goes into protection


Disconnect the speaker wires from the amplifier and see if it still goes into protection mode. If it still goes into protect with the speakers disconnected, there's a problem with the amp; if not, you may have a blown speaker or a shorted speaker wire.

Feb 22, 2007 | Legacy LA2098 Car Audio Amplifier

Not finding what you are looking for?
Pioneer GM-7200M Car Audio Amplifier Logo

Related Topics:

82 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pioneer Car Amplifiers Experts

Lawrence Oravetz

Level 3 Expert

7686 Answers

David Payne
David Payne

Level 3 Expert

13437 Answers

Are you a Pioneer Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...