Question about Kodak EasyShare C330 Digital Camera

1 Answer

The flash doesn't work

I don't know if there is a setting for the flash. I never encountered this before. The camera works but without the flash the image is to dark, as if there is no image. What should I try to do.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 153 Answers

Check if the led inside the flash is allright try replacing the flash

Posted on Dec 11, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Canon 420ex makes brief buzz noise but no lights


The buzz noise may be the zoom motor in the flash activating as it starts up. If it encounters resistance it will shut down to protect the motor and flash. It's impossible to tell if something has jammed the zoom motor or path without opening the flash (I suggest you don't). If mounting the flash on your camera, turning both on and resetting your camera to factory default settings through your camera menu settings doesn't reset it you'll probably need to send it in for repair.

Dec 23, 2012 | Canon Speedlite 420EX TTL Flash

1 Answer

My sb-200 flash won't work with my d200


Go to menu then shooting and turn on ttl

Jan 17, 2012 | Nikon SB-400 Flash

1 Answer

I recently purchased a Canon EOS Rebel T3i SLR camera (July 2011) and already I am encountering a problem called "Err 05 the built-in flash could not be raised." Does anyone know how to resolve...


Hey Leo,

Unfortunately the problem you've mentioned is quiet common with your particular model.

Here's what Canon recommends, on its website.

-Turn the power switch to < ON > to turn on the power again.

And, if that doesn't work. Buddy, you'll have to drop by a service center. Hurry up, or you'll run out on the warranty period.

Toodles,

Rebel K

Sep 18, 2011 | Canon EOS 550D Rebel T2i Digital Camera

1 Answer

Samsung S8000 Camera is not working. I don't know why.


Try to go to the camera settings of your phone and try some adjustments or try to update the soft your phones camera, but if it doesn't work maybe your cellphone camera has a hardware problem.

Jul 01, 2011 | Samsung Jet S8000 Cell Phone

1 Answer

The pop up flash stopped working on my Nikon Coolpix L110 camera. Camera still works, but without the flash, the pictures are less than desirable. What can I do to correct this problem?


Check your settings first. If this still doesn't work then you'll have to take/send your camera to an authorized Nikon service center.

Hiram
Photo Tech Repair Service
110 East 13th Street
New York, NY 10003
212-673-8400

Jul 01, 2011 | Nikon Coolpix L110 Digital Camera

1 Answer

Flash just doesn't work on Kodak Easyshare V1253. whether on automatic flash or flash set to on. Used to have problems with the lens not fully closing, don't know if that helps. All in all, i have...


When you were having that lens problem, did you perchance open the camera case to repair it? If so, please see this link, and afterwards verify that all outer case screws are present and firmly seated (but don't strip them).

May 30, 2011 | Kodak EASYSHARE V1253 Digital Camera

1 Answer

My canon 4OD will not take photos in AF mode...can you tell me why


If any of the red sensor squares light up when you have focused in manual. your sensor is working. It`s not as easy as abc without seeing the camera. So you need to start at the beginning.

try resetting the camera. Once done check the lens for AF mode.
How to reset:-
-set the mode to manual
-press menu, scroll to the third yellow box with the spanner icon.
-scroll to Clear all camera settings,choose clear and confirm your choice.

Try it out in Auto mode and in fair lighting.
If all is not well check the contacts on the lenses, There should be a set of 5 and a set of 2,3 if the lense has Is. These may have been damaged from an imperfect rear lense cap. Also check the pins on the body.

If this doesn`t work let me know , but don`t vote.. This may work for someone else.

Aug 30, 2009 | Canon EOS 40D Digital Camera

1 Answer

E.91:01


the flash board of the camera gets one fire ic damaged u remove the flash board jack ur camera will work ok without flash

Nov 19, 2008 | Sony Cybershot DSC-T200 Digital Camera

1 Answer

Canon sd900


Try a higher ISO speed (suggest 400). Look in your camera's instruction book to find out how to do this.

May 27, 2008 | Cameras

Not finding what you are looking for?
Kodak EasyShare C330 Digital Camera Logo

Related Topics:

53 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kodak Cameras Experts

kakima

Level 3 Expert

102366 Answers

Tony

Level 3 Expert

2598 Answers

Greg Cann
Greg Cann

Level 3 Expert

1114 Answers

Are you a Kodak Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...