Question about Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum

1 Answer

Progressive canister turns on and off when you pull hose.

I have a progressive canister 25614 and it turns on and off when you are vacuuming. Seems like you have to keep the hose in just the right position. It is about 2 years old but has been doing this for a long time. Do you know what needs to be replaced?

Posted by on

  • Anonymous Dec 11, 2008

    My kenmore 25615 turns on and off while in use.I ordered the fuse wand but I dont know how to take the old part off so I can put the new part.

  • Anonymous Jan 03, 2009

    I was looking for a possible recall and found two others' comments who have this problem-- ours also has "rusty pins" and fluctuating power. I paste their comments below as I have identical problems and don't want to spend $125 on a new hose, or trust that Kenmore's new models don't have the same problem.



    Our female end on the hose, into which the rusty pins insert smells burned so I think I will print these comments and see whether Sears will replace the hose--this can't be safe or well-designed.

    I have a progressive canister 25614 and it turns on and off when you are vacuuming. Seems like you have to keep the hose in just the right position. It is about 2 years old but has been doing this for a long time. Do you know what needs to be replaced?

    I had a bad connection between the Wire Harness on the handle and the Terminal Cover on the Extension Wand. I replaced the wire harness, the the vacuum runs great. However, I bought the terminal cover because one of the contact pins looks "rusty" and I don't want to cause another poor connection. Will you please provide instructions for the removal of the Terminal Cover? I've played around with this enough to know that I may start to break something if I apply pressure in the wrong places.

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

I saw this on another FixYa post -- it tells you how to remove the wand cover safely---
Comment posted on Feb 09, 20082bubbles ok here we go.. fine a small file that will fit the holes at the bottom of the wand and break the file so that the flat end fit into the wand. please make sure the wand is not plug in to anything. now put it into the hole and try to clean it out gently not too hard or you will damage the contacts. after that grab a needle nose pilers and very gently press the contacts. not a lot or it won't fit back into the power-mate. ok now for the top of the wand. if you look at the wand where the button is to extent the wand. on each side you will see a small clip. with a small flat head screw driver push into the clip at the point closer to the wand tube. it will pop out. make sure to check the clip to see how to put it back in. after both clips are out you will notice a that the clips left a gap. the back part of the wand or cover will now slip off. push it toward the gap. then up. after removing the cover. you will see a ribbon strip which is attached to the prongs or fuse .you can remove the fuse and then clean the contacts. please be careful. once this is done you then put it all together and try it out. the fuse is a part that you can buy at sears if you have to. let me know if this helps you out. if it seems like too much just take it to sears and ask them to replace the wand fuse for you instead of replacing the whole wand. hope this helps .

Posted on Jan 08, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Get the belt to turn in Progressive Whisper belt


Make sure the roller is not jamed with carpet threds , remove bottom cover and clean dust balls and obstructions out see if ti resolves problem make sure it's unplugged when checking and install complete before applying power!

Feb 21, 2015 | Kenmore 25614 / 25615 Progressive Bagged...

1 Answer

My kenmore progressive canister vacuum turns on only if the hose is attached to the floorwand. It seems that the canister motor is not working because I can't hear anything coming from the caniste


If the floor wand is powered, there may be an electrical connection that is broken when the wand is disconnected. This is part of the design, not necessarily a fault

Jan 05, 2013 | Vacuums

1 Answer

Kenmore 25614/25615 Progressive bagged canister vac won't start


sounds like there was a loose connection or loose wire that came in contact with another wire. check your cord for small burn holes, also could have shorted out in the hose or the wand. If you are comfortable to disassemble the vacuum i can walk you through the troubleshooting process so we can find out what actually went bad. id start with the cord though. let me know if you have any questions or need more assistance

Jan 04, 2010 | Kenmore 25614 / 25615 Progressive Bagged...

1 Answer

Kenmore canister vac 25614


Have you checked and made sure that the hose is COMPLETELY clear and the bag is not full?

Feb 13, 2009 | Kenmore 25614 / 25615 Progressive Bagged...

Not finding what you are looking for?
Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum Logo

111 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Roger Potts

Level 3 Expert

694 Answers

yadayada
yadayada

Level 3 Expert

60960 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...