Question about Sony STR-DE635 Receiver

2 Answers

Receiver clicks and rear speakers stop working

Sony STR DE635. I can unplug stereo for 30 minutes, restart and rears will work. I checked all wires going into stereo, twisted and cut clean and re inserted. Had cabinet door open this time with fan blowing on stereo same thing. Also took receiver apart and vacuumed dust balls.

Posted by on

  • SirJonathan Feb 05, 2009

    HI! got the same problem, something wrong with the relay i think, or somting thats controls the relay. If i can reatch i'm gong to re soldering the relay and se if thats the problem. its place is bad compaird to the other relays=/ anyway have you got any solution for yours yet?

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Temporary Fix.  My rear speakers cut out as well so to fix it temporarily I switch the receiver to "Test Tone" Mode and crank it up a bit until the test tone (white noise) turns the rear speakers on. Turn down the volume first then turn off the "Test Tone" Mode. HTH

Posted on May 09, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Maybe, it worked for me. my rear speakers workt ramdomly, often not. so i re solder the relay for the rear speakers, now it works fine everytime, a hole movie and some random on and offs, it can't do any harme to try=)

Posted on Feb 06, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sony str-de945 s.1 rear speakers not working


rear speakers may only work once you have a 5.1 or DTS signal source connected

Apr 20, 2014 | Sony STR-DE945 Receiver

2 Answers

Sony str d-1015 stereo receiver stopped working


if you have been blasting it, that could be why, recievers of this era are made with cheaper parts that cant handle what theyre supposed too,
i dont know specifically, but things like that have some sort of auto fuse...
i would assume, you are using it with wrong ohmage speakers, are you using car speakers? car subs? older speakers?
most home stereo equipment is 8 ohms, i have a set of 140 watt 3 way (10"[vented]/4"/2") as fronts and a set of 80 watt rears (6"[vented]/1.5"/24mm) the fronts are induviduals, meaning they have to be bought individually, and are not sold as a set, or part of anything, the rears were part of a bookshelf system, i got the set secondhand... but i always checked the ohmage...

Jan 08, 2010 | Sony STR-D1015

1 Answer

I have a Sony STR-DE845 receiver. The rear


Something is heating up to a point that it fails in the rear amplifier section. take it to a tech.

Jan 01, 2010 | Sony STR-DE845 Receiver

1 Answer

Sony STR DE845: rear speakers not working, three fronts are OK.


The rear amp is malfunctioning (duh). Take it to a tech for a real diagnosis.

Sep 05, 2009 | Sony STR-DE845 Receiver

1 Answer

Sony STR-DE635, Sound from left surround speaker but not right


first turn the actual volume up on that channel on the reciver then make sure your speaker wires in the rear are using the same lenght each

May 18, 2009 | Sony STR-DE635 Receiver

1 Answer

I have a Sony STR-DE635. It has a switch on the front for speakers A, B, and A+B. Normal. When I am on speaker A only, it works fine. B does not work. A+B works, but only through the A speakers. Now,...


Check for bad solder connections on the speaker switch or where the speaker switch board connects to another board. Not an uncommon problem with some Sony receivers.

Feb 25, 2009 | Sony STR-DE845 Receiver

1 Answer

No sound from rear speakers during test tone usng Sony STR-DE475


I had this problem last night.

To solve it, you can reset the amp by:

1) Put the receiver on stand-by
2) Hold down "MODE" button and press on button
3) "S.F. CLR" appears in the display and surround is back on.


Good luck

Dr Gardner

Jan 21, 2009 | Sony STR-DE475 Receiver

1 Answer

Bought some replacement speakers and the reciever seems to get ver hot!


Hello! Yes, you need to worry when a Sony gets hot!! You probably have replaced factory 8 ohm speakers with 4 ohm speakers. Look on the back of your new speakers and see what they are. Then look at the rear of your receiver by the speaker terminals and there will be a sentence like "8 Ohm minimum per channel". If your Sony says " 8 ohms " you need to use 8 ohm speakers.
Also, are you a using low level signal ( audio out ) to drive your sub or are you using high level ( speaker line )??? I'd use low level. Good luck!!

barneyluc

Oct 09, 2008 | Sony STR-DE635 Receiver

1 Answer

Sony STR-DE635 Receiver-no sound at all


sorry my expertise is in appliances, youl need to repost you question to another tech

Mar 21, 2008 | Sony STR-DE635 Receiver

1 Answer

Sony STR-DE635 Receiver-no sound at all


Turn your volume down,press the tape monitor button.then turn up?

Mar 20, 2008 | Sony STR-DE635 Receiver

Not finding what you are looking for?
Audio & Video Receivers Logo

Related Topics:

261 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Audio & Video Receivers Experts

nexrad_chris

Level 2 Expert

117 Answers

Cindy Wells

Level 3 Expert

4753 Answers

Pieter Vleeshouwers

Level 3 Expert

1410 Answers

Are you a Sony Audio and Video Receiver Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...