Question about Whirlpool Dishwashers

1 Answer

I have a whirlpool water softner. After regenerating, the water is still hard and the tank is about half full of water. I have cleaned the venturi.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 399 Answers

  1. Check for hose kinks or food plugging drain hose. Start at the drain port exit (there are others, this is just an example)
  2. Check the check valve and drain hose for debris.
  3. Check pump motor for reversing during the pump out make sure the dishwasher is pausing between the wash and drain cycles letting the pump/motor reverse for the drain cycle.
  4. Check timer for not letting the dishwasher pause. ( not all dishwashers )
  5. Check pump motor assembly for a drain solenoid, during the pump out make sure the solenoid makes that distinctive "clunk" noise
  6. If you have recently installed a new garbage disposal, check knock-out plugat connection.
  7. Check pump impeller for damage.
  8. Check that the water inlet valve isn't seeping fresh water into the dishwasher when off.

Posted on Dec 06, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Brine tank fills but doesn't draw it back into the water sosftener


Your injector is stuck. Your manual should show you, at the least,
a diagram; you'll need to clean out the center of the injector and lubricate the seals or o rings with silicone grease. You cannot use Vaseline; it'll attack the rubber. You should bail out the excess water from your salt tank. After you've got rid of the particle of dirt from the venturi in the injector and lubricated the seals or o rings with silicone lubricant, reassemble. Three manual regenerations over the next three days should bring your softener back to full function.

Mar 01, 2015 | Kenmore 350 Series Water Softener

1 Answer

Water in water softener, filling over potassium in tank. How do I fix this?


There is an injector (venturi) in your softener that shunts to allow brine to be sucked out of your salt tank and, near the end of regeneration, shunts again to put water back into your salt tank to make brine for the next regeneration. It isn't moving; probably needs cleaning and perhaps lubrication with silicone grease. If you don't have a manual, download one. There are hopefully illustrations to help. Otherwise you'll need to hire someone to do it for you, but watch so you can do it for yourself. If the injector has plugged in only three years it'll likely do so again.

Feb 03, 2015 | Water Dispensing & Filtration

1 Answer

Brand new softner full of water


Your injector is that part of your control head that switches to allow salt brine to be sucked out of your salt tank (during regeneration) or shifts a couple of mil to add water to your salt tank to make brine (at the end of the regeneration). Your injector is either stuck or the venturi in it is blocked up with some kind of debris. Your manual should tell you how to clean it or, at the least, diagram where it is and how to access it. If you lubricate it you must use a silicone based lubricant; Vaseline or oil based lubricants will make the rubber O rings old before their time.

Sep 09, 2014 | MORTON SALT CO 8708 System Saver Water...

1 Answer

Kenmore Water Softener does not advance through cycles


You can send to the company for repair too ! If it sill under warrenty to fix it and aslo don't try the step anymore it might cause some parts damage that the service provider my charge you more.

Dec 09, 2013 | Washing Machines

2 Answers

Just replaced old softner w/new whirlpool 40,000. Hooked up correctly, regenerated w/ 6 tblsp bleach before use, tested/set hardness, Water is not soft....why?


Is the "bypass valve" in the correct position. I would suggest flushing the water heater at the boiler drain, bottom of tank to assure soft water in WH. Make sure there is salt in brine tank and manually regenerate the softener 3 days in a row. Retest water.
RJ

Sep 22, 2013 | Whirlpool Water Dispensing & Filtration

1 Answer

Culligan wg 1035 water softner bine tank will not empty. water getting hard I have checked the valves in the head and they seem fine.


The eductor assembly is plugged or the refill restrictor in top of float assembly is plugged. The eductor/injector draws the brine in during regeneration. These need to be cleaned to remove any oxidized iron or sediment . Do you have your owners manual for your Water Gard system?
RJ

Sep 24, 2011 | Culligan Sediment Water Filter

1 Answer

My water softener emptied im not sure how long it was empty for but I dont think it was too long I filled it with salt and now it doesnt work. It still regenerates but im getting hard water still any...


Do you mean the salt tank was empty? If so fill salt tank half way wait about 6 hrs for brine to develop. Manually regenerate softener 2x within 24 hrs. When the salt runs out the resin becomes saturated with hardness minerals. It takes at least 2 regeneration cycles back to back to completely restore soft water. Also the hot water will take some time to get soft. It will help to flush water heater after cold water is consistently soft.
I hope this helps,
h2oservices

Feb 26, 2011 | Culligan Compatible S7011C RS23SED5...

1 Answer

Hard water, salt in in tank, what do i do


Make sure there is not a "Salt Bridge" in salt tank. Salt tank should always be at least 1/2 full of salt.
You may have just run out of soft water, run 2 manual regenerations in 24hr period. If no soft water still. The eductor assembly is plugged with iron or sediment and needs to be cleaned out. The eductor assembly is where the brine is drawn through to regenerate the resin.
RJ

Aug 12, 2010 | Culligan Sediment Water Filter Heavy Duty

1 Answer

Where to put the salt? and how to flush it? thank you wg844


Dump the salt in the separate brine tank. Always keep salt/brine tank at least half full. If you want to run a manual regeneration push the regen button. For delayed regeneration (2am) push once, for immediate regeneration push twice.
RJ

Aug 09, 2010 | NRS Fleck 5600 - 64,000 Grain Timer Water...

1 Answer

Not getting soft water. The system charges but it does not seem to be getting brine from the tank to wash the softener pellets. Is there some way for me to check the valve. Maybe change a simple part. ...


You need to remove the venturi valve and clean it. This part is usually found under a round plastic cap that unscrews remember to put softner on bypass or turn off water first

Nov 15, 2009 | NRS Fleck 5600 - 64,000 Grain Timer Water...

Not finding what you are looking for?
Dishwashers Logo

Related Topics:

105 people viewed this question

Ask a Question

Usually answered in minutes!

Top Whirlpool Dishwashers Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Mike Cairns
Mike Cairns

Level 3 Expert

3053 Answers

Mike

Level 3 Expert

4332 Answers

Are you a Whirlpool Dishwasher Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...