Question about IBM DB2 Connect Enterprise Edition for PC, Unix

1 Answer

After installing DB2 query is not executing

I go from all programs -> IBM DB2-> DBCOPY1(default)-> command line tools-> command editor

From the editor i write a simple query to create a table

CREATE TABLE student
(
name CHAR(50) NOT NULL
,std_id INTEGER NOT NULL
,adress CHAR(50)
,contact CHAR(50)
PRIMARY KEY (std_id)
);

But showing .....

CREATE TABLE student ( name CHAR(50) NOT NULL ,std_id INTEGER NOT NULL ,adress CHAR(50) ,contact CHAR(50) PRIMARY KEY (std_id) )
DB21034E The command was processed as an SQL statement because it was not a
valid Command Line Processor command. During SQL processing it returned:
SQL1024N A database connection does not exist. SQLSTATE=08003

SQL1024N A database connection does not exist.

Explanation:

There is no connection to a database. Other SQL statements cannot be
processed unless an SQL CONNECT was previously executed.

The command cannot be processed.

User response:

If the error occurred when disconnecting from the database, continue
processing. If the error occurred on another SQL statement, issue an SQL
CONNECT statement and resubmit the command or statement.

sqlcode: -1024

sqlstate: 08003
what should i do for a data base and execute any query here ??

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Could you check whether you are connected to the database, where you are trying to create table,

check the database list, then connect to the database you want then execute the table creation ddl,
if no db found then create a database then proceed.

Posted on Feb 05, 2009

2 Suggested Answers

  • 258 Answers

SOURCE: i installed DB2 in my

Hi,

Before you create a table you need to:-

1. create a database
2. create a username and password or use the admin generated userid
3. connect to the database

you can then create a table and use the database

Please post if you do not know how to do this and i'll give you some links

Posted on Feb 10, 2009

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How to Create an Advanced Shortcut Using Default Programs Editor?


Open Default Programs Editor. Select "File Type Settings" and then "Context Menu". Use the search bar to find your extension, select it, and press Next. Select the Open command and click "Edit Selected Command..."
http://electronicshelponline.blogspot.com/

Oct 18, 2016 | Computers & Internet

Tip

How to change filetype associations in Windows Vista, XP, 2000 and 98 fast and...



For Windows Vista There are two ways:Method #1 (on the fly):
  1. Right-click a file of the type you want to change, and select Properties.
  2. In the General tab, click the Change button.
  3. Choose a program from the list, or click Browse to select an .EXE file on your hard disk.
Method #2 (view a list of file types):
  1. Open Control Panel.
  2. In Control Panel Home, click Programs, and then click Make a file type always open in a specific program.Or, in the Classic View, open Default Programs and then click Associate a file type or protocol with a program.
  3. Highlight a file type in the list and click Change Program.

For Windows 2000 and Windows XP For Windows 2000 and Windows XP, the following steps are required to set Dreamweaver 8 as a default editor in Internet Explorer:
  1. Launch Windows Explorer (typically, you can launch this by choosing Start > Programs > Accessories > Windows Explorer).
  2. Select Tools > Folder Options...
  3. Select the File Types tab.
  4. Scroll to the HTM extension in the Registered File Types list.
  5. Click the Advanced button. You may have to restore the file association before you see the Advanced button.
  6. Select Edit from the actions list (not Edit within Dreamweaver), then click the Edit button.
  7. Browse to the Dreamweaver 8 executable. The default location for the Dreamweaver.exe file is: C:\Program Files\Macromedia\Dreamweaver8\
  8. Click OK until you are back at the File Types list.
  9. Select the HTML extension and repeat steps 5 to 8.
  10. Click OK.
  11. Restart your system.
  12. Open the Internet Options tool from the Windows Control Panel (Start > Settings > Control Panel).
  13. Select the Programs tab.
  14. Select Dreamweaver8 from the drop-down menu in the HTML Editor category.
  15. Click OK.
For Windows 98 For Windows 98, the following steps are required to set Dreamweaver 8 as a default editor in Internet Explorer:
  1. Open Windows Explorer (Start > Programs > Windows Explorer).
  2. Select Tools > Folder Options or View > Folder Options (both will open the same window).
  3. Select the File Types tab.
  4. Scroll to the Microsoft HTML Document listing in the Registered File Types list.
  5. Click the Advanced button.
  6. Select Edit from the actions list (not Edit with Dreamweaver), then click the Edit button.
  7. Browse to the Dreamweaver 8 executable. The default location for the Dreamweaver.exe file is: C:\Program Files\Macromedia\Dreamweaver8\
  8. Click OK until you have closed all windows.
  9. Restart your system.
  10. Open the Internet Options tool from the Windows Control Panel (Start > Settings > Control Panel).
  11. Select the Programs tab.
  12. Select Dreamweaver8 from the drop-down menu in the HTML Editor category.
  13. Click OK.
please vote if this tip from is really helpful to u .. -shailendra

on Oct 03, 2010 | Computers & Internet

1 Answer

My google chrome crashed and everytime i click on it a message says DEP has closed it


To use hardware-enforced DEP, you must meet all the following conditions:
  1. The computer's processor must support hardware-enforced DEP.

    Many recent processors support hardware-enforced DEP. Both Advanced Micro Devices (AMD) and Intel Corporation have defined and shipped Windows-compatible architectures that are compatible with DEP. This processor support may be known as NX (no-execute) or XD (execute disable) technology. To determine whether your computer's processor supports hardware-enforced DEP, contact the manufacturer of your computer.
  2. Hardware-enforced DEP must be enabled in the BIOS.

    On some computers, you can disable processor support for hardware-enforced DEP in the BIOS. You must not disable this support. Depending on your computer manufacturer, the option to disable this support may be labeled "Data Execution Prevention," "XD," "Execute Disable," or "NX."
  3. The computer must have Windows XP with Service Pack 2 or Windows Server 2003 with Service Pack 1 installed.

    Note Both 32-bit versions and 64-bit versions of Windows support hardware-enforced DEP. Windows XP Media Center Edition 2005 and Microsoft Windows XP Tablet PC Edition 2005 include all the features and components of Windows XP SP2.
  4. Hardware-enforced DEP must be enabled for programs on the computer.

    In 64-bit versions of Windows, hardware-enforced DEP is always enabled for 64-bit native programs. However, depending on your configuration, hardware-enforced DEP may be disabled for 32-bit programs.
For more information about DEP, about DEP configuration, and for a list of Windows Operating Systems that support hardware DEP, click the following article number to view the article in the Microsoft Knowledge Base:875352 A detailed description of the Data Execution Prevention (DEP) feature in Windows XP Service Pack 2, Windows XP Tablet PC Edition 2005, and Windows Server 2003For information about how to configure memory protection in Windows XP with Service Pack 2, visit the following Microsoft Web site:

http://technet.microsoft.com/en-us/library/cc700810.aspx

To confirm that hardware DEP is working in WindowsTo confirm that hardware DEP is working in Windows, use one of the following methods.Method 1: Use the Wmic command-line toolYou can use the Wmic command-line tool to examine the DEP settings. To determine whether hardware-enforced DEP is available, follow these steps:
  1. Click Start, click Run, type cmd in the Open box, and then click OK.
  2. At the command prompt, type the following command, and then press ENTER:wmic OS Get DataExecutionPrevention_AvailableIf the output is "TRUE," hardware-enforced DEP is available.
To determine the current DEP support policy, follow these steps.
  1. Click Start, click Run, type cmd in the Open box, and then click OK.
  2. At the command prompt, type the following command, and then press ENTER:wmic OS Get DataExecutionPrevention_SupportPolicyThe value returned will be 0, 1, 2 or 3. This value corresponds to one of the DEP support policies that are described in the following table.
DataExecutionPrevention_SupportPolicy property valuePolicy LevelDescription2OptIn (default configuration)Only Windows system components and services have DEP applied3OptOutDEP is enabled for all processes. Administrators can manually create a list of specific applications which do not have DEP applied1AlwaysOnDEP is enabled for all processes0AlwaysOffDEP is not enabled for any processesNote To verify that Windows is running with hardware DEP enabled, examine the DataExecutionPrevention_Driversproperty of the Win32_OperatingSystem class. In some system configurations, hardware DEP may be disabled by using the /nopae or /execute switches in the Boot.ini file. To examine this property, type the following command at a command prompt:wmic OS Get DataExecutionPrevention_DriversMethod 2: Use the graphical user interfaceTo use the graphical user interface to determine whether DEP is available, follow these steps:
  1. Click Start, click Run, type wbemtest in the Open box, and then click OK.
  2. In the Windows Management Instrumentation Tester dialog box, click Connect.
  3. In the box at the top of the Connect dialog box, type root\cimv2, and then click Connect.
  4. Click Enum Instances.
  5. In the Class Info dialog box, type Win32_OperatingSystem in the Enter superclass name box, and then click OK.
  6. In the Query Result dialog box, double-click the top item.

    Note This item starts with "Win32_OperatingSystem.Name=Microsoft..."
  7. In the Object editor dialog box, locate the DataExecutionPrevention_Available property in the Properties area.
  8. Double-click DataExecutionPrevention_Available.
  9. In the Property Editor dialog box, note the value in the Value box.
If the value is TRUE, hardware DEP is available.Notes
  • To determine the mode in which DEP is running, examine the DataExecutionPrevention_SupportPolicy property of the Win32_OperatingSystem class. The table at the end of Method 1 describes each support policy value.
  • To verify that hardware DEP is enabled in Windows, examine the DataExecutionPrevention_Drivers property of the Win32_OperatingSystem class. In some system configurations, hardware DEP may be disabled by using the/nopae or /execute switches in the Boot.ini file.

Oct 11, 2012 | Google Chrome

1 Answer

I am trying to graph to evaluate each expression. how could i do it on the calculator(ti-83) a:(f+g)(0) b)(f-g)(-1) c)(fg)(1) (d)(f/g)(3()


Let us see if I understand what you want to do. You have two functions f and g. With f and g you create four functions,
  1. f+g, which you want to evaluate at 0
  2. f-g, which you want to evaluate at -1
  3. f*g, which you want to evaluate at 1
  4. and f/g, which you want to evaluate at 3
If that is not what you intend to do, then I am sorry to I that interpreted incorrectly and you will have to post a comment with more information.
If however I did understand what you want to do, then there is a simple way to achieve this
  1. In the [Y=] function editor, enter Y1 and Y2
  2. In your mind decide which one represents f(x) and which represents g(x), probably f(x)=Y1(x) and g(x)= Y2(x)
  3. Validate each one by pressing [ENTER]
  4. Do not worry about graphing the function.
  5. Press [2nd][QUIT] to return to main calculator screen
  6. Enter a value (for example 5) and store it in variable X; to do so you press 5 [STO->][X,T, theta,n] [ENTER]
  7. To calculate f(x)+g(x) or (f+g)(x) on the command line in main calculator screen
  • Press [VARS][=>][Y-VARS][1:Function][1:Y1][ENTER]. Main calculator screen echoes Y1
  • Press [+]. Screen shows Y1+
  • Press [VARS][=>][Y-VARS][1:Function][1:Y2][ENTER]. Main calculator screen echoes Y1+Y2
  • Press [ENTER] to obtain the value of f+g at X=5
As you can see, if you want a different operation f-g, f*g, or f`/g for a different value of X, you will have to repeat steps 6 and 7.

I am going to show you how to create a small program that will perform all the 4 operations in sequence, each time asking you for the value of X you want to use. If you are not interested, you can ignore what follows. I remain convinced that it will be helpful for other visitors.

Creating a simple program

Press [PRGM]
Use arrow to highlight [NEW]
Press [ENTER]
Screen displays
PROGRAM
Name= with alpha cursor blinking
Type in the name, for example FOPG ( meaning F operation G) or anything else. Do not use a keyword (reserved command of the TI84Plus) These are what you find in the [CATALOG].

ddae385.jpgac147eb.jpg

The top line on each screen capture is inserted by the program editor after you choose the name. The last line of first screen is the the same line as the second line on 2nd screen. It must not be entered. The colon : is supplied by the program editor. It is the beginning of an instruction.

There are only to commands that are repeated here: Disp and Prompt

Disp orders the program to display
  1. a message (what is between the quotation marks) or
  2. the result of a calculation: Y1+Y2, Y1-Y2, Y1*Y2, or Y1/Y2
Prompt X will display X=? and the blinking cursor. You are supposed to enter the desired value of X and press [ENTER].
The Disp and Prompt command are accessed through the command catalog by pressing [2nd][0] (CATALOG) then scrolling along the list of commands to find the one needed. Shortcuts are possible (see below)

How to key in the program steps within the program editor
: Disp "F+G"

Press [2nd][0] (CATALOG) [X^-1](D) [Scroll Down [till...] Disp
Press [ENTER]. Editor shows :Disp
Press [ALPHA] [+] ("). Editor shows :Disp "
Press [ALPHA][COS] (F). Editor shows :Disp "F
Press [+]. Editor shows :Disp "F+
Press [ALPHA][TAN] (G). Editor shows :Disp "F+G
Press [ALPHA][+] (") Editor shows :Disp "F+G"
Press [ENTER] to validate instruction
Calculator inserts a new line :

: Disp Y1+Y2
Press [2nd][0] (CATALOG) [X^-1](D) [Scroll Down [till...] Disp
Press [ENTER]. Editor shows :Disp
Press [VARS][=>][Y-VARS][1:Function][1:Y1][ENTER]. Editor shows :Disp Y1
Press [+] . Editor shows :Disp Y1+
Press [VARS][=>][Y-VARS][1:Function][1:Y2][ENTER]. Editor shows :Disp Y1+Y2
Press {ENTER] to validate instruction
Editor inserts a new line :


:Prompt X
Press [2nd][0] (CATALOG) [8](P) [Scroll Down [till...] Prompt
Press [ENTER]. Editor shows :Prompt
Press [X,T.theta,n] key. Editor shows :Prompt X
Press [ENTER] to validate instruction
Editor inserts a new line :

To save program
Once all instructions are entered, press [2nd][QUIT] to save program.

To run program


  1. Press [PRGM]
  2. Under the [EXEC] menu, the list of available programs appears.
  3. Type the number corresponding to the one you want to run ( FOPG) and press [ENTER].
  4. The main calculator screen displays prgmFOPG and blinking cursor.
  5. Press [ENTER] to make it run
  6. Enter a value of X and press [ENTER]
  7. Follow instructions.

Dec 21, 2009 | Texas Instruments TI-84 Plus Calculator

1 Answer

How do i open a document which is saved on my desktop into Document Manager viewer. when i click the file am able to go to Document Manager Client.


If you go to the Document Manager client when you click the file, it sounds like the file is a .gml, which is a DM document link.
If it was e.g. a Word-file, it would've been opened just like Windows normally handles that filetype.

But, if you want to open document directly from viewer, launch the viewer from the DM program folder, e.g. C:\program files\ibm\db2 document manager\dmviewer.exe

Oct 14, 2009 | IBM DB2 Document Manager

1 Answer

Vb 6.0 to oracle connectivity problem


Your SQL query does not look valid. Test the query in SQL Query analyzer, and then once it is working, copy it into your VB source. You will of course then need to make the query a string that VB will accept.

Mar 23, 2009 | Microsoft Computers & Internet

1 Answer

I installed DB2 in my laptop . then i go to all programs->DBCOPY1(default)-> command line tools -> command editor then write down query to create a table but i cant build it it is showing CREATE TABLE...


Hi,

Before you create a table you need to:-

1. create a database
2. create a username and password or use the admin generated userid
3. connect to the database

you can then create a table and use the database

Please post if you do not know how to do this and i'll give you some links

Dec 05, 2008 | IBM DB2 Connect Enterprise Edition for PC,...

1 Answer

DB2 Connect and Excel


hi, you can use the SQL Drill freeware addin (http://www.sqldrill.com) It is an addin which lets you connect to ODBC compliant databases (DB2, Oracle, SQL Server etc..)
hth

Dec 03, 2008 | IBM DB2 Connect Enterprise Edition for PC,...

1 Answer

IBM WSADv 5.1.2 Installation Error


When I installed the Websphere Studio in the past on my system I installed DB2 first; the Websphere Studio was suppliment to the Universal Database. Remember this software was originally compiled for a IBM Unix System (AIX), the Websphere Studio has an integraded Apache Webserver with IBM and Sun Microsystems libraries; it just has been ported to run on a NT Kernel so that developers have access to the libraries. Make sure you have all the install files and the disc is not corrupted; use windows file and folder search targeting the CD drive to see if that binary file is on the disc. If it is on the disc try copying the files and folders to the hard drive; if the disc is corrupted the operation will fail.

Nov 28, 2008 | IBM WebSphere Studio Application Developer...

1 Answer

Reinstalling Contribute 3


Hi,this is how you can re-install Contribute 3 .
Make sure that you un-install previous installation first and then follow these steps to re-install.

You can either click on
http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_19596 or

Copy the Contribute_Installer.msi from the FSCOMMAND folder on the CD to C:\.
  1. Bring up the Command Prompt program from Start > Programs> Accessories > Command Prompt.
  2. If Contribute is already installed then uninstall Contribute which will also automatically uninstall FlashPaper. To uninstall Contribute 3 you can go to Control Panel > Add/Remove programs and select Macromedia Contribute, or use the command line with the following line of code:
    C:\>msiexec /X ?C:\Contribute_Installer.msi"
  3. Run the Installer from command line as follows.Note: The syntax must be exact for this command to execute. If spaces or extra characters are added, the install will not work. Here is the command:
C:\>msiexec /I "C:\Contribute_Installer.msi" ADDLOCAL=ConfigurationFiles,MLM,DesktopShortcut,QuicklaunchShortcut,ProgramFiles,HelpFiles,Contribute
  1. After the command has executed, enter exit to close the Command Prompt window.
After the install has completed you will be prompted to enter the serial number again. If there are any problems, remove Contribute, using step three above. Then, repeat step four to run the installer again.

May 29, 2008 | Macromedia Contribute 3 And FlashPaper 2...

Not finding what you are looking for?
IBM DB2 Connect Enterprise Edition for PC, Unix Logo

Related Topics:

913 people viewed this question

Ask a Question

Usually answered in minutes!

Top IBM Computers & Internet Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18381 Answers

Computer Links

Level 3 Expert

2385 Answers

Are you an IBM Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...