Question about Canon EOS 400D / Rebel XTi Digital Camera with 18-55mm Lens

1 Answer

Alot of the busy signal and it times out from time to time

Canon XTi. I've had it for a couple of years now and it has worked fine until now. Recently it takes it a lot longer between shots, constantly giving me the busy message. Also it seems to time out while in disuse, but not in disuse for very long. . . and pushing the shutter button doesn't wake it up again. I have to play with the dials or turn it off and on to snap it out of it. I never noticed a sleep mode before. Is it on it's way to the recycling bin? Sad. Please help.

Posted by on

  • brandiraye Dec 30, 2008

    Yes! I'm having the same problem. Body is exactly 2 years old with moderate use.

  • will5843 Dec 30, 2008

    I have been having the same problem as well ("Busy" appearing too often) for the past few months but today I am having an even bigger problem; that is, I am getting a CF error. I am being told that there is a problem with the CF card. I have tried to use other cards, new battery but to no avail.

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 23 Answers

At least a couple of things. Have you tried a different CF card? If this takes care of it reformat the original a couple of times - in the camera. If you're in the area of a camera store ask the person there if they would reformat it in a XSi using Low format option. Then reformat it in your camera again. Check your auto off setting. This may have gotten changed accidently. Try a reset camera of all functions. Try setting your image to medium or small just to see if it goes faster. It really sounds like a CF card. 

Posted on Dec 06, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Canon Rebel XTI and it was working fine until one day it just decided not to turn back on. Tried charging both batteries multiple times and upon putting them in, it still will not turn on. Am I...


Sorry to hear about this. I have a similar camera and have been racking my brain about this...

My only thought...are you using the same battery charger? Perhaps the battery charger is to blame. You may be out of battery on both batteries. When you install the battery, does ANYTHING happen? Does it say, LOW Battery or CHANGE the battery? Or is it totally black? If nothing happens at all, you should probably contact Canon directly. Or purchase a new charger and see if that fixes the problem.

Canon Customer Support Center Phone: 1-800-OK-CANON
1-800-652-2666 Hope this helps!

Jul 26, 2011 | Canon EOS 400D / Rebel XTi Digital Camera...

2 Answers

Xti download to pc


try doing a system restore to yesterday and then try installing the disk again.

You can do the restore from control panel and inside "Performance and Maintenance"

Please let me know it this still doesn't work and we can go from there in finding a way.

thanks

May 10, 2008 | Canon EOS 400D / Rebel XTi Digital Camera

1 Answer

Hello, I have a canon rebel xti. It's about 4 years old and up until this point has worked perfectly. However, currently on a trip in Europe and when I went to shoot this morning, I can only capture...


currently on a trip in Europe and when I went to shoot this morning, I can only capture 1/3 of the area I'm shooting. That is everything in the lower 2/3 of the screen is black. I've tried a couple of lenses with no avail. Viewing previous pics is not a problem, so this is obviously not a screen problem. I'm thinking something with the mirrors? Any suggestionns
for further detail visit this website http://newsallworld.com/

Jul 11, 2011 | Cameras

1 Answer

I have a canon rebel xti, when I take several pictures a get a busy signal and have to wait before I take another picture (flash?) how do i take pictures, many in a row without getting a busy signal..as if...


Not sure, a couple things to check are the memory card you are using. If you have different card give it a try. Also, if you are trying to do burst mode there is a limit for your camera depending upon your settings. When you reach that limit the camera has to wait while all the data is written to the memory card.

Dec 06, 2010 | Canon Rebel XT / EOS 350D Digital Camera

1 Answer

Canon rebel xti flash pops up but says it was obstructed


This is a problem known by Canon, you will have to have it serviced.

Oct 30, 2009 | Canon EOS 400D / Rebel XTi Digital Camera

1 Answer

Why does the word, ''busy'' pop up on the canon rebel xti?


If the flash fires a full charge(eg. in a dark environment) then this message will appear whilst it recharges. If the message appears all the time and you cannot take a photo there is most likely a problem. Try taking some pictures without the flash card to eliminate that first.

Apr 13, 2009 | Canon EOS 400D / Rebel XTi Digital Camera

1 Answer

Recording images takes a very long time after turning camera on


Are you using a typeII Cf card. You might try reformatting the card. Or go pick up a type II or III card, the type IV's seem to not do as good in the Canon..

Jan 29, 2009 | Canon EOS 400D / Rebel XTi Digital Camera

1 Answer

Busy signal when trying to import images to my pc


I have had the same problem with getting a busy signal after plugging in the USB cord. Usually turning it on and off a few times, giving it a few seconds in between, works for me.
Also, have you tried just going into My Computer and clicking on the drive for the USB you've got you're camera plugged into and transferring the photos onto your pc from there? They only go onto your pc, not into a program but you can get them into one from there.

Dec 16, 2008 | Canon EOS 400D / Rebel XTi Digital Camera...

1 Answer

Busy message on computer and camera


Try resetting the camera to factory defaults - Here's how:
  • Firstly press the 'menu' button, then the up button above the 'OK' as many times as needed, until you see the top folders are highlighted.

  • Press the right button near the 'OK' until you see the last folder highlighted. You will know this is highlighted when you see the first menu option that says 'Language'. The 3rd one down from that says 'Clear Settings'.

  • Press the down button under the 'OK' until 'Clear Settings' is highlighted, then press the 'OK' button.

  • Scroll up to your choice and press 'OK' to reset your Canon 400D back to default factory settings.
Hope this helps

Jun 27, 2008 | Canon EOS 400D / Rebel XTi Digital Camera

Not finding what you are looking for?
Canon EOS 400D / Rebel XTi Digital Camera with 18-55mm Lens Logo

108 people viewed this question

Ask a Question

Usually answered in minutes!

Top Canon Cameras Experts

kakima

Level 3 Expert

98879 Answers

TC CAMERA REPAIR.Com...

Level 2 Expert

164 Answers

old marine
old marine

Level 3 Expert

1573 Answers

Are you a Canon Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...