Question about Car Speakers & Subwoofers

1 Answer

I have an alpine IVA-W203/P1 but someone broke the screen but it still works and and everything and changes channel but the screen touch screen does not work.. is there any way to fix it so the touch screen can work?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 22 Answers

If the head unit has a reset button try to reset it. if that doesn't work it will need to be sent to the manufacture to be repaired or replaced. But if someone broke it warranty doesn't cover that. Niether do most insurance companies without special coverage. Sorry.

Posted on Dec 03, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Need a alpine dvd IVA-D900R detachable face


If you cant buy one from Alpine (usually costs half the cost of head) then you might be out of luck. For the price of faceplate, youre half into a whole new unit just about!

May 12, 2009 | Car Speakers & Subwoofers

1 Answer

How do i get the bestsound out of my aline head unit.i have got a b.m.w 535 with alpine 6x9 inthe rear self a boombox in the boot and alpines in the footwell.and iva-d105r head unit but i cant seem to get...


What amplifier(s) are you using. How many, what size subwoofers and what type of enclosure are they in? What is the crossover frequency and slope? Active or passive x-over?

Apr 29, 2009 | Alpine Car Speakers & Subwoofers

1 Answer

Alpine IVA D310RB Backlight issue


If there is no internal/inline fuse for the screen, then check for an inlineresisistor or capacitor that may have blown. I know that in some JVC stereos they put this funky little capacitor thing that blows when overloaded, all you have to do is clip the wire at each end and soldier in a new one. These are generally about twice the size of the lead wire, are wrapped in a heat shrink, and almost look like a splice in the wire, so they are easily overlooked. If the Alpine doesn't have one, then check the connection for the screen, it could have come loose. I really think that, if all else fails, you'll get away with just a screen replacement versus a system board. Try this and let me know.

Aug 05, 2008 | Car Speakers & Subwoofers

1 Answer

My IVA-D106E alphine screen is not turning on, after i had a flat batterey i charged the batterey but the screen is still not turning on.


might want to check the fuses on the back of the radio or on the wires themselves , if your dome light doesnt turn on youve blown a fuse in your car

Jul 23, 2008 | Alpine Car Speakers & Subwoofers

1 Answer

Hello to you i currently own the alpine iva-D105 in my vehicle , my problem is the touch screen doesn't display anything although al of the functions work . my question to you is can i fix this...


Not a very likely scenario unless you have some good electronic troubleshooting skills. Sometimes it is the touchscreen itself, but it can also be the circuitry that drives the touchscreen. Taking them apart can also be a very tricky job. One mistake can cost you lots of extra money at the repair center. It is not a wise thing to try and fix electronics without some knowledge of how the circuits work and without the proper test equipment. I have been repairing car audio systems for nearly 18 years and have seen many people bring in things they thought they could fix themselves and it almost always would have been cheaper for them if they just brought it in to begin with.

Let me know if you need any help.

Jul 14, 2008 | Alpine Car Speakers & Subwoofers

1 Answer

Alpine kca-420i when hooking up to alpine iva-d901 screen says no magazine and i pod doesn't power up


  1. Make sure your iPod has a fully charged battery before connecting it to the KCA-420i. When you connect it for the first first with low to no charge left, the receiver will not recognize it.
  2. Check all your AiNet cable connections. These connectors can be finnicky if they are not plugged in ALL the way and can come out when reinstalling the head unit
  3. Make sure your head unit is in Changer mode after verifying the above.

Jun 08, 2008 | Alpine Car Speakers & Subwoofers

Not finding what you are looking for?
Car Speakers & Subwoofers Logo

Related Topics:

148 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Speakers & Subwoofers Experts

xxxxxx xxx

Level 3 Expert

4706 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Car Speaker and Subwoofer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...