Question about Mk Diamond MK - 170 Wet Cutting Tile Saw

2 Answers

The saw in not pumping water

I did not receive a manual with my saw. There are two cords coming from the pump and one from the saw. The pump is not pumping water and I don't know what is wrong. I bought the saw new from HomeDepot and it has only been used once (not by me). Can you help me figure it out?

Posted by on

  • Anonymous Dec 23, 2008

    My pump stopped pumping water. Do I need a new pump or could it be plugged somewhere that can't be seen?

  • tom May 11, 2010

    is the pump pluged into the saw motor ? try pluging the pump into a regular outlet

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have came across to possible solutions with other tile saws in the past. One is that your pump could have picked up a small piece of tile or sedement from the basin and got stuck in the water port where it comes out on to the blade. The first thing I would try is to disconnect the hose frome the blade shroud while saw is off. **** on the end of the hose until you get water. Sometimes the line needs to be primed and filled with water. Once you get water you can turn the pump or saw on while disconnected to see if water flows. Keep loose hoses away from blade though! If nothing then try the blocked port. Good luck

Posted on Jan 04, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Ridgid wts20001 .plenty of water is reaching the nozzle.water misses the blade.
it drips out of the hood .the nozzles should spray not drool/pour out.try strategically wrapping a rubber band around the nozzle orfuses to redirect the trajectory of the water shot directly into the blade without reducing the water capacity/volume.get a better pump maybe? the nozzle design is about 20% thoughtful.they blew it on this.simple part .i re retro fitted and tweeked mine to get it to work.get creative based on this premise.

Posted on Feb 16, 2012

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

TILE SAW WON'T SPRAY, PUMP AN MOTOR RUN CHECK FOR DEBRI HOW DO I CLEAN TUBING TO SPRAYER I THINK IT IS CLOGGED


Make sure pump is submerged i water
Remove tubing from pump discharge and see if pump is pumping water/ If so your tubing is clogged between pump and saw. Remove tubing and rinse out with hose.

Nov 28, 2012 | Ryobi Saw. 3/4 HP 7 in. Wet Tile Saw WS721

1 Answer

Why is the pumpo not pumpin water to tile saw


Take the hose off the pump, put it in water and turn it on. If it moves water, look for a blockage in the line and nozzles leading up to the blade. If it doesn't move water there may be a small peice of tile or enough of the tile 'mud' in the impeller that it can't spin. Depending on what type of pump you have, if you can, take the cover off the impeller and remove anything that would keep it from spinning. If it does not come apart you may have to force water through it backwards in an attempt to flush out whatever may be in there. If it won't come out sometimes giving the pump a firm wack on the side will knock things loose.

Dec 31, 2011 | Saws

1 Answer

I have a new home less than three years old with the Bradford White Energy Saver Hot Water Heater. The heater has a recirculation pump on it from Jackel. Inc. that is terribly noisy. Is this common for a...


Welcome to fixya

Hello


I have a solution for this


Press Ok, Accept or replay so we may get started


Your pre-solution is coming up shortly


PLEASE REPLY OR LEAVE COMMENT TO CONFIRM YOU RECEIVED THIS EMAIL


My name is Bruce

Jan 17, 2011 | Fasco D403 33" Diameter General Purpose...

2 Answers

Rigid wts2000l WEt saw is not sending water to blade even though it is in on position


look for weak pump, or blocked pump pick up.
I have a similar saw, and the pickup at the pump gets pretty grimey, and ned to blow it out once in a while to keep it clean and of cake like tile paste. also check the hoses for splits and/or cloggs.

Jan 07, 2011 | Ridgid Wts2000l 10" Wet Tile/stone Saw...

1 Answer

Cannot keep water on the blade of my 10" Rigid wet


if waters not getting to the blade you will see the powder of what ever your cutting coming off the back of machine,i like to put my pump in a bucket of water under the drain plug instead of puting the pump in the water tray,you can run bigger tubing up to the blade and reduce it down and it will give you better presure,good luck

Dec 31, 2010 | Ridgid 10"Wet Tile Saw with Laser and...

1 Answer

1999 ford taurus overheats boils out of res.new thermostat...saw water pumping 2 water pump....saw water pumping out of thermostat....not sure though seems like not enough water pumping through...


It sounds like you have an air pocket in your system. By the RH strut tower take the heater hose loose from the metal line and fill the cooling system when coolant starts coming out reconnect the hose. If that doesn't work jack the car up where the over flow tank is the highest point and fill the cooling system.

Sep 22, 2010 | 1999 Ford Taurus

2 Answers

Ridgid Wet Tile saw water pump operates, however the water is not getting directed onto the blade. Hose partially plugged? How to clean nozzle?


You could clean the hose ... however, I think Id get to the hardware store and get a new piece.

Clean the end with a broom straw. You could trim a small piece of the hose off. Dont neglect to clean the filter on the pump. Slide the bottomoff the pump to expose the filter.

Oct 21, 2009 | D Cut CS-070 Wet Tile Saw

1 Answer

Pump has lost its prime. how do i get it to pump water again?


If the pump works but no water coming out try to do the old way of putting water from the side that the water come from and start the pump that reduce the time to build pressure and limited the air inside…Hope that help you and please do not forget to rate my service to be able to improve on it and help everyone.

Sep 19, 2009 | Mk Diamond MK - 170 Wet Cutting Tile Saw

1 Answer

Water pump will not pump. I've checked for clogs and it is clean. any suggestions?


Check for a volume dial on the side of the pump--it may not be obvious at first glance, but if there is one check to ensure it is set to something other than the minimum flow.

Also, when you put the pump in the water, make sure it is completely submersed, and fill the supply side hose with water to prime the pump.

Aug 10, 2009 | Mk Diamond MK - 170 Wet Cutting Tile Saw

1 Answer

No voltage at water pump plug on MK 101 off switchbox.


The Capacitor is only for starting the main motor and not the water pump. Like you said, if you connect the water pump to 110V it will run so there is a problem with how it is wired to the on/off switch. there should be a white wire (neutral) permanently connected to the pump and the on/off switch should supply power on the black wire when turned on.

Apr 05, 2009 | Diamond Products Mk - 101 10" Tile Saw

Not finding what you are looking for?
Mk Diamond MK - 170 Wet Cutting Tile Saw Logo

861 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mk Diamond Saws Experts

EugenesDIYDen
EugenesDIYDen

Level 3 Expert

479 Answers

kakima

Level 3 Expert

102366 Answers

Regalo Tiles

Level 2 Expert

14 Answers

Are you a Mk Diamond Saw Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...