Question about Nitro BMW-482 Car Audio Amplifier

1 Answer

Nitro BMW 484 1200 watt amp.

The l.e.d light that lights up green or red doesnt show any color but the amp is on i checked the all the wires and everything is right but i git no sound from the subs when i turn the music on? everything was just working fine lastnight.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 22 Answers

Check fuses and remote wire at the head unit. must have a good ground at amp.

Posted on Dec 03, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Red light


You have not got your subs wired up poperly, End it fried the ouputs on the amp, Live end learn (Dude)

Nov 10, 2012 | Nitro BMW-482 Car Audio Amplifier

2 Answers

I have a nitro 1200 watt amp that was working great until it a red light that read " protection mode" turned on


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty
Definitely is worth .A thumbs up would be greatly appreciated if this answer is helpful to you. nitro-1200-watt-amp-working-lv2kkrmxrai4iihdvw4m3np2-1-0.jpg

Aug 25, 2010 | Nitro BMW-482 Car Audio Amplifier

2 Answers

Ok so my Nitro BMW - 481 2000w amp was working and then i came back the next day and the red protect light was on its been working for weeks but now it has the red light.


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. D .A thumbs up would be greatly appreciated if this answer is helpful to you. ok-nitro-bmw-481-2000w-amp-working-lv2kkrmxrai4iihdvw4m3np2-2-0.jpg http://www.nitrobmw.com/

Mar 17, 2010 | Nitro BMW-481 Car Audio Amplifier

2 Answers

I have a nitro 1200 watt amp earlier today it was workin with no problems we parked then came back in the car 3 hours later and it wasnt workin wont come on or anything just red light which is protecting...


Check your speaker wires, make sure everythings connected right with no short circuits, and check all of the fuses in the amp, and make sure none of them are blown. If all this checks out just check the battery wire, grnd, and remote wires. It has to be a wiring issue unless you busted your amp, but if was working when you tuned it off it should be alright... hop this helps...

Sep 10, 2009 | Nitro BMW-484 Car Amp

1 Answer

The red light is on how do i reset it


first disconect rca then check power remote or ground disconect speakers if the red light doesnt turn green send your amp to guarantee

Jul 13, 2009 | Nitro BMW-482 Car Audio Amplifier

1 Answer

Red protection light


If the amp is going into protect mode, it probably has shorted output transistors. To eliminate other possible problems, do the following.

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

If the voltage remains near or above 12v, disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If it still shuts down, the amp almost certainly has shorted output transistors and will need to be repaired.

Sep 12, 2008 | Nitro BMW-482 Car Audio Amplifier

1 Answer

Nitro 1000 w amp


unplug the speakers and the RCA leads from the amp, if the red protection light is still lit then its 1 of your linear amps blown or mosfet depending what your amp uses..if the red light does go off with the leads all disconnected, then connect 1 lead at a time and check the light,when you connect the bad lead or speaker then the light will come on and you know that 1 needs replacing..hope this helps

Jun 30, 2008 | Nitro BMW-481 Car Audio Amplifier

1 Answer

Nitro BMW 484 roofers stopped playing


With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.


If the voltage remains near or above 12v, disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If it still shuts down, the amp likely has blown output transistors.

May 15, 2008 | Car Amplifiers

2 Answers

Was a green light during the day the next red and stays red


look for wires that are touching each other like speaker wires or you may have a blown sub

Mar 14, 2008 | Nitro BMW-486 Car Audio Amplifier

Not finding what you are looking for?
Nitro BMW-482 Car Audio Amplifier Logo

Related Topics:

239 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nitro Car Amplifiers Experts

kcunningham2

Level 1 Expert

31 Answers

yadayada
yadayada

Level 3 Expert

60867 Answers

Larry Spears
Larry Spears

Level 3 Expert

625 Answers

Are you a Nitro Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...