Question about Sony XM-1252GTR Car Audio Amplifier

Open Question

Amp not getting any power

Ok funny thing right ex girlfriend steals ur subs and cd player and amp while your sleeping... Well I was lucky and got them back but i have it all hooked up correctly and no power what so ever running to amp yet the wires are fine i got power but not connecting power to the amp for some reason and no the amp isnt blown but it has been unscrewed so any helpful info to get the thing working would be nice thankyou for your help

Posted by on

  • cbianthug Apr 21, 2008

    some time da amp turn on but not power to kick my 12 and then it turns off for days!!!

×

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
  • 323 Answers

SOURCE: Amp powers on but sub does not come on

I would double-check your RCA's on the amplifier. You should hear a thud if you unplug them. If not they are either not hooked up or defective.

Posted on Feb 08, 2009

Ad
KaeZoo
  • 156 Answers

SOURCE: LED power protection light not turning on

Check the fuse on the amplifier; if it's good, then you need a multimeter or voltmeter for further testing. With the meter's black probe on your amp's ground terminal and the radio turned on, both the power and the remote terminals should test at about 12 volts. If neither terminal shows voltage, you may have a problem with your ground connection; if both do, there's a problem with the amp.

Posted on Mar 07, 2007

Lexdiamonzz
  • 203 Answers

SOURCE: my amp works but my sub doesn't...!!!????????????

Whats the condition of your amplifier? New , Used, Old?

 

You might have a blown channel off your amplifier, this may cause little or no sound. You will have some distortion, crackle sound and then maybe nothing at all. What kind of subs are you running to it? Make sure the subs arent blown and check the voice coils to see that they are not torn off the subs , these are the 2 little silver or copper wires that are connected from the speaker connectors to the sub itself.

 

Let me know what happens?

Posted on Oct 21, 2007

  • 3 Answers

SOURCE: No sound from Subwoofers after hooking up amp??

you can **** yourself

Posted on Mar 09, 2009

  • 4 Answers

SOURCE: sony xplode 1000w amp has green light puts out no power to subs

check the speaker, the subs. i had same problem, same reading on volt, its correct as way it should be. if its not the rca plug then it has to be speaker, i replaced the amp and it wasnt that, it was the speakers after all...

Posted on Apr 20, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have 2 amps instalkled in my car one is sony 1200w 2 channel amp for speakers and one is solid audio f2500d for 3 subs my sound and every thing was good but suddenly from yesterday im having trouble when...


First disconnect the CD head unit from the sub amp and see if the other amp works. If yes, the problem is the wires to the amp, the amp itself, or the subs/sub wiring. If no, the problem is the head unit--probably an internal short.
If the other amp works with the sub amp disconnected, reconnect the sub amp to the head unit, but disconnect the sub wires from the amp. Try the CD player. If the amp goes to protect with no speaker wires attached, the amp is bad. If the amp is OK, the problem is the subs or sub wires. Hook the wires up to the amp again, but disconnect them from the speakers. Try the player again. If the amp goes to protect, the problem is the amp wiring. If not, the problem is the subs. Check the impedance of each sub using an ohmmeter to determine which amp is out of spec.
Please let me know if you have questions, and thanks for using Fixya.

Jun 11, 2011 | Solid Audio F2500D 1-Channel Amplifier Car...

3 Answers

Why do i need to open my gain up to 3/4 to full turn inoder to achieve a loud bass?Im using punch 2400 amp and 2 12" kicker.


the amp may not be powerful or your setting on the cd player is not right try adjusting the cd player. turning the gain all the way up will damage your subs even go above halfway

Sep 19, 2010 | Rockford Fosgate Punch 801S Car Audio...

1 Answer

Is there a wiring diagram for the nikkai EAPA450 Amp


Hi, if you still need a photocopy of instructions email me mail@srands.co.uk

If you want instructions in brief this involves POWER CONNECTIONS, PHONO LEAD & SPEAKER CONNECTIONS:

POWER (At the same time when routing these wires, I would connect the PHONO LEADS from the car cd player to the amp, if your car cd player only has 1 preout (1red & 1 white) then you will need two phono splitters, a female to 2 males. Phono leads carry the unamplified sound from cd player to the amp):
~ Permanent 12V+ (Thick lead that is fused direct from battery all the way to the amp, wire must be 20a to 30a +, hence 1cm diameter wire, known as AWG8, Maplin sell cheaper kits then most)
~ Amp REMOTE (A thin insulated cable (5a is OK) from car cd player amp remote wire, this turns the amp on when the cd player is on, if your car doesn't have an amp remote wire, suggest nearest ignition supply or seperate switch that you turn on when you want to turn on the amp)
~ GrouND 12V- (Insulated lead (20a to 30a) to nearest part of unpainted car chassis such as interior panel screw hole, instead of an insulated cable all the way from the batery, this is common practise.

SPEAKER:
Each speaker has a - negative & + positive, these must connected correctly. The amp has 4 channel, 2 channel labeled as front, 2 channels labeled as rear. Using speaker wire, connect cable from amp to speakers. Note: Ensure the speakers being connected only receive sound from the amp (Not cd player as well, as would damage players or at the very least impair sound)
The amp has a feature called bridgeable this means a sub 8" or 10" sub can be powered by 'bridging' two channels. For example there are 2 ways to bridge power a Sub on the NIKKAI EAPA450:
i) Sub speaker wire positive + to channel RL and Sub speaker wire negative - to channel RR.
OR
ii) Sub speaker wire positive + to channel FL and Sub speaker wire negative - to channel FR.

Switches:
~ Bass boost, meant to be on for a channel if using sub, otherwise off.
~ X-over mode adjust hi/lo frequencies, only work if both x-over switches are on! Then adjust switch frequency knob, until it sounds right.
~ Gain (Volume knob) adjust volume knob up or down, until it sounds right!

NOTE:
You will need patience! many hand tools and parts such as: Wiring kit, fuse holder 20a/30a, Phono leads, speaker cable, Fork/ring connectors, wire strippers, wire cutters, set of screw drivers, also ueful to have zip ties to tdy excess cable and 'P' cable clips to tidy speaker wire to shelf, etc.

OK

Any more questions just email me mail@srands.co.uk

Dec 01, 2009 | Car Audio & Video

1 Answer

I had an amplifier and sub installed using the factory cd player and it worked fine. then i replaced the cd player and now the sub and amp are not working but the new headunit works fine. the amp is...


if the wire ur talking bout suppose to be connected then ur radio shouldn't *** on ..the wire suppose to connect to the back of the radio where a screw goes, its a ground wire...hop i was of help.

Jul 12, 2009 | Kenwood KDC-MP435U CD Player

1 Answer

Sony xplode cd player sub problems


Switch your blue wires around.

You have put the remote antenna wire to the remote turn on of the amplifier. The radio cuts off the power to the "power antenna" when you switch to a different mode... so your amplifier is now losing the turn on signal it requires to stay on.

Simple 2 minute fix.

Thanks for using FixYa - a FixYa rating is appreciated!!

Feb 19, 2009 | Sony XPlod CD Player w/MP3 Playback...

1 Answer

Amp powers on but sub does not come on


I would double-check your RCA's on the amplifier. You should hear a thud if you unplug them. If not they are either not hooked up or defective.

Feb 07, 2009 | Sony XM-2150GSX Car Audio Amplifier

2 Answers

Alpine subs not hitting hard


could it be as simple as bass boost??? maybe you have the subs hooked up wrong... have to have the ohms right.....hopefully this helped

Jan 26, 2009 | Pioneer GM-X962 Car Audio Amplifier

2 Answers

No audio


Hi bentley318,

You might be lucky.
Did you hook a sub and amp to this puppy?

forward to: atdlee@netzero.com

Feb 22, 2008 | Car Audio & Video

1 Answer

Trying to wire my amp to my subs


no thats not it you are lucky you havent burned it up like that. wire each speaker to its own source positive and negative, you loose power when you bridge an amp and use two speakers, its best to hook up without bridging you will get more volume that way.

Dec 18, 2007 | Infinity Reference 1211a Car Audio...

Not finding what you are looking for?
Sony XM-1252GTR Car Audio Amplifier Logo

Related Topics:

353 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

xxxxxx xxx

Level 3 Expert

4979 Answers

The Knight
The Knight

Level 3 Expert

75767 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...