Question about Car Audio & Video

1 Answer

Subwoofer in my truck will not play

My amp in my truck turns on but my subwoofer does not work. It will work every once and awhile. I hook up a new amp and that didnt fix the problem. Any ideas on what is going?

thanks

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

You may want to check your grounds, your remote and of course the battery terminal. it seems obvious, but many times small things can cause big problems.(i.e. try cleaning the battery terminals)

Posted on Dec 02, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

12in rockfordfosgates wont play bass


is it the proper amp it must be class D amp or bridgeable 2 or 4 channel. how do you have it hooked up?

Jun 12, 2012 | Rockford Fosgate RFP3212 Car Subwoofer

1 Answer

Can I hook two 12in. Subs up with a 1100w amp. Sony explode, pioneer subs


Yes....hook one up to the left channel and one up to the right.....once everything is wired up.....keep gain down on amp and turn stereo on.....turn up stereo with amp gain down to right before high end speakers start to distort......then while its playing, turn amp gain up about 1/2 way. close your trunk and hop in drivers seat....sound gd????? You might have to adjust level on amp and bass on head unit to taste.....Be careful though....pioneer subs are only rated around 300 watts continuous.....dont want to blow them...gd luck....

Mar 20, 2012 | Pioneer Car Audio & Video

1 Answer

I hooked up a Sony deck and new Kenwood 12' subwoofers and amp that came together in a box set in my 95 Jeep Grand Cherokee and when I play the radio the stock car speakers play but the subwoofers are...


their should be a blue and blue white wire on the Sony radio. cut the blue wire and then connect the car side to the blue white wire and tape off the blue wire that is on the radio side.
the blue wire only turns on when the radio is activated. the blue white wire is activated when the radio is turned on.
please rate my solution.

Jul 02, 2011 | AudioBahn Car Audio & Video

1 Answer

Why does my 6x9 amp drop or not let the sound play at all when my subs are on? it just started to happen? they worked together fine before. i turn the subs off and the 6x9 work? but when i turn the subs on...


You probably have too much hooked up for the size of your power supply which is presumably a small car battery. You either need to get:

A) New, better bigger battery.
B) Capacitor in series with battery.
C) Both of the above.

Mar 08, 2010 | Rockford Fosgate Punch Stage P212 S4 Car...

1 Answer

Why want my subwoofer play like it's supposed to? It barely plays


check your ohm load on that audiobahn sub some amps run at an bypass or ohm load and then kick off if its the sub itself is not a 2ohm stable or 4ohm stable

Mar 03, 2010 | Car Audio & Video

2 Answers

Im trying hook up a subwoofer to my reciever and its getting power to the amp, however the amp is not powering on.. do you have any idea?


did you hook up the power antenna or amp. turn On wire? make sure you should ha a wire that is to power an antenna and this is the wire that has 12 volts as soon you turn On your stereo and send 12 volts to your amp. but if you don't connect this wire, the amp will never turns On

Jan 04, 2010 | Kenwood KDC-MP438U Car CD/ MP3 Player

1 Answer

2 car subwoofers, one doesnt play


Short in amp ? try swiching wire's to speaker's around . if other speaker then work's , speaker's are both fine . if not , then short in amp , or blown channel in amp . get new one or find someone who know's more than i do about amp's

May 24, 2009 | Kicker CVR12 Car Subwoofer

1 Answer

Subwoofer wont play


change your rca's you may have a bad one that is grounding out or one of your spkr

Apr 14, 2009 | Alpine MRP-M1000 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

69 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4807 Answers

yadayada
yadayada

Level 3 Expert

70374 Answers

The Knight
The Knight

Level 3 Expert

72640 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...