Question about Maxon MCB-30 40-Channels Base CB Radio

1 Answer

No sound- audio IC amp ok, squelch circuit or squematic needed- thank you

No sound, broken squelch pot, circuit needed.

Posted by on


1 Answer

Well my friend I have same problem with some radio. Maybe you should try just to connect detector to audio amplifier and than make an squelch circuit in AF?

Posted on Aug 13, 2007


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

No sound on unit

There are any number of reasons for no sound. I will assume you're using new batteries or fully charged batteries. The simplest reason is that a wire has become disconnected from the speaker. This would make the radio sound the same on as off. To test this see if the radio has a way of turning the squelch off, sometimes a simple push button, sometimes a menu setting, sometimes a dial to adjust the squelch setting. If there is no hissing, sometime very loud so turn your volume down first, then either the audio output amp is dead or a wire to the speaker is broken or disconnected. I today's radios the audio amp is most likely a simple small IC but, it could be inside an all-in-one chip and if it's proprietary getting the chip could be a problem. If it's a simple audio chip you'll have to find a replacement or rig up another audio amp IC to work as a replacement. Let's hope for the simple broken or disconnected wire which should be easy enough to fix.

Now, if when you remove the squelch you hear the hissing but you still cannot hear transmitting from your other radio, it could be that the one transmitting is in fact NOT transmitting an not that the other radio cannot hear. You have checked that both radios can or can not hear someone else's radio right?

Assuming you do know that one radio cannot hear what the other can and make no sound other than hissing when the squelch is off the problem is either in the RF or IF sections of the radio's receiver. In general this used to be a more complex repair so let's go another easy fix by going to the very first place the RF comes in, the antenna.

Just like the audio section when a speaker wire is disconnected sometimes the wire or trace going to the bottom of the antenna can become disconnected or broken. To check this bring a good transmitting radio very close to the one that hisses but does not hear the transmitting radio and see if any place as close as you can get the two radios causes the non-hearing radio to hear the transmitting radio. If so, then look for a problem with the antenna connection.

If none of these easy things bring the problem to heel then there's probably something amiss in the RF or IF receiver sections. If the radio has one or two chips that do all the work here then see if you can get both and replace them. I haven't even taken apart my own small FRS radios to see how complex the receivers are in these so I won't go any further than that since I simply don't know your radio.

I hope that helps.

Apr 07, 2014 | Radio Communications

1 Answer

The squelch must be wide open or the whole unit powers down. Is this something I can fix by soldering? It sounds like a bad pot....

No it is NOT a bad Pot, what is happening is that with the Squelch "Open" The "Trigger" for that circuit, is getting "Swamped" by signal, and is shorting out, the MCU, senses this and tells the Power Supply it is drawing too much current, and shuts it down. You will need to troubleshoot this area. It may be a very difficult to find. First you need a service manual.
Above is a USER manual.

Apr 22, 2010 | Midland 75-785 Handheld CB Radio

1 Answer

THERE IS NO audio frm my fisher tad-9925.....the ic has just been replaced but still no is playing but cant hear anything

Its a little hard to diagnose over the computer.
I assume there is no sound from the amp EVER.
I assume you have tried other sources.
I assume the unit worked OK until the IC blew.
I assume you replaced the IC yourself?

Often, parts with the IC also fail. There maybe fuses that look just like little resistors along with the IC. They might be blown.
There are parts in the circuit to test if there are speaker problems called power resistors. These will frequently open circuit when the IC Blows - you won't be able to see anything visually.
If your stereo normally makes a 'Click' sound just before the sound comes on, and now there is no click, this indicates the repair of the IC is not complete yet - find the blown part.

Mar 22, 2010 | Fisher 9925 Shelf System

1 Answer

Wavetek 320B Multimeter Calibration procedure needed. Specifically what do the 6 internal calibritation pots specifically adjust. The circuit board has these numbers: MD-HD110 & 33-5205F & 9917....

Wavetek 320B Multimeter Calibration procedure needed. Specifically what do the 6 internal calibritation pots specifically adjust. The circuit board has these numbers: MD-HD110 & 33-5205F & 9917. The calib. pots have these numbers: R06x, R031, R021, R23, R45.

Nov 25, 2009 | Meterman Wavetek VT101 Voltage Tester;...

1 Answer

My amp fell forward and the (knob side) hit the ground. Now there is no sound, but everything lights up.

You have probably broken some of the pots. You will need to take it in to be serviced or if you have experience take the amp apart and take the circuit board out. Examine the solder side where the control pots are. Hopefully you didn't break the pots themselves and the solder joints just need to be redone. Also look for broken traces near the pots. They look like little roads which they are for electrons.If they are broken you can bridge them with short pieces of tinned wire and if the circuit board is cracked it can be Crazy glued. Look for all the broken parts and don't miss any. If the pots are broken, Take the broken ones into an electronics supplier and ask for exact replacements. If its a tube amp look for tubes that are loose in their sockets and broken tubes. Absolutely do not work on the amp with it plugged in to the wall (no power running to it) If its anything worse than that, take it in to be repaired as you need schematics, test equipment and direct replacement parts to do a proper job. Hope this helps.

Aug 27, 2009 | Music

1 Answer

TV TOSHIBA 32A40 / Vertical Problem / Horizontal line on screen

Check and replace damaged component/s at its horizontal scan output section circuit. Check the LOT (Line Output Transformer) too for damage. Replace the horizontal scan output transistor. Check the input voltage to LOT. If the voltage is absent check the feeder resistor; if any. If you wish to get some details; check the site linked here. Pull up older posts. Type in this key phrase " my service table today " in the search box at the top right of the the home page, to get gathered some pages which has the details of practical experiences of the author of that site. The search result might display about 20 Nos of related posts. Press the "All posts" at the bottom of the list, then you can select them one by one.

Jul 13, 2017 | Toshiba 32A40 32" TV

1 Answer

No sound

Hello sgaffar,

This may mean that you audio detector/amplifier IC in the TV was rendered defective by an electrical surge. Now I would check to see if the circuit was getting and sound from the audio detector (which might be in the IC also). After checking to make sure the bias circuits are ok I would suggest replacing the IC.

You will need a schematic, a multimeter, and if possible an oscilloscope to troubleshoot this problem.

I hope this helps,

Thank you,


Aug 16, 2008 | Orion1934 19" TV

1 Answer

No sound,volume bar works

Sorry I dont have a manual but it is available at If you put your ear close to the speaker, with the volume turned up, do you hear any hiss or buzzing? If you dont it could be a bad speaker,headphone jack(if there is one), or the audio output IC or ascoiatated componets. If there is a hiss, then theres a problem with the audio processor or switching IC. If your not a tech, you should not be experimenenting around inside this TV set!

Sep 01, 2006 | Emerson EWC1903 19 in. TV/VCR Combo

Not finding what you are looking for?
Maxon MCB-30 40-Channels Base CB Radio Logo

Related Topics:

200 people viewed this question

Ask a Question

Usually answered in minutes!

Top Maxon Radio Communications Experts


Level 3 Expert

3289 Answers

Level 2 Expert

500 Answers

Mike Charette

Level 3 Expert

1795 Answers

Are you a Maxon Radio Communication Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides