Question about System Power Supplies

2 Answers

Laptop does not take any mains power

Hi, my name is Mike, my advent 7103 will not except any mains power, there is no power light on. I have checked the power output from the mains adapter which i think is OK. do you think it could be the power socket on the mother board. any help would be gratefull. thanks

Posted by on

  • mikepreater Dec 09, 2008

    Hi, I have now taken apart the laptop and the jack power socket is broken. I have looked around and on ebay finding jack sockets for an Advent 7102 and 7104 and not for an 7103 is it because we got it from P C World. any way thanks for your help, and I will carry on looking. Mike

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Try clearing your CMOS. This is done by removing battery and mains power, lifting the speaker cover off and then look under the keyboard. Unscrew panel where keyboard ribbon enters, you should now see your RAM & BIOS chip. Disconnect ribbon next to BIOS chip and reconnect, that should clear your CMOS.

Posted on Feb 11, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 72 Answers

If your psu is working fine remove the battery and check the jack on the mobo with a small screw driver should have little if any play at all. its a very common problem for the solder on the mobo to become loose/break. its a cheap fix but some power jacks require some de-soldering to remove them from the mobo.

Posted on Dec 02, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi, I have Plasma TV Power Supply Board. The model of board is: LJ44-00144A PS-506-PH. The stand-by voltage 5Vstb works just fine. When I turn on the TV the Stand-by let in front of it comes blue like...


I have the same problem. As I see, here is dead sub PCB with microcontroller on board. Small PCB with 26 pins, mounted verticaly on main, big power supply board. It is not available as a spare part. You must buy complete power supply board LJ44-001444A, as I have done.

Aug 09, 2011 | Philips POWER SUPPLY (41644158) Power...

1 Answer

Advent k200 laptop does not charge new battery


Hi,

Im very sorry to hear that, please follow these simple steps for you to be able to isolate the exact problem.

1. Removed the battery.

2. Connect the laptop directly to the power outlet without using the battery just for the meantime.

3. Turn on the laptop. If the laptop is able to power on, that means that the AC adapter is working fine as well as the DC port. If the laptop is not able to turn on, it maybe the AC adapter itself or the DC port.

4. Try to use another AC adapter if possible, make sure that that AC adapter is working fine. If the laptop is still not turning on, the problem is with the DC port itself. In that case, you will need to replaced the Motherboard itself.

Hope this will help...Your response is very much appreciated...

Feb 15, 2011 | System Power Supplies

1 Answer

Advent k 200 laptop does not charge battery


Hi,

Im very sorry to hear that, please follow these simple steps for you to be able to isolate the exact problem.

1. Removed the battery.

2. Connect the laptop directly to the power outlet without using the battery just for the meantime.

3. Turn on the laptop. If the laptop is able to power on, that means that the AC adapter is working fine as well as the DC port. If the laptop is not able to turn on, it maybe the AC adapter itself or the DC port.

4. Try to use another AC adapter if possible, make sure that that AC adapter is working fine. If the laptop is still not turning on, the problem is with the DC port itself. In that case, you will need to replaced the Motherboard itself.

Hope this will help...Your response is very much appreciated...

Feb 15, 2011 | System Power Supplies

1 Answer

Packard Bell Laptop goes flat even when plugged into the mains su


Are you sure that the power adaptor is working? Does it have any light on the adapter box that informs about it's operation?
What usually happens is that the cable going from the adapter to the laptop gets crackled from repetitive bending, either at the plug, or at the box inlet. Inspect if the cable is intact, and if possible, checks if there's a required DC voltage on the plug.
Perhaps you might need a new adapter for your laptop.

Dec 07, 2009 | System Power Supplies

1 Answer

Advent 7000


The Cmos or (RTC) battery lives with the hard drive on these models. Simply turn the laptop over and release the hard drive, the battery is in the same compartment.

Sep 06, 2009 | System Power Supplies

1 Answer

Advent K200 laptop no longer charges battery


I Haven't Got a Solution, but The same has happened to my Advent K200.i Notice that you posted this 2 years ago, have you yet found a Solution? Thanks

Mar 07, 2009 | System Power Supplies

1 Answer

Computer doesn't switch on!


The troubleshooting techniques you might try is swapping them out with another monitor and keyboard. If they work then you know its the monitor and keyboard if they don't work then the motherboard is bad. The ports for the keyboard and monitor are integrated into the motherboard. So you can't fix the ports, the whole motherboard has to be replaced.

Don't forget to rate this solution with 4 stars before you log out.

Jan 31, 2009 | System Power Supplies

1 Answer

Charging Problems with FUJITSU SIEMENS AMILO PRO V2055


SOunds to me like the charge board inside the laptop has gone bad. If it will not run off of the mains supply without the battery and will not charge the battery, this is your problem. AS far as where you can get the parts or have it repaired. I am unsure of because I would need the full model and make of the laptop which didn't fit in the listing title bar above If you could send me more info, I would be glad to try to help.

Dec 30, 2008 | System Power Supplies

1 Answer

Aspire 5310 power up


sounds like maby bad fan

Jan 23, 2008 | System Power Supplies

3 Answers

Computer doesn't switch on!


More than likely nothing to do with the motherboard.

I have the Thermaltake w0049. and for the money paid is poor quality.
This model and I would guess other models by Thermaltake go belly up if subjected to voltage spikes ie lightening strikes (they are not well protected)
Remove all the leads to your motherboard and join together the single green wire (power select) to any one of the adjacent black leads (ground).
Any atx supply, if connected to mains voltage will not operate at all unless if has some form of load on it. if you do the shunt as suggested(use a paper clip) the fans should spin and you should be able to measure the voltages between ground and the relevant pins.
If you can, plug in a hdd to one of the plugs to give it some kind of load. if you do not know which voltage pins are which on your 20/24 pin connector , then search google for "atx pinout"

Dec 21, 2007 | System Power Supplies

Not finding what you are looking for?
System Power Supplies Logo

Related Topics:

217 people viewed this question

Ask a Question

Usually answered in minutes!

Top System Power Supplies Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

joecoolvette
joecoolvette

Level 3 Expert

5660 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Are you a System Power Supply Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...