Question about ATI RADEON X1650 Graphic Card

1 Answer

New ati radeon x1650 pro graphics card AGP is not recognised

Hi
Running XP
I am in the process of upgrading my graphics card.
The instructions say:
add/remove old graphics done
remove graphics card done
replace with new one done
switch on and run the drivers disk.
At this stage the monitor just gets a check box
windows does not start

Replacing my old card it boots up fine.

I hope its not the graphics card?
I am going to try loading the drivers for the new card and then change.

Any help is appreciated
thankyou
john

Posted by on

  • 3 more comments 
  • Anonymous Dec 13, 2008

    Please please help me; exactly the same problem. email me at
    tw.morgan@mac.com


    Thanks.

  • oohtoknow Jan 08, 2009

    I bought a Radeon X1650 AGP 512mb card for my Dell 4600 computer.( I have XP Pro for my OS ) I took out my Ati X800 XT 256 mb card and uninstalled the drivers. I then put in the X1650 and get nothing but a black screen. I reinstalled my X800XT and it works perfect. I did replace my power supply with an 480 watt unit because the new card requires more wattage. On my X800XT there is a small power cable or something that I have to use in order for the card to work. I noticed three prongs on the X1650 on the top does it need a cable there in order to work? Is there something else to do in order for it to work?

  • Anonymous Jan 28, 2009

    i have the same problem with the same 2 cards, my 1650pro does work as i tested it in another pc, my pc is all up to spec, but it will only boot with the x800, no matter what i do.

  • cliff25624 Jan 30, 2009

    Same prob, except ATI VTX1600XT 256 AGP, upgrading from Radeon 9550SE. After uninstalling the 9550 card, and software, I shut down the pc, switch cards, power up, and nothing.... monitor screams "no signal."

    Plenty of power, 500W supply, power plugged into card, the fan turns, mobo lights up, but no sys beep at boot like normal. I am running DFI LanParty UT nF3 250Gb w/ AMD Athlon x64 3200+.

    I've updated the chipset, flashed the bios, removed all hardware and started with the video card first, but nothing except "no signal" from the monitor.

    As soon as I put the 9550SE card back, system boots no prob. I first started this upgrade with the ATI VTX1550XT 512mb card and had the same experience, so, thinking it could be a bad card, picked up the newer ATI VTX1600XT 256mb card, but nothing comes up still. I tried out both in a friend's ASUS computer, both autoload and play video fine. We both run same version of WinXPpro.

    Guess I'll sell him a discounted video upgrade now.....don't know what else to do---

    cliffford25624@yahoo.com

  • boy10 Feb 06, 2009

    Hi!!!

    I have the same problem but my friends sad to me the i have to update the motherboard and bios to the latest version!!



    I need answer to this problem!!

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 13,433 Answers

Hey, the chat session froze, if you need my help add a comment here and Il get it.

Posted on Dec 01, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Radeon? X1650 PRO AGP


try ebay,or craigslist. you will need a credit card. or just google it and see if there is someone willing to ship to where you are. better yet..just upgrade motherboard that takes PCI express cards instead...agp is outdated but still being used by a small percentage of users with old computers

Dec 24, 2009 | ATI RADEON X1650 Graphic Card

2 Answers

Looking to upgrade my graphic card one last time. Currently running a RADEON X850 AGP 8x. Dell XPS, 3 GHz Pent4 w/875P chipset.(800MHz Bus Clock, 400MHz DDR, Hyper-threaded (2)-- I would like the highest...


I wouldnt know whether you just like ATI Graphics cards, or it was recommended for you. But I would still give you my straight forward advice, and this is : Go for NVIDIA Ge-FORCE graphics cards. Trust me, you would thank me for it later.
I didnt want to recommend a specific model for you though, because of our difference in country locations, but just try and get a high memory (like 256MB and above), NVidia Graphics card that is compatible with your system. Also check out the available slot on your system that you will use for it first before you go (So that you wont go and get an AGP slot card when you have just an open PCI Slot). I'm telling you this because I've used A LOT of graphics cards also (Over 10 years now)! and I've come to that conclusion that NVIDIA makes the best graphics card.
Hope this helps you out.
Goodluck!

Jul 15, 2009 | ATI AGP8X (128 MB) Graphic Card

1 Answer

Can i run ati radeon x1650 512 on asus k8N motherboard


Yes you can run the AGP version of the Radeon 1650 pro on your system. It is always best & recommended to upgrade memory in pairs. You could upgrade to `gb by purchasing a 1 gb kit which would be 512 x 2. That way you have a matching pair of RAM modules. As for a cpu upgrade you can go to the Asus website and see what cpu's are supported by your motherboard. Hope this helps & please remember to rate my answer. Thanks.

Jan 24, 2009 | ATI RADEON X1650 Graphic Card

1 Answer

Screen going blank for a second or two while video freezes then jumps.


If you have on board graphics try removing video card and reboot when computer rebooted turn it of and refit card and restart when restarted computer should recognize new hard ware and should find the already installed drivers if not try installing drivers again
Sometimes windows does not recognize new hardware until its refitted
had this problem with modems alot and the above method solved it

Jul 31, 2008 | ATI RADEON X1650 Graphic Card

1 Answer

ATI x1650 Pro Stops!?


the card you have is a PCI express 16X your board is for PCI express 8X. I think some cards can run at a slower speed but I believe you have the wrong card for your board

Jul 29, 2008 | ATI RADEON X1650 Graphic Card

1 Answer

Sortof mouse lag


your agp acceleration would be enabeld you can disable it by opening direct x and display just disable AGP acceleration if it is enabeld.

Jul 06, 2008 | ATI RADEON X1650 Graphic Card

1 Answer

X1650 xt agp installation problem


check and see if your pc has the recommended power requirements, a lot of the generic power supply's can't support anywhere near the posted wattage. A good power supply is very heavy with big heat sinks. Also check and make sure that the graphics card does not require any extra power connectors. A lot of the newer card require you to either plug in a pci-e power connector, molex plug, or floppy drive power cable.

Oct 02, 2007 | ATI RADEON X1650 Xt, (256 MB) Graphic...

Not finding what you are looking for?
ATI RADEON X1650 Graphic Card Logo

Related Topics:

170 people viewed this question

Ask a Question

Usually answered in minutes!

Top ATI Graphics Cards Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

joecoolvette
joecoolvette

Level 3 Expert

5660 Answers

Tony

Level 3 Expert

2598 Answers

Are you an ATI Graphics Card Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...