Question about PPI DCX-600.4 Car Audio Amplifier

1 Answer

Protect light flashing on and off, sub cuts in and out

My fuses both blew, so i changed them with the same fuses. Once i turned my car on the sub worked but it cut in and out, if it hit harder it would cut out, not as loud bass would play. Also when the sub would cut out the protect light would come on, when they'd play the power light would be on.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 160 Answers

There is a wire crossed somewhere in the system or the sub is damaged how old is the amp

Posted on Dec 01, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My protect light is flashing from red to the green power light it makes a thud noise in the sub when it flashes i have checked my ground and power it all seems to be fine does any1 have a idea on what...


You either have a short in your wiring (between the amp and the sub) or have wired the sub(s) at too low of a resistance. If for example you have wired it to 2 ohms, when the amp can only support a 4ohm minimum, the protect light would come on once you tried to turn up the volume a bit. This may happen if you have lost the wiring off one of your subs or one of the voice coils, thereby affecting the total resistance.

Mar 06, 2011 | Jensen LXA300 Car Audio Amplifier

1 Answer

I accidently put my battery in my car wrong way have changed it back after starting my car now the central lock/heater/inside light eletric windows dont work until i start the car


u blew ur fuse look the fuses under dash replace the ones u blew n u more likely blew 1/2/3-4 under dash to check them u sent back current thru live wires n grounded wires that arent suposse to have juice going thru to etc. u may even zap ur altnator the few times ive crisscrossed them i fried altnator or fuse but thats what fuses are meant for to much of one or another current to it zaps cuts off electricity going to so it dont zap it protects the main area from being fried so easily

Aug 31, 2010 | Mitsubishi Lancer Cars & Trucks

1 Answer

Was loud, now quiet, never changed any setings.


there are many possibilities here:
-one of the subs came unplugged?
-you blew one of the subs
-your amp is over-heating
-some wire has been fried in your amp
-the RCA outputs on your cd player are going bad.

May 09, 2010 | Kicker 06ZX750.1 Car Audio Amplifier

1 Answer

I have 2 kicker cvr12s and a legacy predator 2400 watt amp and when I turn the radio up the amp goes into protection once they hit a decent time. I just down graded from 15s so I know its not a power...


you prolly have the subs wired to a too low of an ohm load...thats what happend to me. i had the same subs, and a 500.1 watt amp...and they still blew up..whire EACH sub to a 4 ohm...that should work.

Nov 18, 2009 | Car Audio & Video

1 Answer

Subs cut out


although an odd thing to have happen it does sound like you blew your amp. check the fuses in it to see if you can avoid having to replace the amp and instead replace a few dollar fuse also check the fuses where you had this pluged in. hope this helps a little. if you give the amp type i may be able to help a little more

Aug 06, 2009 | Alpine MRP-M1000 Car Audio Amplifier

1 Answer

Fuse blew on my lanzar amp and now it won't turn on.


that my find is some am trying to figure out
you say you turn of deck and fuse blow that dont make sense .look at it again


Apr 01, 2009 | Kenwood KAC-7202 Car Audio Amplifier

1 Answer

Changed speakers and now red protect light stays on? why?


the sub might have a short or is blown or the ohms are different

Mar 30, 2009 | Crunch PZi1000.1 Car Audio Amplifier

2 Answers

Protect Light On Subwoofer Cuts Out


some type of over-current protect device in sub amp section gone bad..perhaps a board-mounted resettable circuit breaker or fuse has gone bad? these are hard to locate on the board for a novice.

May 30, 2007 | Verge VGA285 Car Audio Amplifier

1 Answer

Help!!!!


Check your ground wire! Relocate it to another place in the car and try to get a heavier ground wire aswell.

Apr 03, 2007 | Sony XM-2200GTX Car Audio Amplifier

5 Answers

Protect light flashing/ticking


this problem sound like you have too low of power going to your amp, test your battery and make sure its putting out enough power for at least the mininum amount of power that your amp requires, you can find that information in your manual or sometimes they post it on the amp itself. i hope this info helps

Oct 08, 2006 | Infinity Reference 1211a Car Audio...

Not finding what you are looking for?
PPI DCX-600.4 Car Audio Amplifier Logo

Related Topics:

160 people viewed this question

Ask a Question

Usually answered in minutes!

Top PPI Car Audio & Video Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

sonic boom...
sonic boom...

Level 3 Expert

1557 Answers

Jose Velazquez
Jose Velazquez

Level 2 Expert

227 Answers

Are you a PPI Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...