Question about Fusion FEW12PK Car Subwoofer

2 Answers

AMPLIFIER PROBS HEY IV HAD A FUSION SUB AND AMP FITTED TO MY PREVIOUS CAR BUT WHEN I CAME TO INSTALL IT INTO MY NEW CAR THERES NO POWER GETTING TO THE AMP AND THE WIREING KITS ALL PLUGED IN RIGHT BUT IT SEEMS LIKE THE AMP IS DEAD ANY SUGESTIONS? AND IF ANYBODY IS SELLIN ANY CHEAP AMPS COULD YOU GIV ME A CALL ON 07955967523 THANKS PPL TONY ...

Posted by on

  • Anonymous Jan 13, 2009

    Exactly the same as above

×

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 4 Answers

There are only three wires that control whether the amp powers on or not. battery, ground and remote. if any one of those are not hooked up correctly and securely then the amp will not turn on. the ground point needs to be clean to be good. and u might want to make sure none of the wires have a break in them

Posted on Jun 04, 2009

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 113 Answers

Check all power coming to your amp remote especially

Posted on Aug 09, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have got the Fusion FJL-1211 Class D Amplifier.When i turn the music up the amp switches off and back on until i reduce the volume and it plays fine.


your overloading the amp and its going into protect mode. turn the bass down on the deck or adjust the controls on the amp itself. get lower power rated sub(s) or more powerful amp since you won't be able to push the sub(s) you have with that one since the sub(s) is/are pulling too much power from the amp.

Aug 18, 2010 | Fusion Car Audio & Video

1 Answer

Subwoofer not getting max bass


try using a ohm meter and if its not making what the factory specs are its most likly it will keep loosing more and more power then stop working which is what ive had happen to me before

Mar 11, 2010 | Fusion RE-PK2120 900W Bass Pack: Amplifier...

1 Answer

I have a 2channell FE-402 fusion amp,with a fusion sub,and a set of vibe k-series 69's that have a max power of 525 watts. I tryed wiring the sub with the speakers and the speakers sound fine but the sub...


Hello jackstephens,

It's an either/or situation. The FE-402 can be set up to drive normal speakers in stereo, OR drive a sub when both channels are bridged. When the LP filter is on, it benefits the sub at the expense of the normal speakers. And with the filter off, the subs get the full range of frequencies and try as best they can to reproduce them. You might try running it with the LP on, in stereo with the 6X9's paralleled to one channel (2ohm load), and the sub connected to the other channel (?ohm load).

But my recommendation would be to use the Fusion amp the drive the 6X9's and get a dedicated monoblock for the sub.

Hope this helps.

Jun 06, 2009 | Kicker KX500.2 Car Audio Amplifier

1 Answer

Install kicker ix254 into a Land Rover Discovery


that wire probs is your rem wire hook it up and try er out john

Apr 19, 2009 | Kicker IX254 Car Audio Amplifier

1 Answer

Fusion car amp problem


The amplifier likely has shorted output transistors. Going to a higher rated could easily have caused more significant damage.


Let me know if you have any other questions.

Jul 27, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Fusion sub..


check the impedenc on amp and speakers.if speakers have lower ohm the amp cant push them also can cause damage to amp.how do you have everything wired must be specific.high level inputs,rca,.how is the radio and amp wired together,where are you getting power sup[ply from and how?
chriszambrotta@yahoo.com

Jan 09, 2008 | Fusion FEW12PK Car Subwoofer

1 Answer

Subwoofer Wont Work


If the connections are correct...?
then it doesn't sound like theres a problem with the amp.

make sure the amp is not to powerful for the sub?
eg: 1000w amp, 500w sub.

Sounds stupid but it happens.

make sure the gain / volume is not too high!

if your BMW has a totally sealed, metal boot area this doesn't help.

Dec 11, 2007 | Sony XM-2150GSX Car Audio Amplifier

1 Answer

Help me!!!! i have fitted this sub & amp but how do i fit a 2nd amp for speakers


youll need distribution blocks for second amp.this is the basic solution though.other things like wire guages,amp power and crossover settings need to be considered.

Aug 02, 2007 | Fusion FEW12PK Car Subwoofer

Not finding what you are looking for?
Fusion FEW12PK Car Subwoofer Logo

Related Topics:

253 people viewed this question

Ask a Question

Usually answered in minutes!

Top Fusion Car Audio & Video Experts

Jose Velazquez
Jose Velazquez

Level 2 Expert

229 Answers

hoyzee1

Level 2 Expert

150 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Fusion Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...