Question about Tascam US-144 Sound Card

1 Answer

Us 144 firmware not updating with Lepord

I am trying to update firmware for tascam us 144 from 1.02 to 1.12 and will not update. It keeps saying "failed... remove device" AM I doing something wrong?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Try going to Add/Remove software and removing tascam software. Then, unpack your new drivers.

Posted on Dec 29, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I just switched computers to a "Satellite" by Toshiba. On my old computer (windows XP) my TASCAM us 144 worked perfectly on a free program called WavePad. My new laptop runs Windows 7 64bit. I...


Hi there,
It sounds like it maybe an asio problem or latencey issue. You need to increase the latencey in the control panel of your tascam soundcard and this should hopefully cure you .

Jan 07, 2011 | Tascam US-144 Sound Card

1 Answer

Mac drivers


Hello there. a quick google dive pulled up thefollowing page on TASCAM's website

http://tascam.com/product/us-144/downloads/

The second catergory listed would be drivers for MacOS. From that list,the 2.00 driver, which would be the second in the list, would be the most updated driver.

I hope this helps.

Oct 22, 2010 | Tascam US-144 Sound Card

1 Answer

Computer stops responding or sound just stops on Sonar 7 with Vista. Confused whether to set Sonar to use ASIO driver or MME or the other one I can't think of now. Dan


Hi

The most compatible driver would be the one detected by Vista in Windows Update. Give that a try and see if it can find a hardware device driver for the Sonar. Ensure the Sonar is connected and on before you check for updates (Start > All Programs > Windows/Microsoft Update).

Oct 11, 2009 | Tascam US-144 Sound Card

1 Answer

Tascam us-144 no sound with Windows Vista


Often, you just need to ensure that your computer's native driver is disabled, this is a common problem with audio interfaces and windows. Once this is done, make sure that your Tascam is set as both the input as well as the output device for all audio-based programs. If this doesn't work, get an M-Audio . . .
Hope this helps!

Feb 26, 2009 | KEF Audio KIT100 System

2 Answers

Crashing every minute


I have found that the tascam 144 freezes the system evan when using other software than Live. It looks up with Cubase and other stuff evan Windows media player running sound thru the tascam. The problem is erratic and acts like an IRQ conflict and I still believe Tascam has fallen real sort of the mark by abandoning the customers. They are without a dought responsible for this problem and should step up and FIX it NOW. We are many having problems it is no fluke and I for one am discusseded with the total lack of support for what they have released as a viable and workable unit. LIES just to sell their stuff. I feel that Tascam's support should be in on this forum and start to work out the diffinative answere.

Anyone want to buy a cheap Tascam US 144 that won't do what you want. I achive move by plugging into the MIC or Line in on my system sound card than I get from the great Tascam device I bought in good faith and can't use.

THANKS FOR NOTHING TASCAM.

May 20, 2008 | Tascam US-144 Sound Card

3 Answers

Tascam us 144 sync problems with cubase le


Hey lea,

i have a similar setup (Cubase LE & Tascam 144) and each time i start up Cubase i have to make sure there is no digital input going to the tascam. once cubase is started up but no project loaded i plug in my spdif from my DAT machine and then open my project and all is fine. does that answer part of your question?

i have a different problem though, i'm trying to record my DAT tapes which are recorded at 32khz and cubase doesn't recognize that sample rate properly. it'll record no problem, and play them back fine, but exporting always creates mismatched sample rates in the exported file. sucks big time and i have got no idea on how to fix it either.

Mar 04, 2008 | Tascam US-144 Sound Card

1 Answer

Wonder if you can help with this sync issue with the sound


There is a setting in Cuabse where you can select an ASIO driver, play around with this.
I assume you are using cubase


thanks for rating

Jan 09, 2008 | Tascam US-144 Sound Card

5 Answers

Not responding


you might want to downgrade to xp because vista uses alot of ram to run it. you could also get more ram. you need about 1gb and a half to 2 gigs to run most recording softwares and interfaces. i personally use vista cause i lost my xp disk and i got 2 gbs of ram and everything runs great, but if you really want to get into recording do what im doing and save up and buy a mac.


sincerely
andy kastrinelis
owner of addex recording inc.

Oct 13, 2007 | Tascam US-144 Sound Card

Not finding what you are looking for?
Tascam US-144 Sound Card Logo

Related Topics:

246 people viewed this question

Ask a Question

Usually answered in minutes!

Top Tascam Computers & Internet Experts

Ben Armstrong

Level 2 Expert

334 Answers

Electric Dime
Electric Dime

Level 3 Expert

434 Answers

T-Comtech Repairs
T-Comtech Repairs

Level 2 Expert

417 Answers

Are you a Tascam Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...