Question about Kenmore 96532 / 96534 / 96539 Electric Kitchen Range

2 Answers

Not a 965 problem but a 956 problem...

The oven light, clock and indicator lights work but my oven and burners do not. i checked the breaker and it was on. i tripped it once and a burner came on, until i turned on another burner. now, i am back where i was... burners and oven not working. model # is 790.95662102, radiant range, free standing. any help would be appreciated. thanks scott

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: not a 965 problem but a 956 problem...

I have a kenmore gas range and whenever I turn on the broil or the oven and set it to 350 or above or below, after 2 seconds the F1 signal starts flashing, followed by a steady beep. What may be wrong?

Posted on Feb 12, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that gotĀ 5 achievements.


    An expert whose answer gotĀ voted for 20 times.


    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 76 Answers
Re: not a 965 problem but a 956 problem...

Shogan, Most likely, the problem is with the circuit breaker. It became too weak for regular load. Replace the circuit breaker and I believe it will solve the problem. back

Posted on Jan 07, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

No heat from burners or oven after relocating stove

Hi Ron - From what you have described if neither the burners nor oven turns on make sure the electrical connecting is 240V. The oven light and clock portions only required 115V. The clock and oven light working may indicate an electrical circuit breaker supplying the range is tripped or a fuse is blown. Confirm household circuit is correct and the range cord is properly wired to the terminal block.

Sep 16, 2012 | Frigidaire Gallery GLEFM397DS Electric...

1 Answer

Oven element top burners working.replaced oven element.nothing works except clock and oven light

Check your main fuses, it sounds like you are only operating on 120 volts.One of them is blown.Or if on breakers, switch stove breaker off then on again.

Mar 06, 2011 | Kenmore Kitchen Ranges

1 Answer

We recently moved, when we got to our new house we plugged in our stove. We turned on the burner and it didnt work, we tried the other three and they didnt work either.. Finally we tried the oven but there...

i would first try the breaker it sounds like you only have half the power coming to unit and the light and clock will work but the heating componets will not as they require the full 220-245 volts
it sounds very odd that everything as far as burners and elements are out but you have a clock display and light... you have lost one of the legs of power somehow...either the double breaker is not fully on and may require turning off oven breaker and resetting or half the breaker has failed... a sure way of testing would be to pull out and with a volt meter test to see that you have 220-245 volts coming to oven,,, hope this helps out repost if anymore questions...

Feb 07, 2011 | Amana Kitchen Ranges

2 Answers

Hotpoint electic stove, the burners and the oven not working

Is there any sign of life? Does the oven light come on or does the clock work? Just for kicks, go and reset the breaker - it should be a double breaker for a 220V appliance - sometimes half will throw and still leave 110v that will run the light / clock.

Jul 26, 2009 | Hotpoint RB757 Electric Kitchen Range

1 Answer

The indicator lights for the burners and the clock work but the burners and the oven do not work. This is a whirlpool range.

Check the recepticle it is pluged into for 230-240 volts on the outer inlets. You may also have to connect your nuetral wire to the ground wire in your breaker panel and to the unit. The problem is from the power supply. Let me know if you have any questions.

Apr 11, 2009 | Kitchen Ranges

1 Answer

Electric range burners and oven element just stopped working. Burner indicator light came on and oven temp setting displays correctly. Clock went into set mode automatically, though. Burner came back on...

check the power behind the stove, the outlet for 220 volts, i just fix one with the same problem, it was getting 110 volts but not the 220 volts. so there was nothing wrong with the stove but with the power source.when the stove indicator lights work and the clock, it means that only 110 volts are coming to the stove.

Dec 10, 2008 | GE JBP24 QuickClean Electric Kitchen Range

1 Answer

The indicator lights and clock on our glass top slide in stove work, but the burners and oven do not heat

From what you are describing, the power to your stove is incorrect. The diagram indicates the voltages that should be present at the receptacle, I suspect one of the 110 volt legs is bad at the receptacle or circuit breaker. The clock operates on the good 110 volt leg. The burners need both 120 volt legs to be good because the burners and oven need 220 volts to work.


Jul 11, 2008 | Frigidaire Kitchen Ranges

Not finding what you are looking for?
Kenmore 96532 / 96534 / 96539 Electric Kitchen Range Logo

205 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Kitchen Ranges Experts

Dan Webster
Dan Webster

Level 3 Expert

8147 Answers

Barrett Palumbo
Barrett Palumbo

Level 2 Expert

1772 Answers

Cindy Wells

Level 3 Expert

4721 Answers

Are you a Kenmore Kitchen Range Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides