Question about Onkyo TX-V940 Receiver

1 Answer

Onkyo Tx-v940 Receiver/Amplifier Protection Mode

In trying new speakers, amp went into protection mode and now front display will not work. Main Power works. Anything advice to take it out of protection mode.

Posted by on

  • 3 more comments 
  • rick grundy May 04, 2008

    onkyo amp tx-v940 stuck in protect mode

  • celtic_paul Nov 24, 2008

    turn on the receiver and goes right to "Protect" mode - tried new fuse - heard that you could press a combination of buttons on the front to bypass this (ex. tuner and CD at the same time etc..)

  • flink007 Feb 15, 2009

    i have the same problem. my tx-sv727. i want to know where is the CI of the audio amplifier


  • crest5850 Feb 18, 2009

    After hookup to a speakercraft speaker selector, will only light up in standby and no power otherwise - Onkyo TX V940 owned since '95

  • Anonymous Apr 20, 2009

    TX-V940 KEEPS BLOWING 6.3 AMP FUSE NO PROTECT MODE DISPLAY JUST BLANK SCREEN

    ??????????????

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Onkyo Master
  • 1,550 Answers

Audio amplifier IC's damaged you need to change it.Good luck

Posted on Jun 11, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Onkyo tx manuals


http://www.manualslib.com/manual/302311/Onkyo-Tx-Sv414.html#product-TX-V940

Jul 25, 2014 | Onkyo TX-V940 Receiver

1 Answer

Receiver standby sound


If the receiver goes into protect mode with no speakers connected, you will have to troubleshoot the receiver itself to find and correct the problem.

Mar 07, 2014 | Onkyo Audio Players & Recorders

1 Answer

Protect mode. will it work again? how can "i" fix


This indicates a load on the system, turn receiver off, remove speaker wires from the back of the unit. Now power up and turn volume right down, if the word protect stays off, there is a short in the wires or one of the speakers. But if the word protect comes on, "with wires and speakers dis-connected, it means there is a short in one or more of the audio outputs in the receiver. If you are handy using a digital meter then you may be able to track the shorts down, and replace the parts to get it up and running, also if you can solder then it will make the job easier.

Feb 08, 2011 | Onkyo TX-V940 Receiver

1 Answer

Amp always entering protection mode/ on and off it self


Hello, I am sorry about your issue. I f the receiver does not stay on with nothing connected it would need to be serviced. Thank you, Onkyo USA

May 26, 2017 | Onkyo TX-DS787 Receiver

1 Answer

No sound coming out of speakers something is wrong with the receiver


check if it goes to protection mode on power on. see to it that speaker selector switch is set.

Is your speakers connected properly?

Is your music source ok?

Do you hear a click after you switch on the power? the click indicates that the time-on delay transfers the amps output to the speakers which prevents thumps going out to the speakers.

Once it goes to protection mode you need to have it serviced. This is due to a fault in one of the amps and that it protect the speakers from further damage.

Aug 17, 2009 | Onkyo TX-SR502 Receiver

1 Answer

Tx-v940


If you don't got any sound the audio amplifier IC is damaged you gotta change it.Good luck

Jun 11, 2008 | Onkyo TX-V940 Receiver

2 Answers

Protection mode


you have to verify your connection cause if you are a short circuit in your different output or input the protection mode is on. it's an internal security
first disconnect all your output speakers, and restart your amplifier if the protection mode is on again try to disconnect all your input device and restart your amplifier, the protection mode should be off, so after connect one device after one to check who makes your protection mode on
;)

Mar 31, 2008 | Onkyo TX-SR502 Receiver

1 Answer

Reads PROTECT on the display of my Onkyo TX-SV525 ???


HOWDY,         NOW YOU COULD TRY THIS ONE: POWER THE RECEIVER UP , THEN PUSH&HOLD !THE VIDEO 1 BUTTON, THEN TURN THE PIECE IN THE OFF (STANDBY MODE ) ,IT WILL SAY "CLEAR SO IT SHOULD BE BACK TO IT,S ORIGINAL FACTORY SPECIFICATION,S.

SUCCES !                              AMSTERDAMCOWBOY-HOLLAND-NOW FLORIDA! 4-EVER

Apr 28, 2007 | Onkyo TX-SV525 Receiver

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

1,422 people viewed this question

Ask a Question

Usually answered in minutes!

Top Onkyo Audio Players & Recorders Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

 Grubhead
Grubhead

Level 3 Expert

5515 Answers

The Knight
The Knight

Level 3 Expert

75774 Answers

Are you an Onkyo Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...