Question about Canon MV430i MC Mini DV Digital Camcorder

Open Question

Canon MV430i switching itself off

During recording/playback/fast forward/rewind in camera/playback modes, the Canon MV430i switches itself off and then switches itself on again. Manual troubleshooting suggests either in record/pause mode for more than 5 minutes (this is not the case) OR battery pack is exhausted (this is not the case as it also happens when AC adaptor is used without battery). Have tried several tapes to see if tape/cassette may be causing problem, but same effect with all tapes. Regards Baffled

Posted by on


6 Suggested Answers

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

  • 883 Answers

SOURCE: Eating Tape when rewinding in vcr mode

look for a tiny pinhole and insert a pin while powered up to reset the device. if no-go, then the take-up reel needs attention...needs possibly a new or well-cleaned-with-alcohol-swab rubber belt

Posted on May 27, 2007

  • 1 Answer

SOURCE: Canon zr300 ejects tapes

Hi guys,

Thank you very much for this solution posting. Really it worked. I was about to buy another one instead of fixing the problem. Because you know how the pain is, to send it factory and getting it repaired.

Once again Thank you.

Posted on Jun 26, 2008

SOURCE: Canon Elura 100 won't eject tape

I have been having the similar problem. Try switching the power to off and then eject the tape in the off position. My finally ejected.

Posted on Jul 08, 2008

  • 1223 Answers

SOURCE: During playback, only seee a blue screen.

kindly rate me if ui have helped u !

i hope ur problem gets solved

Posted on Apr 24, 2009

  • 5 Answers

SOURCE: "Remove the cassette"

I only got the problem when the tape was bad. Usually the ribbon got folded, or was very wrinkly looking. Eventually I found out the drive was bad, and had to have it replaced.

Posted on May 08, 2010

Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Why does my Optimus Model 163 MovieCorder 8 show "tape" blinking continuously and I cannot record or rewind or fast forward the tape.

This sounds like a fault caused by a mode switch problem. The mode switch tells the electronic section what position the VCR mechanical section is in. The mode switch itself can go faulty, or it can be sent to the wrong position if the VCR mechanism is damaged. For example the mode switch might be in eject mode, when the mechanism is in play mode.
It's unlikely that a reset would cure the problem. But you could try powering down the video by pulling the plug and leaving for some time. Maybe even a day.
Mode switch replacement is only possible if you have either done this before or have the service manual. Since most mode switches are never ever set up in the eject mode position. The VCR mechanism will also need to be checked to make certain it hasn't been damaged before resetting or replacement of the mode switch.

Mar 20, 2015 | Televison & Video

2 Answers

Sony Handycam CCD-TRV37 8mm Analog... 2 Problems, maybe more unknown at this time:

This does require disassembly to remedy the problem. There are various possible fixes. The most prevelant I have seen is cold solder connections of the board connector for the fpc cable from the top operation switch block ass'y. All you need is someone who can handle this task, like a professional. The controls that you are experiencing problems with are all linked with one cable and connector. One bad solder joint can cause serveral operation faults. Good Luck, magic seadog

Aug 18, 2007 | Sony Handycam CCD-TRV37 Camcorder

1 Answer

Why will the Pioneer RT 707 not work in playback mode?

No it is the same motor for both functions. Just check does the record/play switch operate or move when you operate the record function? I have a hunch that is the problem it may also be that the switch contacts are dirty or worn.Try to play a recording you made on another machine if it does sound and play on the other machine then the problem can only be this switch. Some more upstairs decks do have separate amplifiers for play and record .Nakamichi. Studer Revox Tandberg Uher and the such comes to mind These are those machines offering "Off tape" recording monitor. Then it will sport three heads and not only two I hope this gives clues where to start looking for problems

Sep 01, 2014 | Audio Players & Recorders

1 Answer

I have a sony TC-660 reel to reel player, it had been in great condition, and i love using it. All of a sudden however, the reels will ONLY move in one direction (clockwise for the left, and counter...

In order to maintain tape control and tension the reels always pull lightly in opposite directions during PLAY mode. The capstan moves the tape in the desired direction at a precise speed. If the capstan doesn't engage the tape BETWEEN itself and the pinch roller you'll get the reels battling over control of the tape. Check the tape routing.

May 25, 2010 | Quantegy 456 Reel-To-Reel Recording Tape

1 Answer

Samsung Camcorder eating tapes

the roller inside your camcorder might have dust dirt. try to use camcorder's tape cleaner to clean it.

Jun 28, 2009 | Samsung SC-L906 Camcorder

3 Answers

I have a canon SD 580. When I playback the video clip it's always in fast forward mode and I can't play it normal speed. Any help?

Make sure you are shooting your movies in "Standard" mode. If you have the mode set to something else, especially "Time Lapse", the playback may not match 'natural' motion.

In any case, you can control the speed of the playback. When you first enter the movie playback mode, there should be a movie control bar along the bottom of the LCD. Instead of the "Play" button, select the "Slow Motion Playback" button (single arrow with single bar next to the normal Play button), and control the speed with the left or right arrows on the multi-controller.

May 02, 2008 | Cameras

1 Answer

No playback on DCR-TRV103

In playback mode the lCD displays the battery time, hi8 symbol and the tape counter. all the functions work the tape will play, rewind, fast forward. The screen stays blank on playback and the tape counter stays at 0:00:00 eventhough I can see the tape turning. I also hooke the camera to my tv and I got no picture.

Dec 23, 2007 | Sony Handycam DCR-TRV103 Digital Camcorder

1 Answer

Will not playback tapes

a sony cleaning cassette may clear the gunk from your friend ' s possibly ? bad tapes ( do not rewind it - or the gunk will be redeposited ) ; if still no video , get an estimate to have your heads and guides cleaned . . . professionally ;

Jul 02, 2007 | Sony Handycam CCDTRV118 Camcorder

1 Answer

Video will not rewind to beginning of tape.

the clutch gear needs to be replaced . you can order the part go by brand and model easy to replace around 30.00 dls .

Jun 20, 2007 | Toshiba V643 S-VHS VCR

Not finding what you are looking for?
Canon MV430i MC Mini DV Digital Camcorder Logo

Related Topics:

39 people viewed this question

Ask a Question

Usually answered in minutes!

Top Canon Video Cameras Experts

Pieter Vleeshouwers
Pieter Vleeshouwers

Level 3 Expert

1870 Answers


Level 3 Expert

77939 Answers

Steve Mason

Level 2 Expert

305 Answers

Are you a Canon Video Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides