Question about Air-O-Swiss 7133 Humidifier

5 Answers

Air-o-swiss 7135 humidifier not misting

I have purchased a new 7135, soaked the cartridge for 24 hours as instructed, removed a tablespoon of the granules from the cartridge, but still sitting on 30% humidity and no mist? Can you please help?

Posted by on

  • Anonymous Jan 25, 2009

    I followed the instructions, even cleaned it with EZ Cal after it kept doing nothing.
    AIr comes out but no mist. It worked for a week!


×

5 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Ours has done the same thing after only 2 weeks. From article research, it appears that this occurs to everyone after cleaning it with the EZ Cal that is recommended. From looking at our unit and figuring out how it works, it appears as though the Ultrasonic Vibration membrane has stopped working. This particular piece is responsible for vibrating the water and making water mist particles which are blown out with the air. We will be calling the manufacturer on Monday to register a complaint and request a replacement unit.

Posted on Jan 30, 2010

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

I have had a similar problem with an AOS 7135 - usually after changing the granules in the demineraliazation cartridge. I tried it all, including removing some of the granules) and nothing worked.

My problem seemed to be stemming from the fact that the plunger on the bottom of the demineralization cartridge was not functioning properly. I think the plunger allows water to flow from the reservoir into the base. Mine was a problem of overtightening the cartridge after filling it (over and over again) so that the plunger did not meet the base properly any more.

My solution was to simply leave the cartridge about 1/2 turn looser than it was before. I now carry the freshly filled reservoir tank back to the base upsidedown to prevent any leaking onto the floor during transit.

Posted on Feb 09, 2010

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

I read this and thought "Hurrah! My solution at last!" But I tried it -- unscrewed the cartridge at least a 1/2 turn looser -- and still no dice. No mist, that is. Any ideas out there? This unit used to work just fine, but I put it away in storage for about 9 months and now it fails to produce mist (but appears to work otherwise). Darn it!

Posted on May 18, 2010

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 45 Answers

Spoke to rep and the Air less swiss tower type units have a round bronze oscillator at bottom of unit where tank goes surrounded by a white seal/heatsink. Newer ones are SStl. If your unit has cracks in the white seal not a good thing. Clean bronze carefully with 50% baking soda (lightly). and then rinse and try again.

Posted on Jan 11, 2012

  • 1 more comment 
  • Dennis Aanderud Jan 12, 2012

    Since the baking soda solution or the vinegar solution did not solve the problem I removed the bottom panel and the bronze oscillator assembly only to find that the circuit board was partially corroded/rusted. The seal apparently leaked enough to compromise and damage the circuit card. I am sure a rep will call me any moment with an offer to send me a new replacement assembly. The white seal should have never cracked in the first place.
    The circuit card should have at least had a conformal coating. Poor workmanship Air o Swiss!

  • Dennis Aanderud Jan 12, 2012

    I realize my previous comments were directed at a different model but possible the issues are the same. Sorry for any confusion.

  • Barbara Passman
    Barbara Passman Mar 06, 2016

    My oscillator membrane seal looks perfect. I opened my base and pleased all was clean inside, nothing gunked up or cracked. The flywheel turns (can get dunked and stop), circuit board looked good, nothing seemed disconnected,water damaged etc. I have replaced filter granules. If my unit does not work tomorrow night I guess I need to outlay for a new unit

×

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Just an FYI, We fixed ours by flipping over the water level sensor. My wife must have installed it upside down when she cleaned it. The sensor is a little circular float attached to the base. It is just screwed in.

Posted on Dec 10, 2015

  • Barbara Passman
    Barbara Passman Mar 06, 2016

    Describe the location of the sensor. Blue water tank base or the white base on which the water tank sits

  • Nate H
    Nate H Apr 21, 2016

    It was on the white base. You will see a little disk with a screw through it.

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

WATER LEVEL FLOAT DEVICE PREVENTS UNIT FROM TURNING ON,EVEN THOUGH WATER TANK IS FULL. REMOVED SOME FILTER MATERIAL WITH NO EFFECT. FLOAT IS FREE WITH NO RESTRICTION.


These hints are from the air o swiss webpage.
Q: No mist / unit is not working / empty indicator keeps flashing
A: Fill up the water tank. Check if water is flowing through the demineralization cartridge (attached to the water tank cap). If the water tank is full but there is only little water in the base it indicates that the water is now flowing through the demineralization cartridge.

  • Wait for 15 minutes to allow the mist to come out of the unit.
  • If the unit is not working and the empty light is not flashing you might have set the desired humidity too low and the current humidity level in the room is higher. That is why the unit switches off automatically.
  • If the empty indicator continues flashing and the tank is full, water is not flowing through the cartridge. Exchange the cartridge or the granules in the cartridge after 2-3 months, in areas with hard water exchange the cartridge after 1 -2 months. However, the demineralization cartridge and or the granules must be exchanged at the latest after 6 months or the unit does not reach its full performance.
If the granules are new, see the following instructions:

  • Make sure the cartridge and/or granules were soaked for 24 hours, water takes longer to filter through dry granules in cartridge and into the base. Next, remove 2 tablespoons of granules from the cartridge, and throw them away. Too many granules in the cartridge it does not allow water to flow from the tank to the base.
If your issue is with the float and not the mister, then you have to make sure the float is tripping the micro switch that turns the machine on. Some units the filter will not allow the float to hit the switch if the filter is not installed correctly. If everything is in correctly and the float is tripping the switch, then the micro switch must be faulty.

Apr 04, 2011 | Swiss AIR-O-SWISS Ultrasonic Humidifier -...

3 Answers

No more steam. Want advice on disassembly.


There is info on the FAQs from Air-o-Swiss:
http://www.airoswiss.net/service/faq.aspx#35


Q: No mist / unit is not working / empty indicator keeps flashing
A: Fill up the water tank. Check if water is flowing through the demineralization cartridge (attached to the water tank cap). If the water tank is full but there is only little water in the base it indicates that the water is now flowing through the demineralization cartridge.

  • Wait for 15 minutes to allow the mist to come out of the unit.
  • If the unit is not working and the empty light is not flashing you might have set the desired humidity too low and the current humidity level in the room is higher. That is why the unit switches off automatically.
  • If the empty indicator continues flashing and the tank is full, water is not flowing through the cartridge. Exchange the cartridge or the granules in the cartridge after 2-3 months, in areas with hard water exchange the cartridge after 1 -2 months. However, the demineralization cartridge and or the granules must be exchanged at the latest after 6 months or the unit does not reach its full performance.
If the granules are new, see the following instructions:

  • Make sure the cartridge and/or granules were soaked for 24 hours, water takes longer to filter through dry granules in cartridge and into the base. Next, remove 2 tablespoons of granules from the cartridge, and throw them away. Too many granules in the cartridge it does not allow water to flow from the tank to the base.

back to top arrow.gif


Q: Unit is running intermittently.
A: How long has it been since the contents of the cartridge were replaced? If 2-3 months have passed, it is time to replace the contents of the cartridge. However the demineralization cartridge and or the granules must be exchanged at the latest after 6 months or the unit ceases operating at its full performance. If the contents of the cartridge were just replaced there are probably too many granules in the cartridge. Remove 2 tablespoons of granules from the cartridge.

Feb 20, 2010 | Air-O-Swiss U7142 Humidifier

1 Answer

Air-o-swiss membrane coating coming off, is this a


no its not a problem if you dont mind how the system looks...otherwise just get some oil paint and re-coat it

Jan 31, 2010 | Swiss Air-O- 7135 Warm Mist Antimicrobial...

1 Answer

I have air-o-swiss humidifier. Recently I cleaned it. Its motor appears to be working after that but the mist is not coming out. Any clues?


When you cleaned it , did you remove water level sensor? If so did you put it back in upside down? The sensor is a plastic cylinder that is held down by a screw and washer.. If you have it in upside down, the empty water red light will be lit,,, if you unscrew the sensor and flip it .. it should start to work again..

Dec 05, 2009 | Swiss Air-O- 7135 Warm Mist Antimicrobial...

1 Answer

I need an online owners manual for AIR-O-SWISS 7135 Ultrasonic Humidifer. Thankyou


Here is the general download page for all AOS manuals and quick set-up guides.

Here is the direct link to the AOS 7135 manual in pdf format.

Oct 01, 2009 | Swiss AIR-O-SWISS Ultrasonic Humidifier -...

1 Answer

Air o swiss 7135 turns on but no mist comes out...


would you describe your problem in a little more detail please?

Jan 17, 2009 | Swiss AIR-O-SWISS Ultrasonic Humidifier -...

1 Answer

Noisy ultrasonic humidifire


The grey circle (diaphram) needs replacing. Try Maplin electronics.

Mar 31, 2007 | Swiss Air-O- 7135 Warm Mist Antimicrobial...

1 Answer

The humidifier doesn't make enough vapor


Soak it with vinegar for several hours then use a soft nylon bristled brush to scrape off the minerlized crust and rinse. You probably need to replace the silver stick & mineralization cartridge more often.

Jan 04, 2007 | Air-O-Swiss 7133 Humidifier

Not finding what you are looking for?
Air-O-Swiss 7133 Humidifier Logo

Related Topics:

6,900 people viewed this question

Ask a Question

Usually answered in minutes!

Top Air-O-Swiss Humidifiers Experts

paulcarew

Level 3 Expert

1863 Answers

Mack Baxter

Level 3 Expert

379 Answers

Ken Thomas

Level 2 Expert

118 Answers

Are you an Air-O-Swiss Humidifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...