Question about Crown XTi 2000 2-Channel Amplifier

2 Answers

Amp cuts off

I have a crown xti2000 when you first turn it on it works fine after afew mintues of use it cuts off. it dosent shut the power off the lightblinks

Posted by on

  • Anonymous Mar 28, 2009

    on off 

  • chetocheto Mar 28, 2009

    when i turn on the xti2000 it show in and out the power 

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Ok, i have the same proble, what i found until now is the fan is not starting and that allows heat increase,

i conect direct to a 24vcd power supply,
i hope you have the same prblem

Posted on Mar 11, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,992 Answers

The amplifier is going into protection. This may be caused by problems with speakers or wiring, or there may be internal problems in the amplifier. Start by connecting a known good speaker with a few feet of wire, and see if it runs without shutting down. If so, check the wiring and speakers. If the problem continues, the amp should be serviced.

Posted on Nov 23, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My crown vid 4000 amplifier doesn't work.after switching power it goes off after maybe 2 sec.no speaker and input during powering. Same thing happen even there is speaker and input connected


Check speaker to power bank protection circuit. The circuit is faulty indicating to the power amp that speakers are disconnected that shuts down the amp to protect the unit

Mar 10, 2015 | Crown Audio Players & Recorders

1 Answer

No sound from speakers or headphones fan not working gets warm


The Crown CE series of amplifiers have a 7 stage fan that runs as needed when the amplifier is working. Generally the fan is running at some point most all of the time, and you should be able to hear it ramp up as you push the amp to deliver more power. If the amplifier fan is not functioning, you may be in a thermal shut off mode that protect the amp from overheating by shutting off any signal. My advise would be to contact the manufacturer, and have it serviced.

Apr 05, 2014 | Crown CE2000 2-Channel Amplifier

1 Answer

Crowm micro-tech 2400 goes straight to protect upon start


Ok,

Lets get this straight, you are saying that a CROWN MICRO-TECH2400 power amplifier show the two front red lights when you turn it on? Because it supposed to do that if everything is fine, when you turn your amp on and one of the lights or both don't turn on then you have a serious issue with this great amp, keep me informed in case you need further help.

Nov 07, 2013 | Crown Audio Players & Recorders

1 Answer

CROWN CE1000- slips into fault immediately after connection


if ur output power amp is defective u will have that problem - meaning the moment u connect load across it it will go into circuit protection to limit/stop excessive output current. make sure the speaker terminals are connected to +/- output terminals. in bridge mode use only channel 1 and that too with 4 ohms speaker only otherwise amp will clip. considering all connections are okay if it still clips when speaker is connected, u have a faulty power amp section. this the way ur amp is designed

Apr 05, 2010 | Crown CE1000 2-Channel Amplifier

2 Answers

I have a crown k2 amp that I think Have have fed bad signal, a result of having a pet chew through some of the input and output cables. Immediately, it showed erratic warning light displays, and the audio...


Check the gain control in front panel. The material use inside them is pretty thin and weak, an could break loose when hurting during manipulation.
Spider Guy

Mar 13, 2010 | Crown CE2000 2-Channel Amplifier

1 Answer

I have two xti 2000 amp running with electrovoice speaker 600w


This is most likely to be a heat issue where the amps overheat and shut themselves off then cool down and turn back on. Please check that the amps have proper ventilation and that any air ducts are clean.

Feb 26, 2009 | Crown XTi 2000 2-Channel Amplifier

1 Answer

Crown xti2000 cuts off


The protection circuit is most likely shutting down the amp because of heat. When the amp shuts down, does it feel hot? If not, then further investigation into the protection circuit will be necessary. This is not a problem that is likely to be diagnosed remotely as measurements will be required internally once the amp has stopped working. Check the sepaker wires for shorts that will cause the amp to work extra hard (generating extra heat). Other than that, you will need a servicer to diagnose further.

Dan

Nov 23, 2008 | Crown XTi 2000 2-Channel Amplifier

Not finding what you are looking for?
Crown XTi 2000 2-Channel Amplifier Logo

387 people viewed this question

Ask a Question

Usually answered in minutes!

Top Crown Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

4678 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

69767 Answers

Are you a Crown Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...