Question about Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

3 Answers

Won't turn on

I used my Windtunnel to vacuum broken window glass on my minivan. The unit turned off properly but wouldn't restart. I removed small glass from the air passage and shook the machine to verify that all glass had been removed. I then checked the filters whick look good. I also removed the handle and checked the on-off internal button and could detect no problem. Advice?

Posted by on

  • khfritz Nov 21, 2008

    Would like to narrow this down or consider the probability of either problem. It sounds like a repair shop problem in which case I want them started in the right direction. Thanks.

×

3 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 276 Answers

Taking it to the repair shop is much advisable as it looks like a power wire problem and needs to be checked whether the machine is able to output the required power to get ON.

Posted on Nov 21, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 6,966 Answers

Hi,

Initially, you would need a continuity tester (DVM or VOM) to check most (if not all) of the checkpoints in the diagnosis. Continuity of the AC cord down to the switch, the switch itself and the wire that leads to the motor. This page may shed additional information as to the location of the electrical parts that would need checking up.

Just a start, do postback how things turned up or should you need additional information. Good luck and Thank you for using FixYa.

Posted on Nov 21, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 3,422 Answers

HI,

If the low voltage wires are hooked up to it, then you probably have a stuck relay inside the cannister. It could also be the switch in the hose handle.

Posted on Nov 21, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Hoover Dual V Windtunnel has suction but the brushes are not turning. How can I troubleshoot?


Take the lower plate off of the unit and check the belt for breakage. also, if it isn't broken, are there any obstructions between the belt and housing?

Jan 29, 2010 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

The Rotary brushes do not rotate/spin when the unit is turned on.


check the belt it may be stretched or broken...also carpet and hair or other debris around the bruches may have it in a bind,,..remove the 2 screws holding the bottom on to check this

Jan 03, 2010 | Hoover V2 U8140-900 WindTunnel Upright...

2 Answers

Carpet/Floor Switch problem on Hoover WindTunnel Vacuum


Well, you have to deal with it, you have to play with this electrical things if you want to fix this problems.

The good news is, the sources of the problems is the switch already broken.The first things before you do anything is, find this switch on the market first to changes the old ones.Then, remove the power cord from the outlet of course.

After have it, then you must open the old switch, and remove it from the unit by cutting the cables using cutter/ pliers or anything.But remember, you must remember the locations of each cable that been cut, you can use Camera Cellphone to make sure of it if you like.

Then put the cables back together with the new switch, after all done, clean all the mess and try operate it.

Hope it works!!!

Dec 09, 2009 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Brush on underside not working, please help.


Turn the unit over and remove the four screws that retain the bottom plate over the agitator. Remove the bottom plate and see if the belt of off or broken. The belt part number is printed on the data label for the cleaner.

Oct 02, 2009 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Model U6436 broken shift lever


George,
Removal is slow and requires removal of the bottom plate, agitator cavity, the hose connection, and the hood. I can sne a few pictures if you get stumped.

Sep 09, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

2 Answers

Burning smell coming from vacuum


use a penny to turn the 2 screws on top a quater turn then fold down the vacuum and lift up the cover and you will have access to the belt. Clean the small hepa filter with soapy water. their may be 2 of them. The cannnister filters need to be shaken but not washed. Good luck.

Apr 09, 2009 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

I HAVE A HOOVER SAVVY AND THE BRUSHS WON'T TURN.


there is a small circuit board right above the motor on the base ,look and see if there are any burn marks or discoloration.if the headlight isn't working either then thats the problem .the circuit board.you can get it through all-type vacuum and janitorial 314-275-8006 supply.$18.49.there is a belt that runs up the center from the roller to the geart on the motor

Apr 01, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Decreased hose suction with Windtunnel


There are very few things left to check. First verify that the filter is installed properly, in the dirt cup. second check to make sure the dirt cup lid is on and secure. Did you use water on the round dirt cup filter? if you have you will need to replace it. To verify this remove the round filter and re-install the dirt cup on the vac. do not vacuum the carpet, just turn it on to check for proper suction. and then turn it off.

Your problem has nothing to do with it in the upright position. once turned on you will always have suction, either to the floor or when hose is removed from foot for accessories.

Dec 03, 2008 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Hoover Bagless Windtunnel Vacuum roller does not turn.


you have a broken belt. look on bottom of vac remove screws until cover comes of. you will find broken belt inside. take that with you to get a replacement

Nov 19, 2008 | Vacuums

2 Answers

Off/on switch does not work


The on/off switch in Hoover Windtunnel upright vacuum cleaners is operated by a lever in the handle assembly.  remove the two screws on the back ovf the vacuum and see if the lever has bypassed the switch assembly.  if so, re-assembly should fix the problem.  It is also possible that the switch activating lever has broken.  If so, replace the activating lever.

Oct 24, 2007 | Hoover U6437-900 / U6439-900 Windtunnel...

Not finding what you are looking for?
Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum Logo

Related Topics:

14 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18299 Answers

Roger Potts

Level 3 Expert

694 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...